VST Connect & VST Connect SE - Solution Thread

Post general topics related to Cubase 7 and Cubase Artist 7 here.

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Fri Aug 16, 2013 8:29 am

DiSky wrote:Thanks musicullum,
But after many hours trying to get this work, I still get this "Connection Error" - Server not responding.

Also, Cubase does not connect to Steinberg Hub, do you think this could be related ?

This is without firewall, and internet works fine.

Do you think that trying to have a UPNP server working with iTunes could be something to try ?

Thanks !

DiSky

Hi DiSky,
pls don't confuse UDP with UPnP. VST Connect doesn't deal with UPnP at all. And The Hub problems might well be related.
UDP is the protocol which VSTC uses to connect to the connection server when you engage the login button. In general, this is no different than sending a search request to Google, because like Google, the server is wide open to welcome your request. This is quite different from me sending a request to your computer, because your firewall is not expecting this and not williing to let anything in just like that.
When Google replies, your firewall has remembered that you sent a request recently and therefor let the reply in.
The only difference with VST Connect is that your browser uses the htp protocol while VSTC uses UDP. This works close to 100% on almost every connection because there is nothing bad with UDP at all. But firewalls can be set to block UDP packets either on the outgoing request (less likely) or the incoming messages.
Unfortunately (in this case) there are often 2 firewalls to look at: the one of your router, and the "software" firewall in your computer (like Windows Firewall). Either of those may have been set to generally block UDP, probably on the incoming side. Except for when there is actually no internet connection, or the connection server is down (pretty much never), connecting to the connection server has never failed.
Things are quite more difficult when you want to establish a peer-to-peer connection as you would do later on. But that has nothing to do with your problem. Bottom line is: the connection server always welcomes requests and replies reliably, so it is very likely that one of your firewalls is set to block UDP traffic (probably incoming). If you tell me exactly what you have I may try to figure out wher to look.
One final thought...whichever software firewall you use, why not switch it off and see if the message vanishes and you get a key. When you have all other applications closed nothing bad can happen. Then at least you'd know whether that was the culprit.
So when you say you switched off your firewall, which one is that? And how to you tell "internet works fine", do you tell by googling or how else?
Hope that helps,
musi
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby DiSky » Fri Aug 16, 2013 10:20 am

Hey,
Thank you so much for you reply :)

About Firewall : I use Comodo and I did quit before starting Cubase.

About the router firewall, I'm based in France and I have the "neufbox"

I went to the "NAT" section to open UDP :
UDP Plage 51111-51113


Is there a way to check if UDP ports 51111 to 51113 are open ?

I'll continue investigate, from what you're saying, the router is probably still blocking this.

Thanks again and have a great day !

DiSky
Attachments
ScreenShot048.jpg
This should open the UDP port... ?
(15.66 KiB) Not downloaded yet
Windows7 64
Cubase 7
EastWest Orchestra
DiSky
New Member
 
Posts: 3
Joined: Thu Jul 04, 2013 5:31 pm
Has thanked: 0 time
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Sat Aug 17, 2013 7:45 am

DiSky wrote:Hey,
Thank you so much for you reply :)

About Firewall : I use Comodo and I did quit before starting Cubase.

About the router firewall, I'm based in France and I have the "neufbox"

That would be the first thing I would look at. Disable it for a test.
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby axemanchris » Mon Aug 19, 2013 3:39 am

I'd love to be able to get this to work.

I'm using the vst connect template that is included with C7. (ver 7.0.4)

I have allowed Cubase Connect in both Windows Firewall (Win7) and in my router to allow UDP 51111-51113.

The remote user (ver. 1.3.0) keeps getting an error message that says:

" studio key ##### ##### is not logged in"

I can see the key that was generated at my end, with the word "logout" beside it, so I know I am logged in.

Any suggestions?

Does the port forwarding on UDP 51111-13 need to be done on *both* ends?

Thanks!
Chris
Rode K2
Shure SM7b
Studio Projects C4 mkII (matched pair)
Sennheiser MD421
Sennheiser e602
Sennheiser e835
Shure SM57 (x2)
Shure SM58
Steinberg MR816X
Cubase 7
axemanchris
New Member
 
Posts: 20
Joined: Fri Dec 24, 2010 6:21 am
Has thanked: 2 times
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Mon Aug 19, 2013 7:22 pm

axemanchris wrote:I'd love to be able to get this to work.

I'm using the vst connect template that is included with C7. (ver 7.0.4)

I have allowed Cubase Connect in both Windows Firewall (Win7) and in my router to allow UDP 51111-51113.

The remote user (ver. 1.3.0) keeps getting an error message that says:

" studio key ##### ##### is not logged in"



I swear the Performer mistyped the key, or has been told the wrong numbers.
When the engineer clicks the login button and gets a key displayed, he is definitely logged in, and that message says that the Performer was also successfully registered, but no match could be found for the key. Unless maybe there was more than 30 minutes between obtaining and submitting the key.

I can see the key that was generated at my end, with the word "logout" beside it, so I know I am logged in.

Any suggestions?

Does the port forwarding on UDP 51111-13 need to be done on *both* ends?


Usually ports don't need to be opened at all anymore. For connecting to the primary connection server which provides the key numbers, there should also be no need. If this fails (message "server not responding"), one of the firewalls on the engineer's ( Cubase) end is too restrictive and all ports should be opened there. When the peer to peer connection doesn't work it's hard to say which side fails, then both can try to forward ports. But again, if you don't mess around and just use the router and OS firewalls and don't change too much there or apply additional firewall programs, it should really work "out of the box".
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby axemanchris » Tue Aug 20, 2013 6:34 pm

Argh! Thanks for your reply, musicullum!

I tried again with him and got the same result: " studio key ##### ##### is not logged in". I gave him the code one number at a time and had him enter it manually. I had him make sure there were no leading or trailing spaces in the key or the username, that there were no capitals in the username, and that there WAS a space between the two sets of numbers in the key. Same thing. FWIW, he is using Win XP.

However...

I tried with another friend, and it connected just like it should - right out of the text book. This seems to rule out anything that I might be doing wrong. He is using Win7.

However...

I had an issue with the second friend. Once connected, he could hear my talk-back mic, and any audio I played through Cubase. I could see his video stream. I could NOT hear him.

It may be relevant that, after being connected for about 30 seconds, I got a recurring error message that said, "continuous sample rate mismatch: please change either your sample rate to 16000 or the artists' rate to yours."

Now, when I went to the settings in Cubase Connect, we were both at 128kbps. I changed us both to 320 kbps. No difference. The project sample rate was (and is always) at the default setting of 44.1 khz. I couldn't find any mechanism to change his sample rate to anything other than the stock list of 128, 192, 256, etc. kbps.

Can you make anything of this?

Thanks!

Chris
Rode K2
Shure SM7b
Studio Projects C4 mkII (matched pair)
Sennheiser MD421
Sennheiser e602
Sennheiser e835
Shure SM57 (x2)
Shure SM58
Steinberg MR816X
Cubase 7
axemanchris
New Member
 
Posts: 20
Joined: Fri Dec 24, 2010 6:21 am
Has thanked: 2 times
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby axemanchris » Tue Aug 20, 2013 11:49 pm

Update:

Just tried with my mom, running Mac OS Leopard 10.6.8 and she got the "studio key ##### ##### is not logged in" message. I regenerated another key, and still the same result.

Just thinking out loud... does it matter that we have Facebook or Google+ Hangouts running while we try this? This is how I am communicating the username and keys to the people on the other end.

Update again...

Just tried with my sister running Win7. Originally got a "server not responding" error. Tried again with a new key and got the "studio key ##### ##### is not logged in" message.

We both restarted our computers and tried again. After a couple of tries with me getting the "server not responding" error, I got a code and sent it to her. She got the "server not responding" error. I gave her another new code, and she still got the "server not responding" error.

I did check my speed with my provider using their own on-line test. My download speed is 6.25 Mbps, and my upload speed is 0.82 Mbps.

Any thoughts?

Thanks.

Chris
Rode K2
Shure SM7b
Studio Projects C4 mkII (matched pair)
Sennheiser MD421
Sennheiser e602
Sennheiser e835
Shure SM57 (x2)
Shure SM58
Steinberg MR816X
Cubase 7
axemanchris
New Member
 
Posts: 20
Joined: Fri Dec 24, 2010 6:21 am
Has thanked: 2 times
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Fri Aug 23, 2013 9:09 am

axemanchris wrote:Update:

Just tried with my mom, running Mac OS Leopard 10.6.8 and she got the "studio key ##### ##### is not logged in" message. I regenerated another key, and still the same result.

Just thinking out loud... does it matter that we have Facebook or Google+ Hangouts running while we try this? This is how I am communicating the username and keys to the people on the other end.

Update again...

Just tried with my sister running Win7. Originally got a "server not responding" error. Tried again with a new key and got the "studio key ##### ##### is not logged in" message.

We both restarted our computers and tried again. After a couple of tries with me getting the "server not responding" error, I got a code and sent it to her. She got the "server not responding" error. I gave her another new code, and she still got the "server not responding" error.

I did check my speed with my provider using their own on-line test. My download speed is 6.25 Mbps, and my upload speed is 0.82 Mbps.

Any thoughts?

Thanks.

Chris

I have looked up the logs of aug 19th.
There are many cases of "key xxx not found" reports (which result in "...is not logged in").
The reason in all of these cases is, that the Cubase side has been unregistered before the Performer submitted the (correct) key.
This is not good and we'd like to find out what happens.
My first guess is to agree to your suspicion that other Internet related applications and/or connections might get in the way. For instance Skype is also using UDP and under unlikely but possible circumstances it might use the same ports.
But what concerns me is that you have not reported that you were logged out when you returned to Cubase after switching to your browser or whatever. The logs say you were unregistered between obtaining the key, and the Performer submitting it.
So either we need more information, or you to try to not use other programs and see if that works, or drop me a PM and maybe we can sort this out together.
We are not allowed to store any personal information and we don't, but if you try next time, you may also give us a key where it fails, so we can identify it in the logs. A new key is generated with each login, so there is no harm.
We'll sort this out like we sorted out every problem so far, thanks for your patience!
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby axemanchris » Fri Aug 23, 2013 4:50 pm

Hi Musicullum;

Thanks for checking the logs and for your feedback. Interesting.

Here is how a typical session attempt would work on my end:

1. I start Cubase.
2. I initiate a conversation in either Google+ Hangouts or Facebook to facilitate my helper on the other end download and install the software, and to give them instructions on logging in, giving them a key, etc.
3. End user attempts login and fails.
4. I generate another code at my end and send it through either G+ or FB.
etc.

In any case, there is only a few moments between the time I generate the code and when the user tries logging in.

It may be worth noting, though, that the VST Connect plugin on my end - even with two monitors - is never visible when I open up the other browser window (Chrome) to send them a key. However, once I send them the key, the VST Connect plugin doesn't show that I've been logged off. By all appearances, I am still on line with the Steinberg server.

Which, I guess begs the question, how do other people communicate the key to a partner, perhaps on the other side of the planet, other than by telephone or text message? Doesn't something like FB chat or Google+ chat seem to be a natural go-to for most people?

FWIW, my sessions with Ali and my Sister were done with Facebook chat, so the log is saved. I have itemized these attempts (Eastern Standard Time at my end, near Toronto, Canada) below. My friend Dave (who was the one who actually got in, but got the sample rate errors) and my mom (whose attempts look just like the ones below) were attempted via Google+ chat. Unfortunately, those did not get logged. In any case, maybe these logs from my end could be helpful.

My friend, Ali, running XP. (second day of trying) - Aug 19

monday 21:17 - ali - 16782 38953 - studio key ##### ##### is not logged in
monday 21:22 - ali - 29790 7667 - studio key not logged in


My sister, Deanna, running Win 7. - Aug 20

tuesday 21:32 - deanna - 31718 43126 - Server not responding (deanna side)
tuesday 21:37 - deanna - 31845 77898 - 'Studio with Key 31845 77898 is not logged in!'
tuesday 21:40 *deanna and I both shut down and restarted computers*
tuesday 21:49 - no code generated on my side - server not responding (my side)
tuesday 21:49 - deanna - 69265 63873 - Server not responding (deanna side)
tuesday 21:50 - deanna - 82223 53080 - Server not responding again (82223 53080)

^ for the latest one, I didn’t clarify whether it was, in fact, a “server not responding” error if that was just how she put it, but was really a “not logged” in error. I find it unlikely that a server not responding error would generate the key back on her end, would it?

Maybe I'll try with my sister or my mom again and send them the code via text message.

Thanks for your ongoing assistance. It is appreciated.

Chris
Rode K2
Shure SM7b
Studio Projects C4 mkII (matched pair)
Sennheiser MD421
Sennheiser e602
Sennheiser e835
Shure SM57 (x2)
Shure SM58
Steinberg MR816X
Cubase 7
axemanchris
New Member
 
Posts: 20
Joined: Fri Dec 24, 2010 6:21 am
Has thanked: 2 times
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby axemanchris » Fri Aug 23, 2013 7:07 pm

Update:

Just tried with my mom again, running snow leopard 10.6.8. I had neither G+ nor FB (actually, no internet at all running) and gave her the key over the phone.

2:19pm - "studio 70478 65554 not logged in" error.

Chris
Rode K2
Shure SM7b
Studio Projects C4 mkII (matched pair)
Sennheiser MD421
Sennheiser e602
Sennheiser e835
Shure SM57 (x2)
Shure SM58
Steinberg MR816X
Cubase 7
axemanchris
New Member
 
Posts: 20
Joined: Fri Dec 24, 2010 6:21 am
Has thanked: 2 times
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Sat Aug 24, 2013 12:53 pm

axemanchris wrote:Update:

Just tried with my mom again, running snow leopard 10.6.8. I had neither G+ nor FB (actually, no internet at all running) and gave her the key over the phone.

2:19pm - "studio 70478 65554 not logged in" error.

Chris

Quick reply (more later, I'll drop you a PM):

- I can't find "deanna" at all in any logs (was that the name she put in the name box?), which would simply mean she can't connect to the connection server at all. That would indicate a general internet problem or a firewall issue on her end.

- I can see why Ali fails, here is an excerpt of the log (Aug 19th):

2013-08-19 03:54 register: A.., magic: 2851 31410
2013-08-19 03:55 unregister A..
2013-08-19 03:55 register: A.., magic: 89127 77618
2013-08-19 03:55 startSession: 2851 31410 not found

("magic" stands for the key, obviously. And don't worry about the timestamps, different country.)

That means Ali logged in and got given the key 28...., then he logged out, logged in again and got 89..., then somebody tried to connect using the "old" key 28...
Maybe he double-clicked the login button? Have to check if that can happen...but then he should have seen the new key.

As said, I'll drop you a PM later, maybe we can try a connection if that was ok with you?

Thanks for staying tuned!
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby ramrod » Sat Aug 24, 2013 5:05 pm

Great thread.. I actually read all 161 posts :). Musicullum you are a trooper..great to see such involvement from the developer side..bravo!

Moving toward my first VST connect session in a few days..western US to southern France. I set up a session, as far as I could from my end, using the template, which is great BTW. I created an audio channel for the performer's guide track and output it to the "To Performer" group channel. I'm not clear after reading some posts if I should "send" the guide track to the "To Performer" group via a send slot...or if the "send" references in the posts just mean to route the guide material to the "to performer" channel in the usual, output way.

Secondly...when I play the guide material..the glitches and dropouts are terrible. Like if you've ever inserted a 32 bit plug into Cubase 64 bit...that bad!! Thoughts?

Thanks in advance.
Cubase 7.0.4, MR816x, Penryn quad core Q9400. 2.66 Ghz, 12GB RAM, Windows 7 64 pro, Intel P45 chipset motherboard.
ramrod
New Member
 
Posts: 15
Joined: Sat Mar 05, 2011 4:37 pm
Has thanked: 0 time
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Mon Aug 26, 2013 10:13 am

ramrod wrote:Great thread.. I actually read all 161 posts :). Musicullum you are a trooper..great to see such involvement from the developer side..bravo!

Moving toward my first VST connect session in a few days..western US to southern France. I set up a session, as far as I could from my end, using the template, which is great BTW. I created an audio channel for the performer's guide track and output it to the "To Performer" group channel. I'm not clear after reading some posts if I should "send" the guide track to the "To Performer" group via a send slot...or if the "send" references in the posts just mean to route the guide material to the "to performer" channel in the usual, output way.


It makes much more sense to me to use send levels as you would in a room-to-room recording situation. Only then can one provide an individual mix to the Performer. Routing to the "To Performer" group channel directly (multi-output routing) will work too, but without the benefit of individual levels.

ramrod wrote:Secondly...when I play the guide material..the glitches and dropouts are terrible. Like if you've ever inserted a 32 bit plug into Cubase 64 bit...that bad!! Thoughts?

Thanks in advance.

If the dropouts only appear when playback or record is engaged, you should raise the "Remote Latency" setting in the settings page. Usually around one second is ok, if you have to go much higher for seamless operation your connection isn't really good (high "ping").
If the dropouts appear all the time (even in "chat mode", that is, when no playback is active), then you should lower the upstream bitrates for audio and video transmission. If you can't go lower and still have problems, make sure you use a solid ethernet cable to your router instead of WiFi, and if that doesn't help either, you may consider to change your IP provider :-)
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Mon Aug 26, 2013 11:30 am

axemanchris wrote:Update:

Just tried with my mom again, running snow leopard 10.6.8. I had neither G+ nor FB (actually, no internet at all running) and gave her the key over the phone.

2:19pm - "studio 70478 65554 not logged in" error.

Chris


same thing:

2013-08-23 20:01 register: p.., magic: 70478 65554
2013-08-23 20:04 unregister p..
2013-08-23 20:04 register: p.., magic: 84482 36578
2013-08-23 20:04 startSession: 70478 65554 not found

so p.. registered, got key 70..., unregistered, got key 84..., and then somebody (your mum) tried to connect with the old and meanwhile invalid key 70...
Are you sure the key that was displayed in the VSTC plugin was 70... when you told her the key (well, most probably) but most of all, that you didn't do anything thereafter? mean to say, when your mum got the "not logged in" error, the 70... key was still displayed in the plugin, and that not magically 84... had appeared meanwhile??
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby work4fun » Fri Sep 13, 2013 10:35 am

Hi there,

first thx for this good thread. happy to see that a developer is helpin users in such a untiring way.
unfortunately i'm still havin connection problems... still love c7 the most, workin with steinberg since cubasis vst ;)

no matter where i try, it´s always the same problem. my artist is havin perfect video and sound quality while on my side i get nothin clean - voice is comin in binary trash, video is stuttering or totaly collapsing.
artist can hear the playback, but when i record, i have the same digital trash on the recording track.

i did...
- open the ports 51111-51113 (not necessary anymore i read)
- both sides connected with cable, wifi is disabled
- tried with disabeling ASIO Guard
- upload is at least 1Mbit/s on both sides
- both sides closed every other programm
- tried with disabeling firewall (computer and router)
- video and audio upstream to lowest quality (without that nothinng works)
- turned up asio buffering up to 1024 samples
and more i don´t remember...

i used different internet connections/locations because i thought it´s my router. The problem is everywhere the same.
- What about Samplerate and Bit settings? are they synced automaticly? do they have to be set the same?
- What about network remotes like steinberg ski remote, splashtop streamer (desktop streamer), ProCutX remote?
i turned them off but maybe they´re workin in the background
- what about soundcards? do both have to connect one because of asio drivers or is the internal with coreasio2 enough?
(12ms latency on 384samples) - we felt no difference

i'm workin on a 2012 macbook pro, OS X 10.8.4, i5 2,5GHz, 16GB Ram, soundcard is roland ua-55 via usb or allen&heath zed16R via firewire.

hope to get this great feature runnin! would be much less travelling (costs) because of technical problems in the artists studio setup.

thx already
work4fun
New Member
 
Posts: 1
Joined: Fri Sep 13, 2013 9:43 am
Has thanked: 0 time
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Sat Sep 14, 2013 12:16 pm

work4fun wrote:
no matter where i try, it´s always the same problem. my artist is havin perfect video and sound quality while on my side i get nothin clean - voice is comin in binary trash, video is stuttering or totaly collapsing.
artist can hear the playback, but when i record, i have the same digital trash on the recording track.


This looks very much like there is a problem on the Performer side in his or her upstream quality.
Did you check the Performer settings to have the audio and video upstream rates set not too high?
If your partner really has 1 MBit upstream provided by his/her IP (Internet Provider)? Many people confuse this with the downstream rate. Usually, when you browse or get emails etc, upstream rate is of no concern, so this can be easily overlooked.
So: the sum of audio and video upstream as set in the Performer settings must not be more than approx 80% of the upstream rate provided.
Try setting the Performers' cam to "<no video>", and audio upstream rate to 128 kBit. Still distorted sound?


- i did...

You are successfully connected, so none of the port/firewall business applies. Means, it works perfectly. This has nothing to do with connection quality, a connection is either established or not. If it is, all router/firewall/port forwarding issues are solved already.

- upload is at least 1Mbit/s on both sides

I don't know what you mean by that. If you set Performer upstream to 1 MBit for video, for instance, it comes to no surprise that there are problems...?

- video and audio upstream to lowest quality (without that nothinng works)

ah, ok, sorry, so you did it right (lowest quality => lowest bitrate)
But then it should really work...

- i used different internet connections/locations because i thought it´s my router.

The problem is not on your end, but on the Performer side.

- What about Samplerate and Bit settings? are they synced automaticly? do they have to be set the same?

Unless you get a message, samplerate is automatically set to Cubases's rate on the Performer app.

Again, you were trying loads of things on your side but the problem is really on the Performer.

Hope that helps - have to go...
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby lukasbrooklyn » Wed Sep 18, 2013 10:32 pm

We'd appreciate any tips or help regarding the occasional glitch in the audio stream while recording via the VST Connect SE.

The Performer in our case is running a Win 7 machine, while the recordist is on a Mac; both users are running an RME interface, although we did try the Mac's built-in sound card as well, to no difference.

We set up all the right I/O's and connect fine; we've set the audio upstream to mono, set the lowest quality for video at the recordist's end (the Performer does not have a web cam), and have gone through various audio quality settings, including the lowest and the highest. In each case, there have been digital drop outs in the recorded signal.

The recordist noted that while in the pre-record mode, glitches weren't apparent; it is after punching-in that they would sometimes occur. And, quite unusually, it seemed a higher signal modulation seemed to increase the drop-out rate (ie., when the performer uttered a louder sound, a glitch -- not signal clipping, that is -- would be likely to occur).

Thank you for any help!
c6, c7.5, pc, w7, klein&hummel o300, adam s2x, lavry DA, SSL duende, RME HDSP, audeze lcd-2, avantone mixcubes, slate digital, ...
lukasbrooklyn
Member
 
Posts: 527
Joined: Mon Nov 12, 2012 8:51 pm
Has thanked: 22 times
Been thanked: 40 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Thu Sep 19, 2013 3:11 pm

lukasbrooklyn wrote:We'd appreciate any tips or help regarding the occasional glitch in the audio stream while recording via the VST Connect SE.

The recordist noted that while in the pre-record mode, glitches weren't apparent; it is after punching-in that they would sometimes occur. And, quite unusually, it seemed a higher signal modulation seemed to increase the drop-out rate (ie., when the performer uttered a louder sound, a glitch -- not signal clipping, that is -- would be likely to occur).

If there is silence or lower signal, glitches may just not be as appearent maybe.
The only other thing that comes to mind is cpu Performance on the engineer/recordist side, because the audio decoder has a harder time when a signal is present. OTOH, if audio quality is fine when in chat mode, it means the problem appears to be due to a combination of decoding and recording (writing to disk maybe).
My first test would be to try to write to a different medium, like an external HD or for testing maybe even a USB stick. Also you may want to monitor Cubase's performance display to see if there are peaks on cpu or disk end.
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby Freddie H » Fri Sep 20, 2013 9:17 pm

Cubase 7.0.6 and VST Connect 1.3.0 performance issue.


Its to early to say if it just random. Internet speed is on full on both ends.
I don't know but somehow it seem to degrade the performance after the update?

Now its not even workable? :?
Communication are really bad between the "Studio" and "Performer". Work flawless before the Cubase 7.0.6 update? :roll:


Best Regards
Freddie
-Highly developed spirits often encounter resistance from mediocre minds. -It really matters!
User avatar
Freddie H
Member
 
Posts: 353
Joined: Fri Apr 08, 2011 7:59 am
Has thanked: 48 times
Been thanked: 62 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Sat Sep 21, 2013 11:09 am

Freddie H wrote:Cubase 7.0.6 and VST Connect 1.3.0 performance issue.


Its to early to say if it just random. Internet speed is on full on both ends.
I don't know but somehow it seem to degrade the performance after the update?

Now its not even workable? :?
Communication are really bad between the "Studio" and "Performer". Work flawless before the Cubase 7.0.6 update? :roll:


Best Regards
Freddie

There hasn't been a change in VST Connect to the Cubase 7.0.6 update afaik, so it must be something else, some performance issue with another plugin maybe? If audio is disrupted it doesn't help to have the best connection...
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby vaptorx » Sun Sep 22, 2013 3:43 pm

Hi There

Is there is any way to connect 2x cubases together via this software ? So for example
I can collab witch my friend playng vst midi and he will record this and when he play back i can record ?
vaptorx
New Member
 
Posts: 12
Joined: Tue Sep 03, 2013 2:45 pm
Has thanked: 0 time
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Mon Sep 23, 2013 12:39 pm

vaptorx wrote:Hi There

Is there is any way to connect 2x cubases together via this software ? So for example
I can collab witch my friend playng vst midi and he will record this and when he play back i can record ?

Always open for ideas...and working on some, so stay tuned :-)
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby vaptorx » Tue Sep 24, 2013 11:45 pm

I will Thanks
vaptorx
New Member
 
Posts: 12
Joined: Tue Sep 03, 2013 2:45 pm
Has thanked: 0 time
Been thanked: 0 time

Re: VST Connect & VST Connect SE - Solution Thread

Postby musicullum » Thu Sep 26, 2013 5:36 pm

musicullum wrote:
axemanchris wrote:Update:

Just tried with my mom again, running snow leopard 10.6.8. I had neither G+ nor FB (actually, no internet at all running) and gave her the key over the phone.

2:19pm - "studio 70478 65554 not logged in" error.

Chris


same thing:

2013-08-23 20:01 register: p.., magic: 70478 65554
2013-08-23 20:04 unregister p..
2013-08-23 20:04 register: p.., magic: 84482 36578
2013-08-23 20:04 startSession: 70478 65554 not found

so p.. registered, got key 70..., unregistered, got key 84..., and then somebody (your mum) tried to connect with the old and meanwhile invalid key 70...
Are you sure the key that was displayed in the VSTC plugin was 70... when you told her the key (well, most probably) but most of all, that you didn't do anything thereafter? mean to say, when your mum got the "not logged in" error, the 70... key was still displayed in the plugin, and that not magically 84... had appeared meanwhile??


Found out one strange thing today by accident: if both sides use the same name (like "John"), it will fail because the server disconnects the "first John" when the "second John" tries to log in. Nobody ever appears to have tested this...you'll never know.
musi
User avatar
musicullum
Junior Member
 
Posts: 131
Joined: Wed Dec 05, 2012 7:31 pm
Has thanked: 1 time
Been thanked: 7 times

Re: VST Connect & VST Connect SE - Solution Thread

Postby Derek » Tue Oct 08, 2013 11:18 pm

i know a solution thread is not really the place for this because i cant offer any solutions (because it works flawlessly for me), but i still wanted to say this out loud, and be it only so that people who still have connection issues know that its worth getting those fixed:

VST connect is to me probably the best audio innovation of the past 10 years. ive now used it on a regular basis for quite a while, and its just downright amazing. you gain so much from this on a personal and a musical level, its just great, great, great.

- for me, its so stable and troublefree that i am now up and ready to record in an instant. i have a couple of long term clients, and with them, i can basically go out of a skype call and into cubase recording mode within 20 seconds (the time it takes to open the template). it took a while taking care of general gain structuring and levelling on all sides, it took a while until they all had a combo of mic/interface/headphone they liked, but now that its all there, its just the best thing since sliced bread. and with many younger clients who all have some sort of setup anyway, its also pretty much "could you please install this little tool and enter this number, then we can start" "huh???" "no, im serious". i recorded people in their kitchen, on their balcony, from a neighbour city to the other end of the country.

- i save HUGE amounts of time that i would otherwise have spent away from home, away from the kids, doing vocal recording sessions for many days in a row for whatever particular LP i would be producing at the moment. the extra time this gave me with my family alone is worth more than pretty much all workflow and audio feature business that was introduced say in the last 4 major updates combined. i mean, how often does it happen that a *feature in an audio daw* actually ends up improving your overall life quality! this is no joke. people with kids will know what i mean, this is highest priority stuff, and im not talking about some audio daw blablabla priority but "overall-life-priority".

- what used to be a stressful event in the calendar (vocal recording in studio XY! you got X days! better get *flower* of awesome vocal tracks done in that time!) is now the equivalent of casual skype meetings in the evening. with everybody pretty much sitting in their private comfort zones.

- and its not just a question of convenience - that very setting i just described also leads to way better vocal takes. its all so relaxed and pressure free, you can just hear it. you get takes that are natural in a way where youd have to work your ass of to get the same thing in the classic "studio! vocal tracking time!" environment.

thank you charlie steinberg and whoever else was responsible for this. thank you so very much.

that is all :-)
Derek
Junior Member
 
Posts: 69
Joined: Mon Dec 20, 2010 1:23 pm
Has thanked: 0 time
Been thanked: 0 time

PreviousNext

Return to General

Who is online

Users browsing this forum: Hippo, necromorbus, Vetalexy and 5 guests