Control Transport with Midi Controller

Post general topics related to Cubase 7, Cubase Artist 7 and Cubase Elements 7 here.

Control Transport with Midi Controller

Postby Balletryne » Mon Apr 07, 2014 5:46 pm

Hi all!

I have a Novation SL-MK2 25 Midi Controller to use with Cubase 7.5. For some time I have been using Automap, but I have reached a point where I had to admit my workflow was disrupted by having Automap. Dont want to take that discussion in this thread, I have made up my mind. Never going back.

Anyway, when I try to control Cubase transport without using automap it seems that I always have to press two times to start and press two times to stop the transporter. This goes also to rewind, forward and record.
After reading the manual I know there are some flags to put use when making the settings in Generic Remote. First off, I use "Receive" for handling the incoming midi from my controller. Then I use "Push Button" and "Toggle". Have tried combinations with only "Receive" and "Push Button" and "Receive" and "Toggle" without any luck.

Is there a way to set this up so I onky have to press the "Play" button once instead of two times to make it start playing? (same goes for record, stop, rewind etc...)

Hope one of you can help me with this issue. About to loose my mind here...
Laptop:
Asus. Windows 7 64 bit. Home Premium SP1.
Intel Core i7 2.3GHz. 8GB RAM
Steinberg UR22

DAW:
Cubase 7 Version 7.5.10(64 bit)

Midi Controller:
Novation Impulse 49
Balletryne
New Member
 
Posts: 26
Joined: Wed Feb 13, 2013 11:18 am
Has thanked: 3 times
Been thanked: 0 time

Re: Control Transport with Midi Controller

Postby SteveInChicago » Mon Apr 07, 2014 5:55 pm

Start by leaving the flags on the defaults, as they are initially in the Generic Remote.

Does it work?

P.S. Lose is spelled l-o-s-e, not l-o-o-s-e (I'm on a campaign to tighten up loose spelling on the internet ;) )
Cubase Pro 8 | Mac 10.10.1 | 8gb | UR44
User avatar
SteveInChicago
External Moderator
 
Posts: 5006
Joined: Wed Dec 15, 2010 7:42 pm
Location: Chicago, IL USA
Has thanked: 128 times
Been thanked: 338 times

Re: Control Transport with Midi Controller

Postby Balletryne » Mon Apr 07, 2014 6:16 pm

Hi and thanks for your reply!

No it didnt help. If I have pressed play once(or any other transport controllers) it seems like that distinct function/button is being activated and whenever I press the same button once more it reacts instantly. But if I have already pressed play and if I want to stop it, then I have to press the stop button twice in order to make it actually stop..
Laptop:
Asus. Windows 7 64 bit. Home Premium SP1.
Intel Core i7 2.3GHz. 8GB RAM
Steinberg UR22

DAW:
Cubase 7 Version 7.5.10(64 bit)

Midi Controller:
Novation Impulse 49
Balletryne
New Member
 
Posts: 26
Joined: Wed Feb 13, 2013 11:18 am
Has thanked: 3 times
Been thanked: 0 time

Re: Control Transport with Midi Controller

Postby SteveInChicago » Mon Apr 07, 2014 6:29 pm

Since I can't reproduce that I would suppose the issue is with the keyboard.

You didn't explicitly give any other details, so if you want to I can have another look, or maybe someone with a Novation controller will pipe up.
Cubase Pro 8 | Mac 10.10.1 | 8gb | UR44
User avatar
SteveInChicago
External Moderator
 
Posts: 5006
Joined: Wed Dec 15, 2010 7:42 pm
Location: Chicago, IL USA
Has thanked: 128 times
Been thanked: 338 times

Re: Control Transport with Midi Controller

Postby johngar » Mon Apr 07, 2014 6:35 pm

I am not familiar with the SL MK2 but many Transport controls on MIDI keyboards are set to MMC by default, this requires a much easier setup ,(no programming needed).
Check to see if your transport controls use MMC if so:
You set this up in Project Synchronization look for it under the Transport section, not in the Device Setup - Generic Remote.
PC | Nuendo 6.5 64bit | Cubase 7.5 64bit| i7920 | Windows 7 Pro 64bit | 12gb ram | Blackmagic Intensity Pro | NVIDIA GeForce GTX550Ti | RME9632 | Euphonix MC Control -Mix - Transport | Genelec |

MacBook Pro 2.2Ghz i7 | OS X 10.9 | MOTU 828MKII |

elfxi.com
User avatar
johngar
Member
 
Posts: 575
Joined: Wed Dec 15, 2010 5:46 pm
Has thanked: 7 times
Been thanked: 14 times

Re: Control Transport with Midi Controller

Postby Balletryne » Mon Apr 07, 2014 7:11 pm

Hi,
Here's a screenshot of my device setup.


Johngar, looked into it but didnt really understand that synchronization. Will try to read the manual, but hopefully this should be able to do in the device setup? Have been getting really tired of not being able to have a decent setup now, thats one of the reasons why I've skipped the automap(conflict with quick controls, non-standard automapping etc).

Can anyone see any errors in my setup?
Attachments
Device_Setup.JPG
(124.24 KiB) Not downloaded yet
Laptop:
Asus. Windows 7 64 bit. Home Premium SP1.
Intel Core i7 2.3GHz. 8GB RAM
Steinberg UR22

DAW:
Cubase 7 Version 7.5.10(64 bit)

Midi Controller:
Novation Impulse 49
Balletryne
New Member
 
Posts: 26
Joined: Wed Feb 13, 2013 11:18 am
Has thanked: 3 times
Been thanked: 0 time

Re: Control Transport with Midi Controller

Postby SteveInChicago » Mon Apr 07, 2014 7:19 pm

If the SL was sending MMC commands, which are sysex messages, it would be odd if it resulted in anything.

Did you use the Learn function to set the upper pane stuff?

My next troubleshooting steps would be to

- edit what the controller is sending
- put it all on the same channel and use different CC#s for each command.
Cubase Pro 8 | Mac 10.10.1 | 8gb | UR44
User avatar
SteveInChicago
External Moderator
 
Posts: 5006
Joined: Wed Dec 15, 2010 7:42 pm
Location: Chicago, IL USA
Has thanked: 128 times
Been thanked: 338 times

Re: Control Transport with Midi Controller

Postby johngar » Mon Apr 07, 2014 7:46 pm

Just for the heck of it, it is easy to do a quick test, Project Synchronization it is real easy.
You already have your midi controller setup in Device setup, so just open Project synchronization settings and select your controller from the drop down menu, if it works, then your done.
See my settings here:
Attachments
MMC setup.JPG
MMC setup
(46.47 KiB) Not downloaded yet
PC | Nuendo 6.5 64bit | Cubase 7.5 64bit| i7920 | Windows 7 Pro 64bit | 12gb ram | Blackmagic Intensity Pro | NVIDIA GeForce GTX550Ti | RME9632 | Euphonix MC Control -Mix - Transport | Genelec |

MacBook Pro 2.2Ghz i7 | OS X 10.9 | MOTU 828MKII |

elfxi.com
User avatar
johngar
Member
 
Posts: 575
Joined: Wed Dec 15, 2010 5:46 pm
Has thanked: 7 times
Been thanked: 14 times

Re: Control Transport with Midi Controller

Postby SteveInChicago » Mon Apr 07, 2014 8:03 pm

To add to what John said, if your keyboard transport can be set to send MMC instead of CC#s, it's a good way to go.
Cubase Pro 8 | Mac 10.10.1 | 8gb | UR44
User avatar
SteveInChicago
External Moderator
 
Posts: 5006
Joined: Wed Dec 15, 2010 7:42 pm
Location: Chicago, IL USA
Has thanked: 128 times
Been thanked: 338 times

Re: Control Transport with Midi Controller

Postby Balletryne » Mon Apr 07, 2014 10:02 pm

Guys, it worked out well! I had to do the MMC-setup and it works like a charm:)

Thanks to both of you!
Laptop:
Asus. Windows 7 64 bit. Home Premium SP1.
Intel Core i7 2.3GHz. 8GB RAM
Steinberg UR22

DAW:
Cubase 7 Version 7.5.10(64 bit)

Midi Controller:
Novation Impulse 49
Balletryne
New Member
 
Posts: 26
Joined: Wed Feb 13, 2013 11:18 am
Has thanked: 3 times
Been thanked: 0 time

Re: Control Transport with Midi Controller

Postby SteveInChicago » Mon Apr 07, 2014 10:10 pm

Great.
Cubase Pro 8 | Mac 10.10.1 | 8gb | UR44
User avatar
SteveInChicago
External Moderator
 
Posts: 5006
Joined: Wed Dec 15, 2010 7:42 pm
Location: Chicago, IL USA
Has thanked: 128 times
Been thanked: 338 times

Re: Control Transport with Midi Controller

Postby johngar » Mon Apr 07, 2014 10:42 pm

Yes, that's great, glad it worked.
PC | Nuendo 6.5 64bit | Cubase 7.5 64bit| i7920 | Windows 7 Pro 64bit | 12gb ram | Blackmagic Intensity Pro | NVIDIA GeForce GTX550Ti | RME9632 | Euphonix MC Control -Mix - Transport | Genelec |

MacBook Pro 2.2Ghz i7 | OS X 10.9 | MOTU 828MKII |

elfxi.com
User avatar
johngar
Member
 
Posts: 575
Joined: Wed Dec 15, 2010 5:46 pm
Has thanked: 7 times
Been thanked: 14 times


Return to General

Who is online

Users browsing this forum: No registered users and 8 guests