Steinberg Media Technologies GmbH

Creativity First

Frankenstraße 18 b
20097 Hamburg

Tel: +49 (0)40 210 35-0
Fax: +49 (0)40 210 35-300

Cubase LE 4 cannot be installed correctly on Mac OS X Snow Leopard


Cubase LE 4 can't be installed on Snow Leopard because some OEM partners have changed the data structure of the original Cubase LE 4 DVD.


  1. From the OEM DVD copy the folders "Cubase LE 4 for Mac OS X" and "Cubase LE 4 for Windows" to your HD and burn them on a DVD that you call "Cubase LE 4".

  2. Download the Mac update to Cubase LE 4.1.3

  3. Now insert the newly burned DVD and click on "Next".

  4. It is advisable to download and install the latest eLicenser Control Center from

  5. Done

Did this article help you?