Slow Saves, Large .cpr files? Clean up your Pool!

For users of legacy Steinberg Cubase software
Post Reply
User avatar
allisterbradley
New Member
Posts: 7
Joined: Wed Nov 20, 2013 4:48 pm
Location: Wellesley, Ontario, Canada
Contact:

Slow Saves, Large .cpr files? Clean up your Pool!

Post by allisterbradley » Wed Feb 05, 2014 5:07 pm

I had (notice the past tense) a problem with a particular project getting larger and larger, and taking an incredibly long time (several minutes) to save. It became necessary to turn off the AUTO SAVE, just to run a tracking session for a new performer.

My project file had increased to about 86MB in size. Yikes!

I'm proficient with Cubase, but I won't call myself an expert yet, and it took an awful lot of digging through forums to find the solution, so I want to share it, in case it helps anyone else.

Did it have to do with VariAudio? With automatic hit-point detection? With sliced audio? With excess edit history?

Well, sort of. Bottom line - my Pool was full of files I was no longer using. Once I removed unused media and emptied the trash in my pool (didn't need to erase the files), my project shrunk back down to 2.5MB, and now it saves in less than one second.

Note that using VariAudio, slicing and quantizing audio files, comping, etc., contributed to the increase in the number of files in the pool. Bouncing my comp and replacing the event with a new file DID NOT help at all, because the unused (old) files were still in my Pool.

So, before you go out and implement RAID across multiple hard drives, before you spend any money trying to throw more hardware at Cubase, take a look at your media Pool and see if you can remove excess files. It worked for me!

AB
Cubase 9.0 on Windows 7 and Windows 10
Plug-ins by Steinberg, Waves, Focusrite, Slate Digital, iZoTope
VST Instruments by Steinberg, Toontrack, Submersible, Waves
Focusrite Scarlett interfaces

JBeckstein
New Member
Posts: 18
Joined: Wed Oct 05, 2011 5:24 pm
Location: Calgary, Canada
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by JBeckstein » Fri Feb 28, 2014 8:52 pm

Here's an odd aside to this problem. It doesn't seem directly relate to the size of the pool.

I have a VERY large Pool in one project - 1200 some files audio files. All of these have specific tempo information, which I painstakingly entered. I don't want to have to re-enter all of this information each new project, so I start all new projects by copying the last one and clearing the main project window - thus giving me a blank project, but with the same pool. Up until Cubase 7.5, the CPR project file size was ~5mb. Now, it's 80mb, which causes all of the auto-save freezing and workflow interruptions you also experienced.

So, here's the twist. If I go back and re-open an old Cubase 7.0 project file with a similar number of tracks in the pool, it stays at 5mb, even after working with it and saving as a 7.5 project... So, there's gotta be something else other than the number of tracks that makes it so large. I've tried deleting Hitpoints, there are none. I've not used Vari-audio, or done specific edits... Anyone have any ideas?

Of course, it would seem the simple solution is to just start with a 7.0 project... I just don't really want to. My process has worked fine from Cubase 4 until now. I'd just like to know what changed and how I can undo it.

Any input would be much appreciated.
~J

User avatar
jamusic
Member
Posts: 664
Joined: Sun Jun 16, 2013 6:49 pm
Location: An Hour East Of Vancouver, BC
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by jamusic » Mon Mar 03, 2014 12:20 am

allisterbradley wrote:I had (notice the past tense) a problem with a particular project getting larger and larger, and taking an incredibly long time (several minutes) to save. It became necessary to turn off the AUTO SAVE, just to run a tracking session for a new performer.

My project file had increased to about 86MB in size. Yikes!

I'm proficient with Cubase, but I won't call myself an expert yet, and it took an awful lot of digging through forums to find the solution, so I want to share it, in case it helps anyone else.

Did it have to do with VariAudio? With automatic hit-point detection? With sliced audio? With excess edit history?

Well, sort of. Bottom line - my Pool was full of files I was no longer using. Once I removed unused media and emptied the trash in my pool (didn't need to erase the files), my project shrunk back down to 2.5MB, and now it saves in less than one second.

Note that using VariAudio, slicing and quantizing audio files, comping, etc., contributed to the increase in the number of files in the pool. Bouncing my comp and replacing the event with a new file DID NOT help at all, because the unused (old) files were still in my Pool.

So, before you go out and implement RAID across multiple hard drives, before you spend any money trying to throw more hardware at Cubase, take a look at your media Pool and see if you can remove excess files. It worked for me!

AB
Hey thanks & welcome fellow Canadian [- fellow Ontario-an]!

I'm new to Cubase since last June-July and haven't ever though to do this. But I should.
-C7.5.4/8.0.4 -Win 7-x64 -Intel i7-2600k -ASUS P8Z68 V-Pro -Antec High Current 520w -16G RAM
-ASUS nVidia GeForce Video Card -Hyper 212+ Cooler -3 SSDs -1TB Black Caviar HD -2 1TB External USB 3
-TC Electronic SK 48 Audio Interface -Presonus StudioLive 16.4.2 Mixer -Roland UM-550 MIDI Interface
-Advanced Audio CM67se Mic -DBX 376 Tube Channel Strip Pre-Amp/Comp -ART DPS II Tube Pre-Amp
-Roland V-Piano -Yamaha P-200/88 key & Nektar Panorama P6/61 Keyboards -V-Drums/Roland TD-6
-4003 Rickenbacker Fireglow Bass -5 Guitars -4 Sound Modules -Way Too Many VSTs -Little To No Talent ;)


User avatar
ffg
Member
Posts: 573
Joined: Fri Dec 17, 2010 6:46 pm
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by ffg » Mon Mar 03, 2014 12:31 am

Something got changed between 7>7.5 which has caused a huge ramp up in the save time. It is not to do with the size of the .cpr file, although this can get very big - it's also nothing to do with the time it takes to save the file to disk, I have up to 30 seconds save time with a project file of only 3MB, using a SSD drive.

It has everything to do with certain operations in Cubase, the main two I notice are slicing, quantising and crossfading multi-track drum recordings, and offline processing of multiple audio clips, for example with Autotune. I expect there are others but these are the ones which affect my workflow.

The workaround is to bounce the audio so that the clips become a single file again, and re-load the project to dump the undo chain. Of course this limits ability to go back to an earlier version.

I wish Steinberg would say something about this, or better still, get it fixed.
best wishes

David

I'm going to to let the situation mature...

Nuendo 8.2
Cubase 9.5
MacPro 3.3 6-core OSX 10.12
Macbook Pro OSX 10.11
RME Fireface 802
RME Fireface 800

-steve-
External Moderator
Posts: 7964
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by -steve- » Mon Mar 03, 2014 12:44 am

Automatic hitpoint generation was added in 7.5, and it's on by default. Could that be the culprit?
Cubase Pro, Nuendo, and Dorico Pro; latest versions available.
Windows Pro 10 | i7-3770k | GA-77x-UD5h | 32 Gb | UR-RT2 | MOTU Ultralite mk3 hybrid
Macbook Pro 2011 | Mac OS 10.11
not a steinberg employee

User avatar
jamusic
Member
Posts: 664
Joined: Sun Jun 16, 2013 6:49 pm
Location: An Hour East Of Vancouver, BC
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by jamusic » Mon Mar 03, 2014 7:11 am

I had really slow wait times as well with 7.5, and posted around a month ago about having to wait seemingly forever for the Windows 'hour glass' to disappear.

For me the answer was to right-click on the Cubase start icon and then click on Properties.
I had to un-check Run in compatibility with Windows 7, and that fixed it - to no more than just a second or so.

Just something for you to consider & maybe try.
-C7.5.4/8.0.4 -Win 7-x64 -Intel i7-2600k -ASUS P8Z68 V-Pro -Antec High Current 520w -16G RAM
-ASUS nVidia GeForce Video Card -Hyper 212+ Cooler -3 SSDs -1TB Black Caviar HD -2 1TB External USB 3
-TC Electronic SK 48 Audio Interface -Presonus StudioLive 16.4.2 Mixer -Roland UM-550 MIDI Interface
-Advanced Audio CM67se Mic -DBX 376 Tube Channel Strip Pre-Amp/Comp -ART DPS II Tube Pre-Amp
-Roland V-Piano -Yamaha P-200/88 key & Nektar Panorama P6/61 Keyboards -V-Drums/Roland TD-6
-4003 Rickenbacker Fireglow Bass -5 Guitars -4 Sound Modules -Way Too Many VSTs -Little To No Talent ;)


JBeckstein
New Member
Posts: 18
Joined: Wed Oct 05, 2011 5:24 pm
Location: Calgary, Canada
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by JBeckstein » Mon Mar 03, 2014 6:49 pm

ffg wrote: The workaround is to bounce the audio so that the clips become a single file again, and re-load the project to dump the undo chain. Of course this limits ability to go back to an earlier version.
Yeah, unfortunately, that is also a workflow killer for me... and even when my project is completely empty (other than the 1000+tracks in the pool), the .cpr file is still 50mb. Odd.
SteveInChicago wrote:Automatic hitpoint generation was added in 7.5, and it's on by default. Could that be the culprit?
Thanks - I double checked, I've got it disabled. :(


Anyway, hopefully Steinberg will figure this one out soon.

Michiel
New Member
Posts: 9
Joined: Thu Dec 13, 2012 9:49 am
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by Michiel » Fri Oct 13, 2017 11:41 pm

For anyone reading this, a plugin was causing this issue on my side. A simple project would take up 100 MB of space. When I removed the plugin from my project (Youlean loudness meter) the project file was 7 MB again.

LeprechaunStu
New Member
Posts: 6
Joined: Tue Nov 07, 2017 2:20 am
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by LeprechaunStu » Tue Nov 07, 2017 2:54 am

I'm having this exact problem.. How can I locate the offending PlugIn that's creating the problem? Much thx...

totaltom
New Member
Posts: 1
Joined: Fri Apr 06, 2018 9:01 pm
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by totaltom » Fri Apr 06, 2018 9:04 pm

The problem of cpr file size and saving time also applies to damaged midi tracks (which swell while deleting or inserting bars in the score). After finding this tracks and deleting, the size of the cpr file fell from 110 Mb to 20 Mb.

saxmand
New Member
Posts: 39
Joined: Mon May 12, 2014 1:32 am
Contact:

Re: Slow Saves, Large .cpr files? Clean up your Pool!

Post by saxmand » Mon Sep 10, 2018 9:48 pm

This is so interesting.
I have horrible saving times right now.
Project is around 4 hours long. 400 tracks. A cpr file now is round 100mb big.
And I'm doing lots of global time copy, paste, delete stuff. Sounds strange that midi tracks can become damaged. That's something I'd consider a bug :/ But guess I need to go hunting through my MIDI tracks.

Also cleaning out the pool for unused audio didn't help. Only reduced it with a couple of mb.

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: Google [Bot] and 3 guests