CMC-TP Play and Stop buttons not working anymore

This section is about Steinberg's CMC controllers
Post Reply
Max Rebo
New Member
Posts: 2
Joined: Sat Sep 13, 2014 8:54 am
Contact:

CMC-TP Play and Stop buttons not working anymore

Post by Max Rebo » Sat Sep 13, 2014 9:17 am

Other then those 2 buttons, everything else works fine. They have seen the most action so I am pretty sure the rubber contacts need to be cleaned. I can't seem to locate the screws to open it. Are they under the rubber foot pads? Minus the obvious one in the upper left. Any help appreciated. My warrantee is long gone so just need to know how to get it open. Thanks

User avatar
istokblues
Junior Member
Posts: 63
Joined: Sat Jul 16, 2011 9:30 am
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by istokblues » Fri Oct 03, 2014 9:27 am

Max Rebo wrote:Other then those 2 buttons, everything else works fine. They have seen the most action so I am pretty sure the rubber contacts need to be cleaned. I can't seem to locate the screws to open it. Are they under the rubber foot pads? Minus the obvious one in the upper left. Any help appreciated. My warrantee is long gone so just need to know how to get it open. Thanks


I need to clean it too - my problem is SHIFT button !
istok

Max Rebo
New Member
Posts: 2
Joined: Sat Sep 13, 2014 8:54 am
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by Max Rebo » Fri Oct 03, 2014 8:04 pm

I got into it but I was only able to fix the play button. But if anyone wants to give it a go: Take the rubber pads off to reveal the other 3 screws. It will almost open but not quite and you'll notice something is still holding it together near the middle. There are 4 hidden plastic clips, 2 on each side near the middle. I took the backside of a thin knife, and while gently pulling the case open a tad, I ran it in between the 2 halves of the case and it released the clips. Of course I did this on the other side and broke one of the plastic clips. After that it's just one screw that holds everything together. May or may not fix it. Didn't work on the stop button. I tested the contacts with an ohm meter and everything looks right so I'm not really sure what it could be at this point. Maybe that one rubber pad. Just using play and stop on my QC for the time being.

User avatar
istokblues
Junior Member
Posts: 63
Joined: Sat Jul 16, 2011 9:30 am
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by istokblues » Thu Oct 16, 2014 8:40 am

Max Rebo wrote:I got into it but I was only able to fix the play button. But if anyone wants to give it a go: Take the rubber pads off to reveal the other 3 screws. It will almost open but not quite and you'll notice something is still holding it together near the middle. There are 4 hidden plastic clips, 2 on each side near the middle. I took the backside of a thin knife, and while gently pulling the case open a tad, I ran it in between the 2 halves of the case and it released the clips. Of course I did this on the other side and broke one of the plastic clips. After that it's just one screw that holds everything together. May or may not fix it. Didn't work on the stop button. I tested the contacts with an ohm meter and everything looks right so I'm not really sure what it could be at this point. Maybe that one rubber pad. Just using play and stop on my QC for the time being.
Thank you Max !
I will try to do something !
istok

kanon001
New Member
Posts: 3
Joined: Wed Jan 21, 2015 10:52 am
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by kanon001 » Mon May 18, 2015 9:32 pm

I need to get into my Transport Controller to clean up some contacts - if that is what is wrong. Any recommendations on how to clean the contacts. Many years ago I used a silicon spray on contacts - is this still recommended?

Any advice appreciated.

Kanon

JamesTNL
Junior Member
Posts: 66
Joined: Tue May 15, 2012 9:59 pm
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by JamesTNL » Sun Jun 07, 2015 6:22 pm

Same issue here. I opened up the unit and tried cleaning etc without result.

Now I know why they were so cheap. Very limited support lifetime and cheap/shoddy build quality.
Cubase 7.06 - Windows 7 Ultimate x64 - ASRock B85M-ITX - Intel Core i5 4570S - 2 x 8GB Crucial Ballistix Sport DDR3 - Dawicontrol DC-FW800 PCIe - Presonus Firebox - Xigmatek Nebula - be quiet! Pure Power L8 430W CM - Steinberg CMC-AI - Steinberg CMC-TP - Steinberg CMC-CH

JamesTNL
Junior Member
Posts: 66
Joined: Tue May 15, 2012 9:59 pm
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by JamesTNL » Mon Feb 15, 2016 8:51 pm

Since my last post, some buttons had stopped working altogether, specifically the: 'F3', 'Nudge R' and 'Event R' buttons.

So I opened up the unit again and tested the button while connected to my PC and flexing the circuitboard a bit.
I noticed it would give a response now and then. So seeing as it was pretty much useless anyway at that point, I very gently bent the circuitboard just enough until the buttons worked.

So for now, all buttons are working again, but I'm aware this is most likely a temporary fix. Hopefully it will keep me going until I find a decently priced 2nd hand one, or if a decent alternative comes up. So far, the only real alternative still seems to be the Presonus Faderport, but that isn't USB powered and lacks user assignable buttons. All other midi controllers I've come across have either pads, a keyboard section or other additional controls which make the device footprint too big.

Why did Steinberg discontinue this product? It was perfect for my home studio (except for the shoddy build quality that is).
Cubase 7.06 - Windows 7 Ultimate x64 - ASRock B85M-ITX - Intel Core i5 4570S - 2 x 8GB Crucial Ballistix Sport DDR3 - Dawicontrol DC-FW800 PCIe - Presonus Firebox - Xigmatek Nebula - be quiet! Pure Power L8 430W CM - Steinberg CMC-AI - Steinberg CMC-TP - Steinberg CMC-CH

User avatar
Strophoid
Grand Senior Member
Posts: 4659
Joined: Sun Dec 26, 2010 2:56 pm
Location: The Netherlands
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by Strophoid » Sat Feb 20, 2016 12:15 am

I believe the presonus faderport has also been discontinued for a while now, so make sure it's supported on your system.
Software: Steinberg Cubase Pro 8 64-bit.
Hardware: Intel i5 6600, 16Gb DDR3, Win7 64-bit
Mackie Onyx 1620i - Steinberg Midex 8 - Steinberg CC121.

My humble contributions to what could be considered music.

JamesTNL
Junior Member
Posts: 66
Joined: Tue May 15, 2012 9:59 pm
Contact:

Re: CMC-TP Play and Stop buttons not working anymore

Post by JamesTNL » Wed Feb 24, 2016 6:37 pm

Strophoid wrote:I believe the presonus faderport has also been discontinued for a while now, so make sure it's supported on your system.
Good call. Strangely enough though it is still widely available through all main retailers here in the Netherlands, unlike the CMC's, which ran out extremely quick at some point. Not sure what to make of it.
Cubase 7.06 - Windows 7 Ultimate x64 - ASRock B85M-ITX - Intel Core i5 4570S - 2 x 8GB Crucial Ballistix Sport DDR3 - Dawicontrol DC-FW800 PCIe - Presonus Firebox - Xigmatek Nebula - be quiet! Pure Power L8 430W CM - Steinberg CMC-AI - Steinberg CMC-TP - Steinberg CMC-CH

Post Reply

Return to “Steinberg CMC Series”

Who is online

Users browsing this forum: No registered users and 2 guests