Page 1 of 1

I have to reboot iPad everytime I plug in Camera Kit launch

Posted: Sat Apr 29, 2017 10:55 am
by marsxmarsx
Every time I want to use Cubasis; if the camera kit and connected hardware (a USB hub is connected to the camera kit and an Audio interface and a MIDI controller are both connected to the USB hub), I h:ave to reboot the iPad.

My equipment:
iPad Air 2
Apple Camera Adapter USB3 interface
Belkin USB3 Hub
M-Audio Axiom MIDI Air 32 Controller
Zoom U-24 Audio Interface (powered by batteries NOT the USB hub (though I can power it through the hub, I guess)

So, if I have rebooted the iPad Air 2 and plug in the Apple Camera Adapter Kit and the other listed equipment all at once (or put it in before reboot), I can then launch Cubasis and I have no problems.

HOWEVER, if I finish with Cubasis and close it, and then unplug the Camera Adapter Kit (with all the other hardware connected); when I re-connect the Camera Adapter Kit (with all other hardware connected) and launch
Cubasis, there is no MIDI response and I get an error saying "InterApp Audio Error." If I then reboot the iPad, and then launch Cubasis again, it works fine again.

Does anyone else have a problem like this? Is anyone or everyone able to close Cubasis, unplug the Camera Adapter Kit and other equipment and then plug the Camera Adapter Kit and other equipment back in and launch Cubasis again and have it work flawlessly (sort of like hot swapping the Camera Kit and other equipment)?

Any info or advice in this regard will be greatly appreciated. If I haven't made myself clear, please ask questions so I can clarify. I really don't want to have to reboot every time I plug in my music equipment and Camera Adapter Kit to use Cubasis, unless there's no way around it.

Thanks

Re: I have to reboot iPad everytime I plug in Camera Kit lau

Posted: Sat Apr 29, 2017 5:15 pm
by LSlowak
Hi marsxmarsx,

Thanks for your message.

Please give it a test to leave the USB hub out of the game and let me know if rebooting is still required.

Best,
Lars

Re: I have to reboot iPad everytime I plug in Camera Kit lau

Posted: Tue May 02, 2017 8:28 am
by marsxmarsx
Hi Lars,

Yes. If I want to just use one device, the iPad does not need to be relaunched for Cubasis to work properly; however, then I either have just my MIDI device without my speakers connected or I have just my Audio interface connected without MIDI controller connected.

Any advice, or is this just the way it is?

Thanks in advance.

Wade

Re: I have to reboot iPad everytime I plug in Camera Kit lau

Posted: Tue May 02, 2017 2:41 pm
by LSlowak
Hi Wade,

Thanks for the update.

In general, we normally do not use USB hubs when performing Cubasis test with hardware devices.
What happens if you perform the same test with other apps?

Best,
Lars

Re: I have to reboot iPad everytime I plug in Camera Kit lau

Posted: Tue May 02, 2017 10:20 pm
by mm70
is this a powered hub? maybe you can try with a different one?! over here it works as expected. midi keys and audio interface plugged into a no name usb hub (powered) and then new cck. no need to reboot.

Re: I have to reboot iPad everytime I plug in Camera Kit lau

Posted: Thu May 04, 2017 11:37 am
by LSlowak
mm70 wrote:is this a powered hub? maybe you can try with a different one?! over here it works as expected. midi keys and audio interface plugged into a no name usb hub (powered) and then new cck. no need to reboot.
Thanks for sharing your experience in this topic!

Best,
Lars