Page 1 of 1

Cubasis sample rate problems on 48khz audio interface

Posted: Sun May 12, 2013 3:59 am
by qu_bix
There seems to be a problem in Cubasis with external audio interfaces that do not run at 44khz. I have recently been attempting to use my Korg Kronos via the lightning-to-USB camera interface and find that when playing the built-in Cubasis instruments I get a lot of crackling/clicking on the audio output (the good news, by the way, is that my iPad mini and Cubasis immediately recognize both the MIDI in/out and digital audio in/out of the Kronos when I connect to the iPad via USB). Additionally when I record external audio played in from the Kronos and then play back the resulting audio tracks in Cubasis, the pitch of all of the audio is shifted down.

I strongly suspect that these problems are due to the fact that the Kronos audio interface runs at fixed 48khz (and unfortunately it is impossible to change this, it is hard wired) and Cubasis is likely just assuming that all interfaces are running at 44khz, but this is just a guess.

I should note that none of the other audio apps I've tried seem to suffer from these issues. For example, the built in music player app and Sampletank both have no problems at all playing back proper uncorrupted audio through the Kronos USB audio interface on this iPad.

This post is just an FYI for the Steinberg developers, in case they are reading this forum. Cubasis is a great iOS app, by the way, I love it, very nice piece of design and development work. Looking forward to future enhancements.

Re: Cubasis sample rate problems on 48khz audio interface

Posted: Tue May 14, 2013 8:13 am
by crohde
Hi qu_bix,

The audio engine in Cubasis only supports 44.1kHz at the moment, 48kHz is not supported.

Re: Cubasis sample rate problems on 48khz audio interface

Posted: Wed May 15, 2013 3:18 am
by qu_bix
Ah, hypothesis confirmed. Thank you very much for the information and reply. I'll keep my fingers crossed for future 48khz support then :-)

Re: Cubasis sample rate problems on 48khz audio interface

Posted: Mon Oct 14, 2013 12:22 am
by Redrain
My problem is that when I record an audio track with kronos as soundcard all previous recorded track are recorded in the new track !