ID tags missing when rendering to FLAC

All topics on WaveLab 8 and WaveLab Elements 8
Post Reply
User avatar
Pietzcker
Member
Posts: 217
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

ID tags missing when rendering to FLAC

Post by Pietzcker » Mon Sep 29, 2014 2:27 pm

I've just tried to render an audio montage to FLAC and MP3, together with ID tags (using Wavelab 8.5.0). Everything works fine when rendering to MP3, but when I try to render to FLAC, the resulting file doesn't have any ID tags.

I have used the factory preset "CD tracks from custom metadata" in the Metadata window, and I've set the "Import from source file" option in the Rendering dialog (and I think I've entered all the data correctly; after all, they are created correctly in the MP3 files).

Am I overlooking something?

Thanks and best regards,
Tim
Windows 10, Dorico Pro 3, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Justin P
Senior Member
Posts: 2544
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: ID tags missing when rendering to FLAC

Post by Justin P » Thu Oct 02, 2014 2:12 am

I wish I knew more about FLAC and FLAC metadata. I don't often use FLAC but it seems that my metadata presets in the montage that satisfy my WAV, mp3, and AAC needs does not add any readable metadata to FLAC files.

When I tag FLAC files with metadata using the Jaikoz app, the Mac Finder doesn't see the metadata but Jaikoz can when I reopen the files in Jaikoz.

Maybe you need a special FLAC metadata app, but it would be nice if Wavelab could directly tag FLAC files like it can with other formats.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

PG
Moderator
Posts: 7327
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: ID tags missing when rendering to FLAC

Post by PG » Thu Oct 02, 2014 6:18 am

WaveLab does not support ID3 tags in FLAC files. This is why the preset you mention does not work. The big meta-data dialog is for producing wav, mp3 and aac files.
For FLAC, you can edit meta-data in its dedicated edtitor, that you open from the file format dialog:
2014-10-02_07-15-00.png
(37.77 KiB) Not downloaded yet
Philippe

User avatar
Pietzcker
Member
Posts: 217
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: ID tags missing when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 12:23 pm

I tried using the File Format dialog, but the resulting file still didn't have any metadata...
02-10-_2014_13-04-58.png
File Format dialog
(112.05 KiB) Not downloaded yet
Or did you mean I have to re-enter all the information after having rendered the file? That would be pretty awful, don't you think? Why wouldn't Wavelab (if it can be used to edit FLAC tags) then also allow those tags to be created upon rendering?

But anyway, the approach you suggested doesn't even seem to work:

Open the file, press Shift-A (Edit - Metadata), enter some metadata and click "OK":
02-10-_2014_13-16-14.png
Editing Metadata
(67.34 KiB) Not downloaded yet
The filename tab turns red and gets a "*" to show that it has been modified. Press Shift-A again - metadata are gone:
02-10-_2014_13-16-43.png
Metadata edit ignored...
(83.55 KiB) Not downloaded yet
What's happening there?

Thanks,
Tim
Windows 10, Dorico Pro 3, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

PG
Moderator
Posts: 7327
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: ID tags missing when rendering to FLAC

Post by PG » Thu Oct 02, 2014 2:44 pm

Or did you mean I have to re-enter all the information after having rendered the file? That would be pretty awful, don't you think?
No, I don't mean that. You have to enter the data as you do on your pictures. And the variables will be automatically rendered during rendering.
But you have found a bug: the data is lost when closing the dialog. I have identified the problem and it will be corrected in 8.5.20.
Philippe

User avatar
Pietzcker
Member
Posts: 217
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: ID tags missing when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 3:55 pm

Oh, excellent! Thanks for getting to the bottom of this so quickly! :D
Windows 10, Dorico Pro 3, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

Post Reply

Return to “WaveLab 8 | WaveLab Elements 8”

Who is online

Users browsing this forum: No registered users and 1 guest