Page 3 of 3

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Wed Oct 08, 2014 11:42 pm
by Antonio Escobar
Hi Pål,

My folder data:

Code: Select all


drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 AppleAVCIntraCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:51 AppleHDVCodec.component
drwxr-xr-x+ 3 root     wheel  102 16 sep 02:52 AppleIntermediateCodec.component
drwxr-xr-x  3 root     wheel  102 25 ago  2013 AppleMPEG2Codec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 AppleProResCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:50 DVCPROHDMuxer.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDVideoDigitizer.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDVideoOutput.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDVideoOutputClock.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDVideoOutputCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DXVCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:48 DesktopVideoOut.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 FCP Uncompressed 422.component
drwxrwxr-x+ 3 antipop  wheel  102 16 sep 02:51 FLACImport.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 IMXCodec.component
drwxrwxr-x+ 4 antipop  wheel  136 16 sep 02:43 XiphQT.component

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Thu Oct 09, 2014 1:02 pm
by psvennevig
Hi,

For a test, move components out of the /Library/QuickTime folder to a safe location so the result looks like this:

Code: Select all

drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 AppleAVCIntraCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:51 AppleHDVCodec.component
drwxr-xr-x+ 3 root     wheel  102 16 sep 02:52 AppleIntermediateCodec.component
drwxr-xr-x  3 root     wheel  102 25 ago  2013 AppleMPEG2Codec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 AppleProResCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 DVCPROHDCodec.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:48 DesktopVideoOut.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 FCP Uncompressed 422.component
drwxrwxr-x+ 3 root     wheel  102 16 sep 02:52 IMXCodec.component

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Thu Oct 09, 2014 3:00 pm
by Dolfo
/Library/QuickTime/AppleHDVCodec.component
/Library/QuickTime/AppleIntermediateCodec.component
/Library/QuickTime/AppleMPEG2Codec.component
/Library/QuickTime/AppleProRes422.component
/Library/QuickTime/Blackmagic Codec.component
/Library/QuickTime/DesktopVideoOut.component
/Library/QuickTime/DivX Decoder.component
/Library/QuickTime/DVCPROHDCodec.component
/Library/QuickTime/DVCPROHDMuxer.component
/Library/QuickTime/DVCPROHDVideoDigitizer.component
/Library/QuickTime/DVCPROHDVideoOutput.component
/Library/QuickTime/DVCPROHDVideoOutputClock.component
/Library/QuickTime/DVCPROHDVideoOutputCodec.component
/Library/QuickTime/FCP Uncompressed 422.component
/Library/QuickTime/IMXCodec.component
/Library/QuickTime/LiveType.component
/Library/QuickTime/Motion.component

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Thu Oct 09, 2014 3:32 pm
by psvennevig
Try what I described above!

[ISSUE] Video Engine crashing in 6.5.3

Posted: Fri Oct 10, 2014 9:05 am
by goodbyenine
But we won't be able to run our video files if we do this. I wish SB would chime in here before we mess with our systems.

Also we know this problem is not exhibited with earlier versions of Nuendo, despite the system files already present.

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Fri Oct 10, 2014 10:26 am
by psvennevig
Yes you will. You do not need all those DVCPROHD files to support DVCPROHD

I'm asking because we've had problems with the exact same with ProTools also.
I wonder where they come from all those DVCPROHD files?

Also DivX Decoder you don't need to get Nuendo to work.

And this also just a test!!

Pål

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Sat Oct 11, 2014 5:02 pm
by goodbyenine
Hmm. Looking closely I see you have suggested leaving active the core useful codecs. So yes, I take back what I said.

I had no idea PT was suffering too.

I think those codecs get installed by FCP. Or compressor. Don't know...

Sometimes hard to realise we are 21st century and still struggling with all these things!

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Sat Oct 11, 2014 7:30 pm
by psvennevig
goodbyenine wrote:Hmm. Looking closely I see you have suggested leaving active the core useful codecs. So yes, I take back what I said.

I had no idea PT was suffering too.

I think those codecs get installed by FCP. Or compressor. Don't know...

Sometimes hard to realise we are 21st century and still struggling with all these things!
No, those other DVCPRO codecs must come from somewhere else because I haven't seen them in a while.
We have FCP7, FCPX, Premiere CC, Compressor 4 etc. at work on all Macs, and they aren't there.

We had problems with a BMD card apprx. a year ago, then I had to wipe all the quicktime components and get new ones, it was hard to sort. Today it is a little bit easier.
To make sure the core is updated, download the latest Pro Apps Codec update
This is the latest as of now:
http://support.apple.com/kb/DL1396?view ... cale=en_US

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 14, 2014 10:42 pm
by Darren The Musical
Hi all,

This may be absolutely nothing at all, but I was looking at my mac's Activity Monitor and noticed the processes videopreload, videooutput and videocode activate when Nuendo 6.5 is running. However, these processes quickly turn red and are marked as Not Responding. This is without any project loaded. Also, they are flagged as 32 bit processes. Should I be concerned about this?

Thanks!

Darren "32 bits ain't what they used ta be" Ingram

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Wed Oct 15, 2014 8:32 am
by psvennevig
No

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 12:46 pm
by goodbyenine
Well it's moody. Now It's crashing constantly and I have no idea why. I have stripped the Quicktime Folder as suggested, part from the Blackmagic component.

Can SB give some kind of update on this please?

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 2:31 pm
by Tino Degen
Hello to you all,

this issue seem to happen more often recently. We are still
investigating into this.
The only situation to reproduce this problem here inhouse is
having the "DVCPROHDMuxer.component" present - located
here:
Drive / Library / QuickTime / DVCPROHDMuxer.component

When creating an Aggregate device (not even used in Nuendo)
makes this issue worse. Removing this component, solves this
here. Other than that we can´t reproduce this problem at all.
We aren´t still sure which application (tool) install`s that
component. If you could help in that regard, we´d appreciate it !

Please remove this component and report back the result for
your system. Thank you.


The situation of the videopreload, videooutput and videocode
process in the Mac "Activity Monitor" showing "not repsonding"
is not affecting the functionality and a different topic and is
almost fixed.

best wishes, Tino

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 2:34 pm
by goodbyenine
Hi Tino

Thank you so much for responding. I appreciate the information.

I have pulled out many codecs this morning, including the DVCPROHDMuxer. I wonder, would you like me to put the others back in, APART FROM the DVDHDPROMuxer, as a test?

Thanks

Ben

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 2:42 pm
by Tino Degen
Hi Ben,
thank you for your quick reply. Yes, please put the other components back into the QuickTime folder apart
from the "DVCPROHDMuxer.component" and let us know if it´s working ok for you ? Thank you, cheers, Tino

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 2:52 pm
by Neil K
Hi Tino, I pulled out the DVCPROHDMuxer like you directed me to in our emails. I've not had it crash since (about 2-3 weeks). I now believe the other problems I've been experiencing are not related to this.

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 4:59 pm
by Antonio Escobar
Hi,

Taking DVCPROHDMuxer.component out did the trick here and I have no crashes changing the sample rate frequency :-), but I still having CPU spikes due the video component, even when I don't have any video in the project. In fact, I'm working without it (taking it out from the components folder) any time that I don't have to use video. The CPU spikes are really a deal breaker most of time. I've been working in a project that needs a 25% of the CPU resources that glitches all time when I have the video component active, even not having any video track.

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Tue Oct 28, 2014 7:56 pm
by Oliver.Lucas
Tino Degen wrote:
We aren´t still sure which application (tool) install`s that
component. If you could help in that regard, we´d appreciate it !
I'm not 100% sure, but since it says it's copyright is by apple I would guess that it comes from my Logic installation (that is only on that one machine that used to make trouble).
I have the studio 9 dvd version with compressor.

Just a wild guess....

Ollie

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Wed Oct 29, 2014 4:05 pm
by Dolfo
I took out the Quicktime folder DVDPROHDMuxer.component and crash still happens when sample frequency is changed.
:o

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Wed Oct 29, 2014 4:22 pm
by Darren The Musical
I don't have DVDPROHDMuxer.component and have recently had a crash. I do, however, have DVDPROHDCodec.component. Also, I do not use BM anything.

Should this be removed?

Thanks!

Darren "Fix It In The Mux" Ingram

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Thu Nov 20, 2014 12:31 pm
by Dolfo
Two weeks since updated to 6.5.3. and DVCPROHDMuxer.component removed. No video engine crashes.

Happy.

Re: [ISSUE] Video Engine crashing in 6.5.3

Posted: Sat Nov 22, 2014 2:48 pm
by nkf
Yesterday, while trying to replace audio in a video file with Nuendo, I had a crash again of the video engine. DVDPROHDMuxer.component is removed here to. Newest Nuendo version 6.5.35. OSX 10.9.5, MacPro HexCore. Annoying.