Page 1 of 2

Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 10:27 am
by James K
I think C 10 has worse performance than before.

Exact same buffer settings of 512.

Exact same arrangement. One Groove Agent 5 track and all other audio tracks with an instance of Scheps Omni Channel on each.

Results:

Cubase C 10.0.20: Best was maximum 37 tracks with clicks and pops. Tried all different settings.
Screen Shot 2019-06-20 at 2.16.20 AM.png
(513.03 KiB) Not downloaded yet
Studio One 4.5: Best was 57 tracks.
Screen Shot 2019-06-20 at 12.41.05 AM.png
(542.25 KiB) Not downloaded yet
Logic Pro 10.4.5: Best was 61 tracks. Performed perfectly until it hit overload and stopped.
Screen Shot 2019-06-20 at 2.07.53 AM.png
(646.69 KiB) Not downloaded yet

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 10:46 am
by GlennO
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 10:50 am
by skijumptoes
Wow, that's really quite shocking, as there's 4 threads in Logic is that the i5-2400 CPU?

I've heard it said that Macs perform worse on older generation CPUs, but i presumed that was in relation to the older Intel Xeons. It would be interesting if anyone could something similar on a 7/8th generation intel Mac

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 10:56 am
by James K
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.
While keeping the buffer setting at 512 I tried all different combination of options in the settings panel and that was the best Cubase could produce.
Screen Shot 2019-06-20 at 2.57.49 AM.png
(92.75 KiB) Not downloaded yet

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 11:01 am
by James K
skijumptoes wrote:
Thu Jun 20, 2019 10:50 am
Wow, that's really quite shocking, as there's 4 threads in Logic is that the i5-2400 CPU?

I've heard it said that Macs perform worse on older generation CPUs, but i presumed that was in relation to the older Intel Xeons. It would be interesting if anyone could something similar on a 7/8th generation intel Mac

Here's my specs
Screen Shot 2019-06-20 at 3.00.16 AM.png
(79.7 KiB) Not downloaded yet

Much better milage for me in the other two DAWs.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 11:09 am
by GlennO
James K wrote:
Thu Jun 20, 2019 10:56 am
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.
While keeping the buffer setting at 512 I tried all different combination of options in the settings panel and that was the best Cubase could produce.
Screen Shot 2019-06-20 at 2.57.49 AM.png
I understand, but that's different than saying you used the same conditions in all 3 tests. These days, with hybrid buffers and asio guard, setting your buffer size to 512 does not mean you are using a buffer size of 512 :). Try my test and see if you observe a difference.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 11:13 am
by James K
GlennO wrote:
Thu Jun 20, 2019 11:09 am
James K wrote:
Thu Jun 20, 2019 10:56 am
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.
While keeping the buffer setting at 512 I tried all different combination of options in the settings panel and that was the best Cubase could produce.
Screen Shot 2019-06-20 at 2.57.49 AM.png
I understand, but that's different than saying you used the same conditions in all 3 tests. These days, with hybrid buffers and asio guard, setting your buffer size to 512 does not mean you are using a buffer size of 512 :). Try my test and see if you observe a difference.

If that's the best Cubase can do on my hardware... and the other DAWs have optimizations and settings that are working better then perhaps Cubase could improve in that department.

That's my point.

Me doing your test just Compares my Hardware to your Hardware and that's irrelevant.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 11:22 am
by GlennO
James K wrote:
Thu Jun 20, 2019 11:13 am
Me doing your test just Compares my Hardware to your Hardware and that's irrelevant.
I'm saying perform my test and see if you observe a difference between DAWs.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 3:12 pm
by ckon
To original poster, your test just shows an issue with disk throughput.
Are you just using internal imac drive?
Where is your project stored?
Have you tried backing up the project/archiving the audio(audio pool) etc?

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 3:17 pm
by Ivochkin
I don't know how you tested, but on my system Cubase performance is so much better than both logic's and studio one's. and I am on OSX Mojave and mbpr 2016

For example, Cubase can handle 4 instance of Roland's System-8 playing 2 voice super saws at the same time while logic 10.4.5 can handle only 1 instance and studio one only 3 of them.

I don't even say about number of plugins that can be loaded in both daws. cubase just doesn't leave a chance to all other daws. even reaper is way behind it. and I'm telling you, I was a big cubase skeptic for a long time.

your screenshot clearly shows disk overload. so performance wise it's not cubase's issue. you should better check your hardware issues before posting posts like this.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 4:10 pm
by skijumptoes
Isn't the Roland Cloud stuff plagued with CPU issues on the Audio Unit versions? I subscribed when it was first released and the CPU performance was terrible for AU at the time.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 5:24 pm
by GlennO
skijumptoes wrote:
Thu Jun 20, 2019 4:10 pm
Isn't the Roland Cloud stuff plagued with CPU issues on the Audio Unit versions? I subscribed when it was first released and the CPU performance was terrible for AU at the time.
Anytime you see somebody report a difference in performance between Cubase and Logic, something like this is the more likely explanation than some deficiency in one of the DAWs. The other likely explanation is that conditions for the tests were not equal and apples were being compared to oranges. That seems to be the case for the results reported in this thread.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 7:26 pm
by shanabit
Most of the time it is guys using the internal drives for everything

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Thu Jun 20, 2019 7:43 pm
by skijumptoes
With Macs a lot depends on thermals too, if you go from one DAW to the other and you're pushing the CPU then the earlier tests may come out stronger than the later ones due to throttling. Particularly on Macs with discrete cards and higher clock/temp CPUs. That's why a benchmark test really needs to be ran for a reasonable duration at high load.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Fri Jun 21, 2019 4:43 am
by James K
ckon wrote:
Thu Jun 20, 2019 3:12 pm
To original poster, your test just shows an issue with disk throughput.
Are you just using internal imac drive?
Where is your project stored?
Have you tried backing up the project/archiving the audio(audio pool) etc?

Yes you are correct. It looks like a hard disk reading issue?

All 3 daws in the comparison were reading from the internal iMac disk. No external disks were involved in any way.

So why would Cubase have issues reading my internal HD when the other DAWS do not?

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Sat Jun 22, 2019 6:52 am
by James K
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.

I see you did you test on Logic Pro X 10.4.4.
Any chance you could run your test on Logic Pro X 10.4.5 to see if it's the new version that provides better performance?

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Sat Jun 22, 2019 8:05 am
by GlennO
James K wrote:
Sat Jun 22, 2019 6:52 am
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.

I see you did you test on Logic Pro X 10.4.4.
Any chance you could run your test on Logic Pro X 10.4.5 to see if it's the new version that provides better performance?
Better performance than what? Anyway, I get the same result with 10.4.5. I've gotten the same result with various versions of LPX going back quite a ways. This is just further evidence that the DAW has very little influence on the performance of plugins. Why anyone would think it does is a mystery to me.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Sat Jun 22, 2019 8:50 am
by James K
GlennO wrote:
Sat Jun 22, 2019 8:05 am
James K wrote:
Sat Jun 22, 2019 6:52 am
GlennO wrote:
Thu Jun 20, 2019 10:46 am
My performance tests don't show a difference.

viewtopic.php?f=283&t=162153

It's possible you've found a difference, but the more likely explanation is you've got some settings different in your tests. Those DAWs have performance-related preferences that can affect a test like this.

I see you did you test on Logic Pro X 10.4.4.
Any chance you could run your test on Logic Pro X 10.4.5 to see if it's the new version that provides better performance?
Better performance than what? Anyway, I get the same result with 10.4.5. I've gotten the same result with various versions of LPX going back quite a ways. This is just further evidence that the DAW has very little influence on the performance of plugins. Why anyone would think it does is a mystery to me.

You seem to be obsessed that the only thing affecting a DAWs performance is plug ins. We already identified in this thread that it's the disk read over loads that are showing the issue in C10 on my system. Look at the performance meters in Studio One and Logic which have no issues compared to the performance meter of Cubase 10s.

The point once again is that C 10s performance ( including disk performance ) is not as efficient as the other 2 DAWs when considering optimizing all possible settings in each DAW.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Sat Jun 22, 2019 9:28 am
by DaveAbbott
Hi All

I can’t help but wonder why people spend so much time playing around with things like this instead of making music.

Best Regards, Dave

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Sat Jun 22, 2019 10:22 am
by peakae
BTW. Performance meters are highly unreliable, you can't compare performance using those.
Fill up with plugins until I starts to crackle, then back off until the audio is stable.
Make sure no track is armed for recording,

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Mon Jun 24, 2019 7:54 am
by James K
Obviously I'm experiencing disk overloads which is affecting C10s performance.

It's a pretty reasonable question to ask when compared to the performance of the 2 other DAWs.which do not experience disk over loads using the same audio files and same plugins.

What a helpful forum lol

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Tue Jun 25, 2019 5:22 pm
by ckon
Did you backup/archive the project as I suggested? Whats the sample/bit date rate? Are you realtime stretching/pitch shifting?

Hard Disk speed and access should be no different between DAWs. It seems odd that disk overloads are occuring.
What a helpful forum lol
Dude, ignore unhelpful comments and be thankful for those reaching out!

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Tue Jun 25, 2019 8:27 pm
by shanabit
If I recall and I do, it was recommended to use a secondary drive for all Cubase projects since way back when. Im guessing this is an old code area in Cubase

This points to the fact that you are more than likely correct, Cubase is not optimized well to run off an internal HD. I bet an SSD would fair better?

I have and use all three DAWS you are quoting there. I haven't had any reason to test them though as I never use the internal drive here for any Projects

Carry on

It would be interesting for you to do the test using the Mac sound card and not the Steinberg interface just to see what ya get there.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Wed Jun 26, 2019 12:38 am
by mr.roos
I don't know, I find this interesting. I've recently built a new PC DAW and even though I've upped my memory, my cores, moved from Win7 to Win10, and now run all SSDs, (internally), I do have a better Cubase experience and more 'ease of use' with the added power - but - eh, the Average Processing Load bar still reacts more than I had hoped for. Sure, with my 4 core Win7 DAW the Processing Load bar did go higher than with my new 6 core processor but plugins like Ozone 8 Advanced still suck some juice. I think this test is accurate.

Re: Performance Test C 10.0.20 vs Logic Pro 10.4.5 vs Studio One 4.5

Posted: Wed Jun 26, 2019 12:54 am
by GlennO
You have 37 tracks in your cubase session, but only 2 audio files, is that right? While I don't know what your problem is or why only Cubase is showing the i/o overload, I can tell you it is unusual for Cubase to have a disk i/o overload on a session like that and I think that's probably why you haven't received many responses to help you solve your problem. It would not be unusual however, for an 8 year old hard drive to have problems.