i7 PC yet can't run 1 vsti without spiking all the time

Find topics on computers, studios and music-related hardware.
Post Reply
coxy46
New Member
Posts: 1
Joined: Wed Apr 25, 2018 10:39 am
Contact:

i7 PC yet can't run 1 vsti without spiking all the time

Post by coxy46 » Wed Apr 25, 2018 10:51 am

Hi Guys,
I have been a long term Cubase user from way back in the original VST days.
My current setup is as follows:
Cubase 9.5 Pro
i7 4790
16GB Ram
2 x 256SSD disks (one for windows the other for cubase and plugins)
Absolute 3 Vsti's
RME Raydat PCIe audio interface mated to a Behringer ADA8200 preamps and outputs
Windows 7 Pro
Using built in graphics - Intel HD4600

I have done a completely new reinstall of everything so everything is fresh.
As far as I am aware everything is up to date.

The problem is I can only run Cubase at 512 samples (at 44.1khz) if I want to run more than one Vsti at once.
Anything lower and it just spikes continuously.
At 32 samples (which the RME can handle), it's idling real time cpu (F12) is around 30% and when I hit play it just spikes continuously.
Yet when I do a ctrl alt delete and look at the resource monitor when it's playing , it's only around 30% and lowers to 20% ish when stopped.

Am I expecting too much from my machine, or is there something wrong?
Would be interested in your thoughts as at the moment I can't have more than one vsti playing without having to freeze the previous one and play one live otherwise the latency is too large for me to play my drums and piano accurately enough.

Any help would be much appreciated.

Romantique Tp
External Moderator
Posts: 3014
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: i7 PC yet can't run 1 vsti without spiking all the time

Post by Romantique Tp » Wed Apr 25, 2018 7:14 pm

Take a look here, specially steps 4 and 6, 7, 8, 9:
https://helpcenter.steinberg.de/hc/en-u ... s-for-DAWs
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

mixtur
New Member
Posts: 20
Joined: Sat Dec 26, 2015 2:53 pm
Contact:

Re: i7 PC yet can't run 1 vsti without spiking all the time

Post by mixtur » Fri May 04, 2018 12:25 am

I´ve been troubleshooting music workstations for 25 years now, and I am still learning.

Here are a few things that can really interfere with real time audio.

Wifi: Try to switch it off completely to see if that helps. In fact, try to disable any type of network interface for troubleshooting purposes.

Connected USB-devices like cameras, external drives etc can also raise cause issues from time to time.

Then you can move on to close out background processes like file synchronization (ex drop box), security software and so on. I have chrome open with about 20 tabs, and it generates 1+% CPU-spikes every now and then (probably scripts and page re-loads). A process/performance monitor utility can help you track this down.

Energy saving schemes is another typical source of issues. Check your BIOS settings as well as windows settings and make sure they are set to something like "Always On" or "Maximum Performance".

Last but not least, clear your cubase path to exclude any plugins on the path (Channels, sends, master). Keep it clean while recording, and then you can start to adding plugins. One bad plugin can ruin the whole party.

Poor graphics drivers can be the cause as well. Don´t update if you ´don´t have to. NVIDIA has been causing issues with real time processes for the last 10 years on and off. I personally run the driver that comes with windows and never download the latest one from NVIDIA.

There is a tool called DPC latency checker that can help you troubleshoot this: https://www.thesycon.de/eng/latency_check.shtml

By the way, most plugins use only one core, so it can still max out even if the other cores are almost idling.


Good luck!
Last edited by mixtur on Fri May 04, 2018 12:28 am, edited 1 time in total.

User avatar
Clark Kennt
Junior Member
Posts: 62
Joined: Tue Apr 17, 2018 4:24 pm

Re: i7 PC yet can't run 1 vsti without spiking all the time

Post by Clark Kennt » Fri May 04, 2018 12:41 am

1. which plugin is causing the issue
2. why have a seperate drive for cubase&plugins -> put them all on c: and use the other drive for vst data/samples
3. Do not deactivate your network card if you have waves plugins as they rely on the network card for authentication
4. An offline DAW is a happy daw.. -> go offline (if you are online) deactivate your antivirus and windows defender etc. to see if it helps.
5. Try deactivating asio guard and boost audio priority
6. It could be anything really... you need to troubleshoot one step after the other.
7. Good night.
---Superduperman---

Rob335
New Member
Posts: 12
Joined: Thu Jan 30, 2014 5:21 pm
Contact:

Re: i7 PC yet can't run 1 vsti without spiking all the time

Post by Rob335 » Tue May 08, 2018 8:03 pm

I had exactly the same trouble with my 4790 and was getting spikes with one instance of Omnisphere. Just playing a simple analog pad.
I found that turning off C steps in the BIOS fixed this. I then proceeded to duplicate the same track until I had 20 copies and on playback the real time peaks were gone.
I stopped at 20 satisfied that I had found the issue. Haven’t seen a real time peak since.
C steps is part of my ASUS boards BIOS set up.
It’s to do with energy management and as someone posted above these things should be turned off in bios.
Go into your BIOS and find your way to the CPU features.
Google the names of the different features and if they sound like power management/ throttling features disable one by one and retest between each change.
Good luck!
|Cubase 9 pro|Windows 10 pro|Asus 797m plus mb |4790k|Geforce GT 610|RME UFX

Post Reply

Return to “Computer/Studio Hardware & Setup”

Who is online

Users browsing this forum: No registered users and 6 guests