Page 1 of 1

ASIO glitching? Please help!

Posted: Mon May 13, 2019 9:55 am
by Damozoid
Hi there. I recently got myself a new PC because my last one had a problem playing back and recording audio that I was never able to solve, so I assumed it must just be a knackered out old computer, but I'm having exactly the same problem with my new one and I'm fed up with it!

I run Cubase 8 through a Focusrite Scarlett 2i4 interface on Windows 10 (my previous PC was Windows 7) - the PC has 16GB of RAM, an i7 core, and large SSD and HD drives - and I cannot record or playback for longer than 5 minutes (often a lot more frequently) without getting a 'hiccup'-type glitch. I've been working around it for a long time, mainly by not recording much actual audio, just MIDI, but I've had enough and just want things to work properly. I get this even when I just record one track of audio or MIDI, with no plugins. I've tried changing buffer size, shutting down background programs, everything I've seen on forums and videos to try and optimise my PC for audio, yet I still get the same problem. And because I was having the same kind of audio glitching when I just played back songs through my MusicBee player I assumed it must just be the PC.

HOWEVER, yesterday I tried MusicBee through the WASAPI driver instead of the Focusrite ASIO driver (bypassing the interface and playing straight out of the PC's headphone output) and the problem seemed to completely vanish! This is distressing though because it suggests that the problem is with the ASIO drivers, which seem to me to be essential to both Cubase and the Scarlett, so if for some reason my computers have an issue with ASIO I won't be able to use them properly. I don't want to have to switch to a new DAW because I really like Cubase and have been using it for years.

As I say, I've tried changing the buffer size to no avail. Are there any other things about ASIO that I should know? Any suggestions would be welcome. Thank you.

Re: ASIO glitching? Please help!

Posted: Tue May 14, 2019 9:09 am
by airflamesred
How is the cpu performing?