Inspector's 'midi channel select' is not blocking unwanted midi notes

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
Organism
New Member
Posts: 8
Joined: Mon Aug 08, 2016 11:08 am
Contact:

Inspector's 'midi channel select' is not blocking unwanted midi notes

Post by Organism » Sat Jul 06, 2019 12:24 am

Hi Cubase community.

I have a very strong desire to emulate a Groove Box, Specifically the Yamaha RS7000. I'm currently trying to patchwork a solution within Cubase with Groove Agent SE: 4 as the sampler (or maybe Loopmash), The Linnstrument doing the sequencing and the MPK mini servicing as the control knob panel.

What I'm having an issue with is trying to play dual midi sequences (a synth pattern and a drum pattern) from the Linnstrument as shown here: (LinnStrument Step Sequencer: https://youtu.be/bhy_Wx2PWVw?t=912).

In order to achieve this, Linnstrument needs to send one sequence to midi channel 1 and the drum sequence to midi channel 16.
Now the strange thing is that when I try to play a drum pattern simultaneously with a synth pattern, both patterns go to both VSTs (with record enabled on both tracks), not one pattern per VST as I would like.

I made sure to test the problem with Midi Monitor. The strange thing is that when ever I change the midi channel via the Inspector, Midi Monitor says it's receiving the currently assigned midi channel (e.g. I scroll to ch. 1, MM says it's ch. 1, ch.2 = ch.2, ch.15 = ch.15, etc). The only time when Midi Monitor says the correct incoming midi channel is when receive "Any" is enabled.

I can block entire midi controllers (e.g. Linnstrument only recording to the selected synths and the MPK mini only recording to groove agent, etc). I made sure it wasn't just the Linnstrument and the same issue happens with the Akai MPK mini (e.g. "Any" midi in = ch.1 (which is mpk's default channel), ch.2 = ch.2, ch.9 = ch.9, etc).

The only VST I've found so far that I can assign a midi channel natively within the VST itself is HALion Sonic SE: 2. It only works by going to the "MIDI" tab in HALion Sonic SE: 2's "Edit Instrument" screen and going to the "channel selection" drop down menu of the "key range" screen and selecting the desired midi channel. Every other VST including, Groove Agent, Steven Slate Drums 5, Retrologue 2, Synthmaster 2.9 and Synthmaster One accepts all incoming midi data, no matter the restrictions put on midi data in the Inspector.

Is there any way around this issue? Or is simultaneously recording different midi patterns on two separate tracks (e.g. pattern 1 to midi ch.1 exclusively & pattern 2 to midi ch.16 exclusively) from the same source (one midi controller) a feature that most people don't need?
I'd appreciate any help given.

Thanks and have a great day.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 9 guests