Mouse causing ASIO performance spikes

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
rschmid
New Member
Posts: 34
Joined: Sun Jul 26, 2015 10:11 pm
Contact:

Re: Mouse causing ASIO performance spikes

Post by rschmid » Wed Dec 14, 2016 6:52 pm

Andy,
Your below suggestion worked for me. Thanks.
-Randy
audiophobic wrote:Hi, had exactly the same problem using EWQL Spaces (based on the Play engine) and the built-in intel HD4600 graphics on both my i5 and brand new haswell i7 machines - solved it in one stroke by going to control panel - mouse - pointers and choosing Windows Inverted (system scheme).

It does change your mouse cursor to a black silhouette - but took away all of my CPU spikes/glitches whenever the mouse moved. Give it a go!

Andy
CP Pro 10, Win 10 Pro on Intel 17-6700 3.4 Ghz, 32 Gb mem, 500 Gb SSD, 2 Tb disc 7200 rpm, Nvidia 745 graphics card; Steinberg UR824
Primary VSTs: Various EastWest, Native Instruments, Spitfire Audio, Amplesound, Steinberg Absolute 3, Hauptwerk

jongorrie
New Member
Posts: 2
Joined: Sat Dec 24, 2016 2:55 pm
Contact:

Re: Mouse causing ASIO performance spikes

Post by jongorrie » Sat Dec 24, 2016 3:06 pm

Hi all,

I had this issue with Cubase 9.0.1 as well on an ASUS N53SN laptop running WIndows 7 (16GB RAM, SSD drive for OS and Cubase + HDD for extra storage), NVidia GEForce 550M graphics card, external screen, but seem to have solved it now after adjusting the VST Audio settings.

Go to: Devices >> Device setup >> VST Audio system

These are my settings, under advanced options:
"Activate multi processing": ON
"Activate ASIO guard": ON
ASIO-guard level: "High"
Audio priority: Boost
Activate *Steinberg* Audio Power Scheme: Off
Disk preload: 4
Activate: "Adjust for record latency"
Record shift: "0"

The key here seems to be these 4 settings:
"Activate multi processing": ON
"Activate ASIO guard": ON
ASIO-guard level: "High"
Audio priority: Boost


Hope that's useful for someone! :)

jongorrie
New Member
Posts: 2
Joined: Sat Dec 24, 2016 2:55 pm
Contact:

Re: Mouse causing ASIO performance spikes

Post by jongorrie » Mon Jan 02, 2017 4:26 pm

...and I may have spoken too soon. Although the above settings reduced CPU load and some spikes, the problem still exists with any track record enabled.

However, inverting the mouse pointer as described in a previous post is a workaround.

BassMasterK
New Member
Posts: 11
Joined: Fri Feb 14, 2014 6:27 am
Contact:

Re: Mouse causing ASIO performance spikes

Post by BassMasterK » Sun Jul 28, 2019 11:18 pm

I know this is an old topic but figured I'd chime in if it helps anyone else. After years of no problems, I suddenly started having the same issues with performance spikes occasionally when I would move the mouse during playback. At first it wasn't a big deal but the longer it went on the more annoyed I was getting with it. I changed the mouse to the Windows Inverted system as suggested above, but that didn't do anything.

Then when I was looking at the list, I saw Windows Aero (system scheme). It reminded me that I had recently turned Windows Aero on because I heard there was a conflict with it being off and the latest update to Halion. For the first several years on this system I had it turned off because I heard it unnecessarily taxed the graphics and I'm running this system just with onboard graphics. I changed the pointer to Windows Aero and boom....everything went back to normal and no more spikes and glitches. Hope this helps someone. I'm happy to have this issue resolved. This is on Win7 Pro x64 and Cubase 10 Pro

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 8 guests