Focusrite Liquid Mix

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
RobKellySound
New Member
Posts: 15
Joined: Sat Apr 04, 2015 12:21 am
Contact:

Focusrite Liquid Mix

Post by RobKellySound » Thu Apr 09, 2015 11:12 am

Hi all,

I appreciate the hardware I am using is somewhat old school, but I have an issue with the Focusrite Liquid Mix and Cubase Pro 8.

On OSX 10.8, the plugin windows for Liquid Mix instances are blank after the installing C8. The hardware is still sonically processing the audio, but I use the hardware to follow what plugin I have selected. There is issue with C6.5 on the same system.

This happened in Windows when I first installed C8, but reinstalling the Liquid software fixed it and they work great. I have tried this on OSX and no joy.

Windows 8, Cubase 6.5 64 bit, Cubase 8 Pro 64 bit.
OSX, Cubase 6.5 32 bit, Cubase 8 Pro 64 bit.


Thanks
Computer Specs:
Dell E6530
Windows 8.1
i7 3740QM @ 2.7GHz up to 3.7GHz, 6MB Cache.
8GB DDR3 RAM (1600MHz)
Texas Instruments FW card
7200rpm Travelstar Z7K500 Operating System Drive (internal)
7200rpm Western Digital 750BPKT Audio Drive (internal)

DAW Software, Interfaces & DSP
Cubase 6.5 (Main), 8.0.10.
Pro Tools 11.3.1 (Secondary)
Focusrite Saffire Pro 40 and Pro 24
KRK ERGO
Focusrite LiquidMix

RobKellySound
New Member
Posts: 15
Joined: Sat Apr 04, 2015 12:21 am
Contact:

Re: Focusrite Liquid Mix

Post by RobKellySound » Thu Apr 09, 2015 11:30 am

It works fine when C8 is run in 32bit mode, but it should work fine as 64bit mode is no issue in WIndows.
Computer Specs:
Dell E6530
Windows 8.1
i7 3740QM @ 2.7GHz up to 3.7GHz, 6MB Cache.
8GB DDR3 RAM (1600MHz)
Texas Instruments FW card
7200rpm Travelstar Z7K500 Operating System Drive (internal)
7200rpm Western Digital 750BPKT Audio Drive (internal)

DAW Software, Interfaces & DSP
Cubase 6.5 (Main), 8.0.10.
Pro Tools 11.3.1 (Secondary)
Focusrite Saffire Pro 40 and Pro 24
KRK ERGO
Focusrite LiquidMix

Jack Focusrite
Junior Member
Posts: 53
Joined: Fri Mar 20, 2015 2:25 pm
Contact:

Re: Focusrite Liquid Mix

Post by Jack Focusrite » Fri Apr 17, 2015 9:40 am

Hi Rob,

I'm sorry to hear that you're having some problems with the Liquid Mix software. Support for the software ended after OSX 10.6, please see our OS Checker: http://focusrite.com/downloads/os?product=Liquid+Mix

Unfortunately, since the software was not designed with your operating system in mind, you may well encounter some issues. If possible, we would recommend reverting back to a support operating system.

If you need to contact us directly you can do so through the form on this webpage: http://focusrite.com/answerbase/contact

Best regards,
Jack // Focusrite Technical Support

http://focusrite.com/answerbase/contact

pc-eater
Junior Member
Posts: 58
Joined: Wed Dec 15, 2010 7:34 pm

Re: Focusrite Liquid Mix

Post by pc-eater » Fri Apr 17, 2015 1:41 pm

Yes, there must be a lot of these units sitting on a shelf today ;-(

Maybe we got to start asking Focusrite for a update?
I've done it today!


good-luck,
Peter
Mac Pro Quad-Core 2,8 OSX 10.11.5/ Cubase VST5 --> Cubase Pro 8.5.15.x.x / RME-HDSPe-Madi/ Soundcraft XD-328/ Genelec 8050

User avatar
mroekalea
Senior Member
Posts: 1378
Joined: Thu Dec 16, 2010 11:12 am
Contact:

Re: Focusrite Liquid Mix

Post by mroekalea » Fri Apr 17, 2015 6:17 pm

Mine is eating dust (so for sale available ;-)) due to lack of legacy firewire drivers (I've seen a legacy driver but am concerned that the total stability will go down if I install the liquid mix with legacy firewire drivers), an update would be nice however the Original manufacturer is portugese syntfex or something like that, so will not happen I fear!
Menoj

If nothing goes right, go left!


Win10, 3930K@3.2Ghz, 32GB, 2 x DELL u2713hm monitors (5120 x 1440), monitoring: ADAM P22A with SUB8, Audient ID14 & Behringer XR18 & Focusrite safire pro 26IO, Cubase 9.5 pro & artist 8.5, wavelab 9.5 elements, HSO, RND Portico 5033, CC121, Cubase IC pro, Halion 6, GA4, VG2, Arturia Analog Lab, TRacks CS grand + all custom elements, BFD3, Amplitube 3&4 (fender, orange, SVX collections, slash), Z3TA+2, HSO library, many Waves plugs, Plugin Alliance plugins (BX, SPL, Maag & Elysia), NI Komplete 11 Ultimate, AIR instrument expansion pack v3, Melodyne Studio v4, Soundtoys 5, Lexicon native PCM reverb bundle, UJAM Virtual Guitarist complete bundle, SoniVox Premium collection, Ezkeys upright & Vintage Fender Jazz basses, Fender Bassman 100, Markbass TTE500 , FMC Neo 2128 cab

RobKellySound
New Member
Posts: 15
Joined: Sat Apr 04, 2015 12:21 am
Contact:

Re: Focusrite Liquid Mix

Post by RobKellySound » Mon Apr 20, 2015 7:36 pm

mroekalea wrote:Mine is eating dust (so for sale available ;-)) due to lack of legacy firewire drivers (I've seen a legacy driver but am concerned that the total stability will go down if I install the liquid mix with legacy firewire drivers), an update would be nice however the Original manufacturer is portugese syntfex or something like that, so will not happen I fear!
Legacy drivers for Windows 7/8/8.1?

I got it to work perfectly with Windows.

http://robkellysound.com/2014/12/30/foc ... ndows-8-1/
Last edited by RobKellySound on Mon Apr 20, 2015 7:39 pm, edited 1 time in total.
Computer Specs:
Dell E6530
Windows 8.1
i7 3740QM @ 2.7GHz up to 3.7GHz, 6MB Cache.
8GB DDR3 RAM (1600MHz)
Texas Instruments FW card
7200rpm Travelstar Z7K500 Operating System Drive (internal)
7200rpm Western Digital 750BPKT Audio Drive (internal)

DAW Software, Interfaces & DSP
Cubase 6.5 (Main), 8.0.10.
Pro Tools 11.3.1 (Secondary)
Focusrite Saffire Pro 40 and Pro 24
KRK ERGO
Focusrite LiquidMix

RobKellySound
New Member
Posts: 15
Joined: Sat Apr 04, 2015 12:21 am
Contact:

Re: Focusrite Liquid Mix

Post by RobKellySound » Mon Apr 20, 2015 7:38 pm

Jack Focusrite wrote:Hi Rob,

I'm sorry to hear that you're having some problems with the Liquid Mix software. Support for the software ended after OSX 10.6, please see our OS Checker: http://focusrite.com/downloads/os?product=Liquid+Mix

Unfortunately, since the software was not designed with your operating system in mind, you may well encounter some issues. If possible, we would recommend reverting back to a support operating system.

If you need to contact us directly you can do so through the form on this webpage: http://focusrite.com/answerbase/contact

Best regards,
Jack // Focusrite Technical Support

http://focusrite.com/answerbase/contact
I respectfully disagree; there are no issues with the same VST plugin on older Cubase versions. The LiquidMix software works flawlessly with my Windows and OSX DAW computers; but version 8 of Cubase is the only place where issues arise.
Interestingly, version 8 on both the W8 and OSX platforms exhibit the same problem; which would further indicate it is not a LiquidMix vs. OS issue.

Thanks.
Computer Specs:
Dell E6530
Windows 8.1
i7 3740QM @ 2.7GHz up to 3.7GHz, 6MB Cache.
8GB DDR3 RAM (1600MHz)
Texas Instruments FW card
7200rpm Travelstar Z7K500 Operating System Drive (internal)
7200rpm Western Digital 750BPKT Audio Drive (internal)

DAW Software, Interfaces & DSP
Cubase 6.5 (Main), 8.0.10.
Pro Tools 11.3.1 (Secondary)
Focusrite Saffire Pro 40 and Pro 24
KRK ERGO
Focusrite LiquidMix

User avatar
mroekalea
Senior Member
Posts: 1378
Joined: Thu Dec 16, 2010 11:12 am
Contact:

Re: Focusrite Liquid Mix

Post by mroekalea » Mon Apr 20, 2015 7:42 pm

RobKellySound wrote:
mroekalea wrote:Mine is eating dust (so for sale available ;-)) due to lack of legacy firewire drivers (I've seen a legacy driver but am concerned that the total stability will go down if I install the liquid mix with legacy firewire drivers), an update would be nice however the Original manufacturer is portugese syntfex or something like that, so will not happen I fear!
Legacy drivers for Windows 7/8/8.1?

I got it to work perfectly with Windows.

http://robkellysound.com/2014/12/30/foc ... ndows-8-1/
Wauw I got used to the idea that mine focusrite saffire pro 26 and my liquid mix where doing nothing that I forgot to checkup on drivers and solutions, thanks man! Will try this out :D
Menoj

If nothing goes right, go left!


Win10, 3930K@3.2Ghz, 32GB, 2 x DELL u2713hm monitors (5120 x 1440), monitoring: ADAM P22A with SUB8, Audient ID14 & Behringer XR18 & Focusrite safire pro 26IO, Cubase 9.5 pro & artist 8.5, wavelab 9.5 elements, HSO, RND Portico 5033, CC121, Cubase IC pro, Halion 6, GA4, VG2, Arturia Analog Lab, TRacks CS grand + all custom elements, BFD3, Amplitube 3&4 (fender, orange, SVX collections, slash), Z3TA+2, HSO library, many Waves plugs, Plugin Alliance plugins (BX, SPL, Maag & Elysia), NI Komplete 11 Ultimate, AIR instrument expansion pack v3, Melodyne Studio v4, Soundtoys 5, Lexicon native PCM reverb bundle, UJAM Virtual Guitarist complete bundle, SoniVox Premium collection, Ezkeys upright & Vintage Fender Jazz basses, Fender Bassman 100, Markbass TTE500 , FMC Neo 2128 cab

RobKellySound
New Member
Posts: 15
Joined: Sat Apr 04, 2015 12:21 am
Contact:

Re: Focusrite Liquid Mix

Post by RobKellySound » Mon Apr 20, 2015 7:46 pm

mroekalea wrote:
RobKellySound wrote:
mroekalea wrote:Mine is eating dust (so for sale available ;-)) due to lack of legacy firewire drivers (I've seen a legacy driver but am concerned that the total stability will go down if I install the liquid mix with legacy firewire drivers), an update would be nice however the Original manufacturer is portugese syntfex or something like that, so will not happen I fear!
Legacy drivers for Windows 7/8/8.1?

I got it to work perfectly with Windows.

http://robkellysound.com/2014/12/30/foc ... ndows-8-1/
Wauw I got used to the idea that mine focusrite saffire pro 26 and my liquid mix where doing nothing that I forgot to checkup on drivers and solutions, thanks man! Will try this out :D
I was giving out to Windows about the legacy driver issue. There were quite a few photography people doing the same, and to be very fair to Microsoft; they released the legacy driver. I was shocked! So happy that the software provider would go to that effort. Steinberg, on the other hand. I feel like such a guinea pig since getting version 8. Reminds me of the day I purchased Version 6.5 about 4 hours outside of the grace period update for V7. :roll:

Best of luck with the Liquid Mix, it is a great unit.

EDIT: I had not realised that the old Pro 26 would have been hit by the same legacy issue. Please keep in touch as I would be more than happy to edit the website post so more people can be included. I was just focused on the Liquid Mix as I own the newer Saffires.
Computer Specs:
Dell E6530
Windows 8.1
i7 3740QM @ 2.7GHz up to 3.7GHz, 6MB Cache.
8GB DDR3 RAM (1600MHz)
Texas Instruments FW card
7200rpm Travelstar Z7K500 Operating System Drive (internal)
7200rpm Western Digital 750BPKT Audio Drive (internal)

DAW Software, Interfaces & DSP
Cubase 6.5 (Main), 8.0.10.
Pro Tools 11.3.1 (Secondary)
Focusrite Saffire Pro 40 and Pro 24
KRK ERGO
Focusrite LiquidMix

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 10 guests