Page 3 of 6

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jul 07, 2015 1:27 pm
by alexis
cmaffia wrote:
ggc wrote:
cmaffia wrote: the drawbacks (if any) in doing this change?
Smooth sailing in cubase:p
I get your response but it doesn't answer the question. Others already have "smooth sailing" without this suggested registry change. Could someone from Steinberg please comment? If your offloading graphic processing from GPU to CPU, something's obviously impacted..
My thoughts as well.In my limited understanding I had thought one of the main points about using Aero was to keep the graphic processing in the GPU, so more CPU was available for "music"?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Jul 12, 2015 3:38 pm
by Marsman
CanĀ“t see how this would work with nvidia cards, since settings like these are nvidia control panel related.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Jul 12, 2015 8:35 pm
by barryfell
My fix of doing a repair install didn't last long. It worked for about a month but now Cubase is back to hanging on exit lots of times. I've not changed anything, and subsequent repair installs haven't fixed it, so who knows what's causing it. :(

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Jul 13, 2015 8:47 am
by matjones
Had an iLok driver update a few days ago..... problem seemed to go a way for a few days but i had one hang on exit yesterday...... strange......

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Jul 17, 2015 4:29 pm
by GeoMax
I did notice that turning off the VSTs in the rack before saving my project, and then exiting... seemed to help when I was experiencing this. I have a new build and PCIe interface. I have not had any issues, yet. My video card is NVidia GeForce GTX 780. I am running on Windows 7(64). I have not applied any of the registry edits suggested here in this thread.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Aug 06, 2015 1:49 pm
by dickiedrummer
I came across this thread today, and have recently installed Windows 10. I thought I'd give this registry change a quick try.... must admit I was very surprised to see all the random ASIO peaks completely (so far) disappear. Whaddya know? It worked :)

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Aug 10, 2015 3:10 pm
by Whatisvalis
Does anyone experience crazy real time peaks with ATi graphics cards?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Aug 11, 2015 9:31 am
by JTRake
Hi
Upgraded to windows 10 and had real bad crackle and pops while using Cubase 8.
When starting up Cubase all was fine but after a short while the crackle and pop/"static noises" began, and only got worse while using Cubase.
I added this registry entry and the problem is gone. No more crackle and pops.

I have had a lot of problems when running with the Nvidia chip on my laptop. No problems when the Intel HD has been the active card. The laptop uses the Nvidia chip when running external displays and the Intel for the internal so I have not been able to run Cubase, trouble free, with external display until now. Tried the latest Nvidia drivers etc with no luck. So glad I finally got rid of the problem, back to composing and tracking now. Just hoping this registry entry wont give other problems.

UPDATE/SOLVED: Because the problem obviously was gfx card related I tried to totally remove the gfx card drivers an tried to reinstall them but the problems did not go away. Finally I whiped the OS drive and did a clean install. Let Windows install all drivers and now everything seems ok, for now. Running without the reg fix. My problems was OS/drivers related, not Cubase.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Aug 13, 2015 2:12 pm
by wo1
Turning off graphics acceleration helped me also, but I've also found another solution
Crashes happens mostly with ATI cards, not only in Cubase, but also in Reaper.

I've found old, bulletproof and working drivers for my ATI card. Removed latest drivers, reboot, installed that old package --- 13-12_win7_win8_64_dd_ccc_whql.exe, reboot again and whooa!!! No more crashes at all with Cubase 8.0.20 / 7.5.40 and Reaper.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Aug 13, 2015 5:11 pm
by Sonik
Waves V9r29 installer - August 13th, 2015

The new Cobalt Saphira available separately as well as in Mercury, Pro Show and SD7 Pro Show.
Butch Vig Vocals: Sensitivity LED now properly responds to signals from both left and right channels.
Doppler no longer crashes in AudioSuite while processing 4 mono tracks.
Reel ADT: VCO movement now stays limited to VCO range when using the mouse wheel or arrow keys.
GTR: Fixed microphone selection mismatch in some cabinets.
Stomp Distortion: Fixed an issue where Tone and Contour may stop working in some cases.
H-Delay: Note division and MS is now properly saved in MultiRack SoundGrid snapshots when using tap tempo.
IR-1, IR-L, IRLive: Fixed IR locating issue under MultiRack after changing the name of the folder containing imported IRs.
MetaFilter: Fixed LFO sync issue in Cubase/Nuendo.
SoundShifter Pitch: Fixed latency issue under AudioSuite when shifting down.
SoundShifter Pitch no longer creates a fade in on the first region when processing several regions under AudioSuite.
TG12345: Switching presets now advances properly (within each category) instead of in alphabetical order.
Waves Tune, Waves Tune LT: Fixed possible crash in offline processing.
Waves Tune, Waves Tune LT: Copy/Paste Notes was removed from the menu.
X-Crackle: Fixed processing at 96kHz on SoundGrid.
NLS: Drive no longer affects the noise level.
Scheps 73: GUI expand/collapse state is now properly saved in sessions.
Final Cut Pro: Fixed GUI corruption when plugins are instantiated during playback.
Cubase/Nuendo: Fixed possible crashes on Mac when closing and reopening sessions.
Cubase: Plugins with Noise no longer crash when inserted in instrument tracks.
Pro Tools 11 & 12: Fixed various issues with resetting (Alt+Click) controls.

Testing it right now...

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Aug 14, 2015 6:30 am
by Sonik
Yesssssss! After almost a day, working on many different projects it worked without a crash...

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sat Aug 15, 2015 1:49 pm
by lucky909091
I tried this with partial success:

the audio peaks are gone but the measurement numerics at the head of the listen editor
are gone, too.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Aug 21, 2015 7:20 pm
by Buzz
I have a multiple boot win7/8 system which has been rock solid for at least a year. Don't think I ever had a crash.

I added another partition with Windows 10 recently and experience the "Peaky" performance issue right away.
I have never had this before. So I dug around a bit and found this thread. I applied this regedit,
rebooted and problem has vanished!

So you're putting a new (32bit) D word 'GraphicsAcceleration' in:

[HKEY_CURRENT_USER\Software\Steinberg Media Technologies GmbH\Steinberg Cubase 8 64bit]
"GraphicsAcceleration"=dword:00000000
Well worth giving a try for those having issues. I also believe disabling C-States in bios may be important!
Buzz

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sat Aug 22, 2015 12:12 pm
by dman2014
On my PC, with C8, I found that if I close the project using the X in the top right and then wait before doing anything else - including clicking again to fully close C8 - then I don't get the on-exit crash.

If I don't wait a moment after the first X click to close the project, then it tends to crash. I have found too that if I use the File..Close menu route, it tends to crash.

I have used this way to avoid the exit-crashes consistently. Whether that's down to Cubase or a VST/VSTi, I have no idea, but it has worked for me.

It's a problem, though, still. You would expect to close the door without it falling off the hinges.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sat Aug 22, 2015 2:19 pm
by Blackout
why the install for Cubase doesnt do this registry hack for us i dont understand!

i hope you are incorporating this regedit into the new C8 update installer Steinberg!

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Aug 23, 2015 1:44 am
by Brian Roland
I gave it a try.

CuBase 8.0.20.486 64bit, Windows 7 64bit.
AMD Phenom II X6 1090T, all cores active, locked, and stable at 3.6ghz
ASRock A770DE+ Motherboard @ 8gig DDR2 dual channel RAM running at 800mhz but with super tight timings.
Stock FSB, PCIe, and PCI, timing.
XFX/ATI R9 270 running at stock speed.
A couple of Cheap PCIe to SATA3/USB3 cards (lost track of what type/brand they are).
M-Audio Delta 1010 PCI audio
Tascam 1200 USB2 Audio
Samsung 830 and 840 SSD
PNY (Forgot the model numbers) SSD
WD Raptor Class SATA2 Drives

For me this registry hack rendered CuBase totally unusable.

It loaded up my project fine, but when I hit play, it just sat there and did nothing. I'd click a menu or button, and it'd take 30 seconds or so before it would react! It was so sluggish I ultimately gave up on closing out CuBase, and used the Task Manager to kill the process. Rebooted, tried it again...same results :(

Upon reversing the Hack, it went back to normal. In general CuBase 8 works well for me. Other DAWs, Scoring Packages, and Live VST hosts I've tried have similar performance on this machine.

Note, for the most part my rig works pretty well. I did experience some problems with some plugins 'dropping out/glitching', and tracked it down to two PNY Brand SSD drives I was trying to stream the plugin samples from. I'd tried the same drive on various SATA2 and SATA3 hosts/ports, etc. When I moved everything OFF of the PNY SSD drives, 99.9% of my VST glitches went away!

I ignore the 'VST Performance Monitor'. That's just telling me that ASIO Guard is working to correct latency for whatever track I have 'armed' for recording. This meter seems to be confusing/upsetting people who aren't realizing any 'real problems'. So what if the meter shows the ASIO Guard buffer is filling up (spiking)? That's what it's there for! To give the system a moment to recalculate and make corrections for the latency on your 'armed' track(s). I don't think it's even relative to CPU use, or any other system resources.

Note, if you do NOT have any tracks armed for recording, this meter tends to sit pretty idle.

Note, if you disable ASIO Guard, you'll probably need bigger ASIO Buffers (For me I start at around 512kb on this really old/slow rig, and add on as I need it...while I could probably get by with 128k or smaller...I just go ahead and start with some headroom). Make use of live-monitoring if your audio device supports it. You'll need to make the ASIO Buffers larger as the project grows in scope and complexity, and while you may see fewer 'spikes', you'll see larger average Monitor activity. You'll also miss out on some latency correction features for whatever track(s) you have armed for recording (the idea is to give the tracks that are being recorded priority so your live playing doesn't seem to be half a second ahead of the sound you hear).

I've learned that any VST glitches I get that I can actually hear, so far has to do with my really old, budget build piece of junk PC. I've also learned that part of my problem was trying to force newer/faster protocols on such an ancient motherboard, memory, and processor. I.E. I get more stable DAW and VST performance with older AV optimized SATA2 drives right off the motherboard than I do with my shiny new SATA3 SSD drives!

In the case of those PNY drives...they were giving massive short bursts of data, saturating the bus, and for whatever reason didn't give another burst in time to keep the stream running steadily. One of the more obvious hints was that more than one plugin kept reporting 'disk loss' counters upon their attempts to 'stream' samples. I found the drives to be problematic on my system if used for system/page files well. In my particular system, they can be really fast drives for large bursts of data where timing/latency or streaming isn't critical, but they absolutely SUCK at any sort of streaming or rapid read/writes to a single file (when trying to use one as home to OS page files...the system would often lock up for short periods of maybe half a second before resuming).

In contrast, the Samsung drives have been fine.

Now I only have one plugin that sometimes glitches if I load something like a 20 velocity layer piano! In this case I can usually get rid of any glitches by making sure no tracks are armed for recording, and letting the track play all the way through at least once (subsequent replays find more in RAM, and are asked to 'stream' from disk less at this point). Again, I'm pretty sure this has to do with my ancient system, and the hodge-podge of SATA controllers and other mess I have crammed into slots over the past decade or so. These days I simply do my composite with a lighter patch, and wait until the last mixing stages to load up the heavy version. If it glitches while I'm doing my mix-down (use the automation lanes...tracks do not have to be armed for recording that way) I just ignore it, as I know it won't be there when I use instant render.

At the end of the day...I've tried a few different DAWs and scoring packages...and they all suffer with similar issues on this particular PC. I learned months ago not to stress over the CuBase 'VST Performance Monitor'. Ignore it....unless you 'hear a problem'...just let ASIO guard do its job.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Aug 24, 2015 2:34 am
by inoran
So this issue will be reflected on next update (8.0.30), right?

I hope the update would be released soon.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Aug 24, 2015 7:33 pm
by eddiemacarthur
tried it. Cubase still hangs on exit about a third of the time.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Aug 25, 2015 4:55 pm
by barryfell
Interesting, I'm hardly getting any crashes on exit now I'm on W10. I've only see it happen a couple of times in the last couple of weeks since upgrading.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Aug 25, 2015 10:27 pm
by matjones
In the 2 weeks since i last posted i've updated my GPU drivers to the latest version, had another iLok update and have also updated eLC and i've only had ONE hang on exit in the past week..... my money's on the GPU driver in my own case......

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Wed Aug 26, 2015 4:44 am
by nick galea
I can confirm this also worked for me.

I used it on Fabfilter, Waves, izotpe & wavefactory trackspacer so far.

i watched it and it keept dropping my asio meter.. I have a good %10 under redline now & very stable on the project i was testing.

I tested it on 3 macs & good reulsts.

I had the same issues on my mac pro 12 core 3.33ghz laptop 15' retina & my hakintosh 4790k..

all fixed & no crash on exit.. very snappy.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Sep 07, 2015 9:23 am
by djgraver
nick galea wrote:I can confirm this also worked for me.

I used it on Fabfilter, Waves, izotpe & wavefactory trackspacer so far.

i watched it and it keept dropping my asio meter.. I have a good %10 under redline now & very stable on the project i was testing.

I tested it on 3 macs & good reulsts.

I had the same issues on my mac pro 12 core 3.33ghz laptop 15' retina & my hakintosh 4790k..

all fixed & no crash on exit.. very snappy.
where is the destionastion folder for iZotope,Waves ? cant find Waves & iZotope folder to put GraphicsAcceleration 0


BTW maybe it help to someone

i5 4670
16gb ram
Intel HD graphics 4600

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Sep 08, 2015 8:45 am
by nick galea
So this is weird.

Just had had massive cpu spike on my mac & it would not play any audio on project that was fine all day.

interestingly cubase was showing a 400% usage on my video card haha.. I suggest everyone get the monitor app for mac.

So i did the graphic acceleration hack to cubase & restarted, my cubase project instantly opened & now is working again,
the cpu usage has also dropped on cubase..

Im happy it is working but im so confused.. lets hope cubase can sort out all these bugs.

but happy days she is working :D

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Sep 13, 2015 9:57 am
by ggc
Cubase 8.03 fixes this issue... for me... it was safe to revert to gpu again... again, for me.. :p - maybe also for you;)
(P.s. cubase 8.03 seems to be straining my cpu more than the previous version - for me, hopefully not for you; )

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Sep 13, 2015 1:59 pm
by barryfell
Yeah so far 8.0.30 seems to have solved the issue for me as well, which I was occasionally getting, especially if I opened a project then quickly closed it.

Still got the real time bounce issue and occasional zero progress bar bounce issues, but it's not the end of the world, just a bit annoying.