[Windows]USB Midi Device Not Recognized After CB8 Is Running

All feature requests and suggestions for upcoming releases of Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 can be posted here.
jpack
New Member
Posts: 12
Joined: Sat Oct 31, 2015 10:53 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by jpack » Sun Feb 07, 2016 5:16 pm

I have the same. Sometimes I have to restart cubase many times if I want my MIDI cotroller to work. I saw that this issue is since 2013. Why Cubase team can't solve it? it is really annoying!

tepa
Junior Member
Posts: 120
Joined: Wed Jan 12, 2011 8:28 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by tepa » Fri Feb 12, 2016 3:52 am

Recently on Gearslutz, someone asked exactly that problem to Pete Brown (Microsoft Program Manager).
It's certain that if Steinberg updade their software to that new MIDI API we will get many benefits from it.
I really hope it's not going to take years to have an update on this MIDI API, on my side over all I really wish the multi-client access to single MIDI hardware.
https://www.gearslutz.com/board/music-c ... re-58.html

Here is the copy of the messages :
--------------------------------------------------------------------------------------------------------------------
Hi Pete,

I am sure this has been answered before but couldn't find any info. I am on W7 and they work perfectly for me. However, I some things really bug me compared to when I am working on OSX so can you please let us know if on W10:

1. Do Windows let a USB midi device be recognised while a DAW is running? This is very annoying because in most production studios there are several USB midi devices (controllers, keyboards, stuff like Maschine etc) and it's very common to decide and turn one on while your DAW is running. On W7 you have to stop your project and restart your DAW. Is this behaviour fixed on W10?

2. Is the Midi Device limit (registry) still happening? Again, very easy to reach 10 midi devices and the point when a PC won't install new midi devices. Is this limit removed?

3. Do W10 still reinstall the drivers for USB devices when you connect them to a different USB slot?

All these little nuisances would make me switch to W10 which seems well received. But as I said W7 is behaving well for me so I would like to give it up for some benefits.

Thanks in advance


---------------------------------------------------------------------------------------------------------------------
1. Up to the DAW developer. Windows supports detection of new devices. With the new MIDI APIs, for example, I've tried to make sure our examples show how to do that. I think with the old APIs, folks just didn't both.

2. It happens. It's because many device vendors do not follow the USB specs and offer up the IDs required by USB. (I don't think the limit is 10, but it's been a bit since I tested.) So each time you move the device around, it ends up with a new ID because we can't tell it was the old device. We can't just go by its type because many people have multiples of the same device on their system (think two launchpads, for example)

3. See #2 .

So it's on the app developers and device manufacturers. BUT, we (Microsoft) need to provide better guidance up front, which we are doing with the new APIs. No one ever bothers to go back and update old stuff, unfortunately, so we haven't put a ton of effort into trying to get vendors to update the old stuff.

Pete
Last edited by tepa on Tue Feb 16, 2016 3:40 am, edited 3 times in total.
Nuendo 10 (last version) / Cubase 9 / Win Pro 10 / i9-9900K 4.8 Ghz / RAM 32G / RME UFX / RME FF800 / UAD 2 (1 Octo & 1 Quad) / SSD / nVIDIA

bemushroomed
New Member
Posts: 41
Joined: Mon Dec 01, 2014 5:14 am
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by bemushroomed » Mon Feb 15, 2016 9:06 am

Really sad to see that this isn't implemented. I was googling for this feature (as i was sure it was in there) and found this thread.

I have to start up for example my Moog Sub37 and Beatstep Pro, even though i'm not sure if im gonna use them, but just to be sure that i dont need to close down and start up Cubase again if i want to use them. It's really annoying since many times these units are on four hours or for a whole day and i didn't use them. I really wish i could turn them on when i need them.

dac21j
New Member
Posts: 4
Joined: Fri Jan 04, 2013 3:44 am
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by dac21j » Sun Feb 21, 2016 3:47 am

+1

I have gotten so used to this limitation that I power EVERYTHING on before Cubase is booted - I didn't even know there was an alternative add as you go approach, at least for the MAC (Doh!).

I then sit in a very hot room while I go through my creative session with devices that don't even get used. Right now Cubase 8.5.10 seems to have introduced an issue/bug(?) where my Yamaha S90ES's midi port are no longer getting mapped any more... This is my main sound source outside of Steinberg and Third Party Software plugins.

Steinberg - I have trawled the complete thread and didn't notice any response from the Mod's. Is this going to be addressed? As a loyal Atari - to Windows10 User of Cubase (READ: I've spent thousands on this product across the years) this would certainly solve a lot of my frustration with a limitation that happens way too often enough to be painful.

Cheers,
David
ukuleledac
Cubase 9.0.1
Windows 7 64bit, i7-4770 3.4GHz, 16GB, Gigabyte GA-Z87-D3HP,
Yamaha 01V96, Edirol UM-880, RME ADI-8-DS and HDSP 9652,
Yamaha s90ES, JV1080 +ExpCards, JV90 +ExpCards

DiSky
New Member
Posts: 26
Joined: Thu Jul 04, 2013 5:31 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by DiSky » Thu Feb 25, 2016 2:10 pm

+1 - Please, add a rescan midi devices !
Kontakt Stand alone does this so well.

My M-Audio Oxygen88 sometimes freeze the midi, and my only solution then is to save/close/restart cubase

Even if Oxygen 88 is still in midi device, Cubase does not receive midi.
Windows7 64
Cubase 8.5
Komplete 7 - EastWest Orchestra Platinium
Oxygen88 - BCR2000
A&H Z14 - SC205

User avatar
peakae
Senior Member
Posts: 2995
Joined: Sat Jan 05, 2013 8:15 pm
Location: Bedroom
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by peakae » Sun Mar 13, 2016 10:38 am

For the new midi API in Windows 10, Microsoft even includes some sample code that illustrates how this has to be coded. From what I can read between the lines midi over Bluetooth is going to be part of the new API soon.
Cubase Pro 10, Wavelab Elements 9, I7 3770K , win10x64, 16Gb Ram, RME Raydat, Steinberg MR816x, Motu 828mkII, Behringer ADA8200, Yamaha moXF6, Steinberg UR242, Yamaha THR 10, Grace Design m900, CMC TP, CMC CH.

tepa
Junior Member
Posts: 120
Joined: Wed Jan 12, 2011 8:28 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by tepa » Wed Apr 20, 2016 1:58 pm

peakae wrote:For the new midi API in Windows 10, Microsoft even includes some sample code that illustrates how this has to be coded. From what I can read between the lines midi over Bluetooth is going to be part of the new API soon.
It's coming, one more reason for Steinberg to update to that new MIDI API :)

---------------------------------------------------------------------------------------------
Pete comment on this just few days ago :

Just a quick note, since some folks are discovering this in the latest insider build: we now have support for Bluetooth MIDI using the ratified MMA protocol (compatible with Apple's implementation). It's in the box in the insider build, and will be in the Windows 10 Anniversary Update (Redstone 1). You pair the device (or use the pairing API inside an app) and it shows up as just another MIDI endpoint.

The reason I haven't said much about it here is that it doesn't yet apply to DAWs you use. As the DAWs incorporate the new Windows 10 MIDI API (which also offers multi-client support), then you'll be able to use it for bluetooth peripherals connected to Windows 10 devices (PCs, phone, Xbox, Raspberry Pi, etc.) Currently, the Windows 10 device cannot be the peripheral due to how our BTLE stack works. It's on the backlog, though.

This was a while in coming. We voted to ratify Apple's proposal last year, and then put it on our engineering list once the protocol was official. I'm happy to see it in there, because we'll be able to use the new bluetooth peripherals that have been coming out this past year.

Pete
-------------------------------------------------------------------------------------------------------------------

Message from : https://www.gearslutz.com/board/music-c ... re-72.html

.
Nuendo 10 (last version) / Cubase 9 / Win Pro 10 / i9-9900K 4.8 Ghz / RAM 32G / RME UFX / RME FF800 / UAD 2 (1 Octo & 1 Quad) / SSD / nVIDIA

User avatar
kresbeatz
New Member
Posts: 28
Joined: Wed Jul 30, 2014 7:38 pm
Location: Budapest, Hungary
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by kresbeatz » Fri Jul 22, 2016 11:19 pm

+1 for "Re-scan MIDI Devices" button, and it will be great if we can assign key command on this, or there will be new button in the toolbar for this purpose.
i7-5820 / 32GB RAM + Benq 32" + RME UFX + UAD OCTO PCIe
Cubase 10.0.15, HALion 6, Absolute VSTi+, Groove Agent 4, WaveLab 9.5
Moog Sub 37 / Elektron Analog Keys / SE Boomstar 4075 / Clavia Nord Lead 4 / DSI Prophet-6 / Neve 1073LB x2, Strymon BigSky, Strymon Mobius
Expert Sleepers ES-3, ES-5 and ESX-8MD

User avatar
Minimalist
Member
Posts: 276
Joined: Tue Jul 28, 2015 9:49 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by Minimalist » Sat Jul 23, 2016 4:29 pm

This is kind of OT but speaks to the complexity or suckyness of Windows 10 and perhaps the difficulty of programming for it. I have long assumed that Steinberg engineers use mostly Macs.

I recently had to do a clean install of Windows because it would no longer recognize the dongle at any time. If I could afford to, I would switch to Mac now.

User avatar
peakae
Senior Member
Posts: 2995
Joined: Sat Jan 05, 2013 8:15 pm
Location: Bedroom
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by peakae » Mon Jul 25, 2016 4:58 pm

Nah it's not a Windows thing, and Microsoft actually have code examples, but only for the new midi API in win 10.
Anyhow it supposed to be trivial in both midi api's.
Would Love to see the new win10 midi API used in Cubase. Mostly because of tighter midi clock and the upcoming multiclient support.
Cubase Pro 10, Wavelab Elements 9, I7 3770K , win10x64, 16Gb Ram, RME Raydat, Steinberg MR816x, Motu 828mkII, Behringer ADA8200, Yamaha moXF6, Steinberg UR242, Yamaha THR 10, Grace Design m900, CMC TP, CMC CH.

User avatar
Minimalist
Member
Posts: 276
Joined: Tue Jul 28, 2015 9:49 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by Minimalist » Tue Jul 26, 2016 5:27 pm

peakae wrote:
Would Love to see the new win10 midi API used in Cubase. Mostly because of tighter midi clock and the upcoming multiclient support.
Excellent suggestion.

User avatar
kresbeatz
New Member
Posts: 28
Joined: Wed Jul 30, 2014 7:38 pm
Location: Budapest, Hungary
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by kresbeatz » Tue Jul 26, 2016 7:56 pm

Minimalist wrote:This is kind of OT but speaks to the complexity or suckyness of Windows 10 and perhaps the difficulty of programming for it. I have long assumed that Steinberg engineers use mostly Macs.

I recently had to do a clean install of Windows because it would no longer recognize the dongle at any time. If I could afford to, I would switch to Mac now.
I think it's not just Windows behaviour. For example, you have "Reset MIDI devices" action in Reaper that works flawlessly. I have a lot of gear that connected via USB (synths, fx, etc) and it's real pain to restart Cubase every time I want to use one of them.
i7-5820 / 32GB RAM + Benq 32" + RME UFX + UAD OCTO PCIe
Cubase 10.0.15, HALion 6, Absolute VSTi+, Groove Agent 4, WaveLab 9.5
Moog Sub 37 / Elektron Analog Keys / SE Boomstar 4075 / Clavia Nord Lead 4 / DSI Prophet-6 / Neve 1073LB x2, Strymon BigSky, Strymon Mobius
Expert Sleepers ES-3, ES-5 and ESX-8MD

Photon
New Member
Posts: 36
Joined: Sat Dec 03, 2016 5:43 am
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by Photon » Mon Dec 05, 2016 9:26 pm

This is a major inconvenience. This problem has been discussed on numerous threads on this forum over a period of several years, so why hasn't Steinberg fixed it? Steinberg's unresponsiveness on this issue has made me hesitant to buy Cubase Pro 9 -- whenever it becomes available.

This issue has caused all kinds of trouble and confusion for me, with the demo version of Cubase 8 that I've been trying out.

I know this is not a Windows issue, because my demo copy of Sonar Platinum reliably detects external midi gear whenever it is plugged in.

For example, if Cakewalk Sonar is already running, I can turn on an external keyboard which is connected via USB, and Sonar will recognize it. In contrast, if Cubase 8 is already running, and I turn on the external keyboard, Cubase will not recognize it. The keyboard is recognized only after I shut down Cubase and restart it. In other words, the keyboard must be turned on and physically connected before I start Cubase, or Cubase will not recognize it.

Here are the disadvantages:
1. When I restart Cubase, I lose my undo history.
2. Having to restart Cubase is a waste of time, and it disturbs my train of thought.
3. Generally, when I'm using fussy, unreliable software, I end up wasting a lot more time on troubleshooting.

The only reason I care is that Cubase has some functions that Sonar lacks -- including better tempo editing -- so I'd prefer to buy Cubase. But I do think Steinberg should be more responsive to its customers' concerns, and I do think Steinberg should have fixed this USB hotplugging issue long ago.
Cubase 9.5.50 Pro. Windows 10. Processor: Intel Skylake i7-9800x. RAM Memory: 64 GB. Audio Interface: RME Fireface UCX via USB. Hard Drive for audio: Samsung EVO SSD. Graphics card Asus Geforce GTX 1070.

tepa
Junior Member
Posts: 120
Joined: Wed Jan 12, 2011 8:28 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by tepa » Tue Dec 06, 2016 4:21 pm

Yes it's not a Windows issue, but midi improvement/new features will only come with this new midi API that is exclusively available for Windows 10.

I don't know if it's means that if they recode on the new Midi API it will make Windows 7 unsupported because of a different/old API, just wondering.....
Nuendo 10 (last version) / Cubase 9 / Win Pro 10 / i9-9900K 4.8 Ghz / RAM 32G / RME UFX / RME FF800 / UAD 2 (1 Octo & 1 Quad) / SSD / nVIDIA

tepa
Junior Member
Posts: 120
Joined: Wed Jan 12, 2011 8:28 pm
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by tepa » Tue Dec 06, 2016 4:31 pm

peakae wrote:
Would Love to see the new win10 midi API used in Cubase. Mostly because of tighter midi clock and the upcoming multiclient support.
Exactly
A kind of revolution to PC user, and a lot less workaround ;)
Nuendo 10 (last version) / Cubase 9 / Win Pro 10 / i9-9900K 4.8 Ghz / RAM 32G / RME UFX / RME FF800 / UAD 2 (1 Octo & 1 Quad) / SSD / nVIDIA

Photon
New Member
Posts: 36
Joined: Sat Dec 03, 2016 5:43 am
Contact:

Re: [Windows]USB Midi Device Not Recognized After CB8 Is Run

Post by Photon » Wed Dec 07, 2016 7:53 am

The Windows 10 market share is still much lower than Win 7, as you can see here:
https://www.netmarketshare.com/operatin ... pcustomd=0

I reverted to Win 8.1 when I discovered that I could not install some crucial legacy software on Win 10. I have no plans to upgrade to Win 10, ever. And I'm not alone.

So if Steinberg wants to make use of some new win 10 feature, they'll have to continue supporting win 7 and 8, or lose customers.

The undeniable fact is, Sonar can detect hotplugged USB interfaces -- in Windows 8.1. Steinberg has no excuse. They need to catch up.
Cubase 9.5.50 Pro. Windows 10. Processor: Intel Skylake i7-9800x. RAM Memory: 64 GB. Audio Interface: RME Fireface UCX via USB. Hard Drive for audio: Samsung EVO SSD. Graphics card Asus Geforce GTX 1070.

Locked

Return to “Feature Requests and Suggestions”

Who is online

Users browsing this forum: No registered users and 3 guests