Mac record performance part 4

Post general topics related to Nuendo 7 here.
Post Reply
Hugh
Member
Posts: 240
Joined: Wed Dec 15, 2010 8:24 pm
Contact:

Mac record performance part 4

Post by Hugh » Wed Mar 21, 2018 5:08 am

Hello,

This post is part 4 of a Nuendo 7.x support case I’ve had open with Steinberg since early March 2017 regarding high track count recording on MacOS. Steinberg was initially responsive, then silent for several months, then after some pressure and public posturing they were briefly responsive for an email or two. There has never been an official resolution despite my extensive documentation and approximately 100 active testing hours and another 300 or so passive testing hours. Jeff Deno of Steinberg US Support was encouraging but the developers in Germany never followed up on a promised response nor offered any solutions. I would have upgraded to v8 if that was the fix but no fix was offered.

We are high profile Nuendo users in broadcast television with approximately 9 Nuendo 7 licenses running on dual- and triple-Madi systems. We also own a number of ProTools HDX-3 triple-Madi systems for those that prefer PT.

Short version of the issue -
- With high track count recording (tested from 64-192) in Nuendo 7, occasionally and unpredictably Nuendo attempts to read audio files from the record drive at the drive’s maximum read capacity. This crashes the recording obviously.
- The only fix is restarting Nuendo, not possible in a live broadcast.
- Not system dependent, it manifested on all our Nuendo 7 machines.
- Once the problem started we ran dtrace and iosnoop to generate a text file of every IO action on the DAW. This proved unequivocally that Nuendo creates the issue, not the OS or any other task, and which audio files and not waveform files are read.
- As a test a coworker set up a script that engaged record for a few minutes, stopped and waited for the files to close, updated a counter, and engaged record again. Quantity of record engagement events varied extensively before the problem occurred, anywhere from 5 to 131.

We were forced to use an old Nuendo version on an OS no longer updated and our IT folks were threatening every day to force us to remove those DAWs. That meant spending a few hundred thousand dollars on 9 new replacement PT systems. I was able to stall a bit longer by moving all the machines to a slightly newer OS and forcing Nuendo to install against it’s will.

I searched the notes for each v7 update to see if this issue was dealt with and when the “final” v7 update was released without a noted fix I was discouraged. I loaded it onto a somewhat recent OS on a test bed machine and it worked without issue for approximately 30 hours of record time with multiple record engage events. I was going to be at a show for a couple of weeks so I set up both DAWs as dual-boot so I could move back to the earlier version if there was an issue, then ran those DAWs for 6 days recording 14 hours per day as a test, along with the show, without issue.

I was moderately encouraged so I did the same thing on the next show with two other DAWs and the previous two were sent to another operator with explicit instructions that if there was a problem to boot to the earlier OS. No issues.

As I frequently remind folks who are less fact-based - absence of evidence is not evidence of absence. This problem may not be solved. However with a total of perhaps 300 hours on the updated DAWs so far they have performed better than the problem initially reported. In the last two months those v7 DAWs were used as the primary broadcast DAWs on the Grammys, Oscars, Super Bowl Halftime, NFL Honors, iHeart Radio Music Awards, and a couple more without issues. We will be updating more of our DAWs this month and will be upgrading a test unit to v8 to see how it performs despite the documented Mac v8 performance issues noted elsewhere.

I’m disappointed in Steinberg’s official support channel. In each of our facilities we have tens of millions of dollars in broadcast gear and we have support from every one of those manufacturers. I have the personal cell phone numbers of every one of their field support personnel and can call them any time and get an answer or a replacement board shipped overnight. Even the cheap gear has decent support or we don’t use it. I documented more than any other Steinberg user would have done and every correspondence to Steinberg was polite, documented, and helpful. Even my public posturing to generate some action listing all the shows we use these on was civilized. As I interpret it there are several possibilities for Steinberg’s response on this issue -
- They had no idea what I was talking about; not likely, the developers are smart folks and I was explicitly clear and helpful.
- They didn’t care as it was only one user; not likely, it is proven to be a systemic problem that could have been responsible for many of the forum problem posts that users didn’t know how to diagnose. If it affected us in that incontrovertible way it does affect others, and I even sent them a report of a fellow mixer with Cubase 8.5 and his same exact problem.
- They were too busy developing v8 and possibly knew it would not be an issue; maybe, if the “fix” for a proven systemic issue was paying for an upgrade I can see how that’s not politically ok to publish.
- Saw the issue and fixed it surreptitiously without listing it; weird, seems a little machiavellian to me since some of the listed fixes are a bit obscure.

I will update if the problem recurs and will spend yet more of my valuable time testing v8 at some point soon.
Sincerely and frustratingly,
Hugh

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest