Page 1 of 1

Install Latest Version of FLAC in Wavelab

Posted: Tue Sep 11, 2018 4:48 am
by bob99
I feel really dumb, but how do I install the latest version of FLAC (1.3.2) in Wavelab? I can only get an exe from the FLAC site. I tried the dll from Rarewares but that doesn't work. Tried renaming, etc. How do I do this?

Re: Install Latest Version of FLAC in Wavelab

Posted: Wed Sep 12, 2018 1:06 pm
by stingray
bob99 wrote:
Tue Sep 11, 2018 4:48 am
How do I do this?
I didn't know you could do this. Just out of interest, what are the advantages of the latest version?

Re: Install Latest Version of FLAC in Wavelab

Posted: Wed Sep 12, 2018 6:51 pm
by bob99
stingray wrote:
Wed Sep 12, 2018 1:06 pm
bob99 wrote:
Tue Sep 11, 2018 4:48 am
How do I do this?
I didn't know you could do this. Just out of interest, what are the advantages of the latest version?
You can do it with LAME, for MP3, which I've been meaning to try again to see if it still works.

https://helpcenter.steinberg.de/hc/en-u ... ements-7-8

That's where I got the reassurance to go to Rarewares.
Should also work for Ogg Vorbis, I would think. And FLAC. But I can't get the Rarewares FLAC dll to work, unless PG or somebody else has any ideas. It would be really handy if it could be made to work.

I was thinking maybe it would help someone who's having a very specific unusual problem with Wavelab FLAC metadata in one specific program, Native Instruments Traktor. Wavelab is currently using FLAC 1.3.0. The latest version is 1.3.2. Not sure it would help. My current thinking is the newer FLAC version probably won't help unless something else is also changed, but it might help on it's own..

https://translate.google.com/translate? ... t%3D143273
-

Re: Install Latest Version of FLAC in Wavelab

Posted: Wed Sep 12, 2018 7:58 pm
by bob99
That thread is a long boring read with me going around in circles as usual, so I wouldn't bother reading the whole thing, but the gist is, Wavelab FLAC metadata is readable in dpoweramp, mp3tag, Windows Explorer, VLC, Foobar2000, the Windows 10 built-in Groove Player and Kid3.

But not in NI Traktor.

I suggested the OP ask Native Instruments look at it because Traktor should read the Wavelab metadata if all those other programs do. But on the other hand Traktor can read FLAC metadata from every other program FLAC, so I suggested he ask Steinberg to look at it too.

Re: Install Latest Version of FLAC in Wavelab

Posted: Wed Sep 12, 2018 8:33 pm
by MrSoundman
I've also encountered a case where a FLAC generated in WaveLab could not be read by a JVC device, even though (thanks to the GPL) the device's manual states it uses libFLAC .... but doesn't say what version. I have had no issues with FLAC generated with WaveLab anywhere else, so as far as I'm concerned it's the JVC device that's at fault.

Nevertheless I have an interest in knowing how to update FLAC for use in WaveLab ....

Re: Install Latest Version of FLAC in Wavelab

Posted: Wed Sep 12, 2018 9:45 pm
by PG
I can't help. Maybe some incompatibility was introduced in 1.3.2
WaveLab should provide the 13.2 version, but I don't know when this happens.