Play - Auto fade in (unwanted)

All topics on WaveLab 9 and WaveLab Elements 9
Post Reply
nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Play - Auto fade in (unwanted)

Post by nazardo » Thu May 23, 2019 4:04 pm

Playng a waveform, if the start point has an amplitude different from 0, WL apply an auto fade in.
If it starts form an amplitude = 0 the rendering is normal (no fade in).
These is some setting to disable this auto fade in?

The setting:
File-->Option-->Audio connections-->Option Tab-->Perform Short Fade In/Out When Starting/Stopping Playback
does not affect this Fade In

My version:
Wavelab Elements 9.5.50 (build 208) - 64 bit

User avatar
Justin P
Senior Member
Posts: 2467
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Play - Auto fade in (unwanted)

Post by Justin P » Thu May 23, 2019 4:46 pm

Any plugins involved?
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Mon May 27, 2019 9:11 am

Thanks Justin!
No any plugin works.

I suppose this feature is good for mastering, to prevent undesired bump, but it's pretty not good to produce sounds for musical instruments.
For this type of use you need to be able to listen exactly the profile of the waveform.

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by S-EH » Mon May 27, 2019 5:05 pm

Hi,

With the built-in Signal Generator make a pulse sample
factory settings/preferences
now use the settings
File-->Option-->Audio connections-->Option Tab-->Perform Short Fade In/Out When Starting/Stopping Playback
turn this off
here it works I can clearly hear the first sample
this is with WaveLab 9.5.50

regards S-EH
RME Fireface 800, WaveLab, Cubase...

User avatar
Justin P
Senior Member
Posts: 2467
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Play - Auto fade in (unwanted)

Post by Justin P » Mon May 27, 2019 5:23 pm

nazardo wrote:
Mon May 27, 2019 9:11 am
Thanks Justin!
No any plugin works.

I suppose this feature is good for mastering, to prevent undesired bump, but it's pretty not good to produce sounds for musical instruments.
For this type of use you need to be able to listen exactly the profile of the waveform.
Hmm. Sometimes I do mastering for production library music with a lot of hard and tight starts to the files. I don't experience the fade in.

I have a feeling this is a setting somewhere either in WaveLab or your audio device. Do you have an alternate audio device to test with? Even the built in output of your computer could help troubleshoot.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
Arjan P
Senior Member
Posts: 2546
Joined: Wed Dec 15, 2010 6:28 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by Arjan P » Mon May 27, 2019 9:32 pm

Maybe it simply is not working in WL Elements - even though the setting is there? Maybe someone else with Elements can try S-EH's test.
--- "If anyone owes it all to Bach, it's God" - Emil Cioran ---
SOFT: (All 64 bit) | WaveLab 10.0.10 | Cubase 10.0.50 | HALion 6.0 | Win10 Pro - SoundCloud
HARD: i7-950 | Asus P6TD | 30GB | Tascam DM-3200 | DigiMax48 | Midisport 8x8 - SoundByte Studio

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Tue May 28, 2019 10:11 am

S-EH wrote:
Mon May 27, 2019 5:05 pm
With the built-in Signal Generator make a pulse sample
...
Since WL Elements doesn't have a pulse generator, I generated one sample pulse.
Without "Perform Short Fade In/Out When Starting/Stopping Playback":
- playing starting one or few samples before the pulse, you can ear the click
- Playing starting at the pulse, you can not ear the click

That's what happens with Elements

May be Arjan P is right, that's happens only with Elements.
Arjan, what you mean with " S-EH's test"?

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Tue May 28, 2019 10:15 am

Justin P wrote:
Mon May 27, 2019 5:23 pm
Do you have an alternate audio device to test with?
I usually use Adobe Audition and Sound Forge, either play without "Auto Fade In"

User avatar
Arjan P
Senior Member
Posts: 2546
Joined: Wed Dec 15, 2010 6:28 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by Arjan P » Tue May 28, 2019 11:22 am

nazardo wrote:
Tue May 28, 2019 10:11 am
Arjan, what you mean with " S-EH's test"?
Well, simply the pulse test with the 'short fade in/out' setting on and off. Maybe someone using WL Elements can confirm.
--- "If anyone owes it all to Bach, it's God" - Emil Cioran ---
SOFT: (All 64 bit) | WaveLab 10.0.10 | Cubase 10.0.50 | HALion 6.0 | Win10 Pro - SoundCloud
HARD: i7-950 | Asus P6TD | 30GB | Tascam DM-3200 | DigiMax48 | Midisport 8x8 - SoundByte Studio

User avatar
Justin P
Senior Member
Posts: 2467
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Play - Auto fade in (unwanted)

Post by Justin P » Tue May 28, 2019 1:34 pm

nazardo wrote:
Tue May 28, 2019 10:15 am
Justin P wrote:
Mon May 27, 2019 5:23 pm
Do you have an alternate audio device to test with?
I usually use Adobe Audition and Sound Forge, either play without "Auto Fade In"
It would still be helpful to try another output to help narrow things down.

Are you on Mac or PC?

I just tried Elements on my laptop, playing this test tone in the audio editor:
https://www.dropbox.com/s/5cirflixqkgqs ... c.wav?dl=0

There is not a fade in and the playback is OK.

Maybe WaveLab and your specific interface do not get along. I've heard of this happening but you haven't provided enough info or tested another interface to help know that.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Wed May 29, 2019 6:29 am

I use windows.

Justin , I load your waveform, it plays with fadein, even if your waveform is correct.
Well, try to insert a silence of 500 samples before this waveform and play from begin: in my system it plays correctely.
Try to play where the sine starts or after: it plays with fade in.
I'm very curios to know what happen with your system.

P.S. the made fade in is very short, I suppose 500 samples about, it produces a light smooth attack, same same, but different :D

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Thu May 30, 2019 7:38 am

My friend who use Mac + Elements confirms that WL apply an auto fade in.
Hope Steinberg team will fix that point...

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by S-EH » Thu May 30, 2019 12:47 pm

I tested a very old version of WL 7 LE... as well
and guess what it plays exactly at start 0 smp one pulse sample
with full gain/dB if anybody needs this
just turn this setting off
""Perform Short Fade In/Out When Starting/Stopping Playback"

I have tried this with OSX and WL 7 - WL 9.5.50
RME Fireface 800 and Built-in Audio

so it must be something with the Audio Device if auto fade is heard at the very first start of wav

regards S-EH
RME Fireface 800, WaveLab, Cubase...

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Fri May 31, 2019 10:18 am

S-EH wrote:
Thu May 30, 2019 12:47 pm
I tested a very old version of WL 7 LE... as well
...
so it must be something with the Audio Device if auto fade is heard at the very first start of wav
Hi S-EH, thanks for help.
I suppose WL7 no have this [sometimes] annoying feature.
Sound Card can't do that. Sound Card simply plays the contents of the audio buffer, no intelligence aboard.

Easy to test with Justin's waveform + silence on top

bob99
Senior Member
Posts: 2526
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Play - Auto fade in (unwanted)

Post by bob99 » Fri May 31, 2019 10:58 am

Like S-EH and Justin, I don't get a fade in either, with Elements on Windows 10. Maybe if you recorded the output into Audacity (because it makes it easy with input set to WASAPI loopback) it would possibly illustrate what you're hearing.

https://www.howtogeek.com/217348/how-to ... tereo-mix/

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Fri May 31, 2019 11:18 am

Hi Bob, Thanks for your time.
Yes, I recorded WL output into Audition by stereo-mix.
But the result I posted is exactly what I ear.

That's incredible, hoping someone of the WL staff can help..

P.S. I had the demo version (expired today) and I'm waitng for a licence already purchased

bob99
Senior Member
Posts: 2526
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Play - Auto fade in (unwanted)

Post by bob99 » Sat Jun 01, 2019 5:28 am

I reproduced your problem, but got inconsistent results based on the (I think) level of the starting sample. I know I got a few with no fade in at all when started from different spots in the waveform, but I'm not sure why. When I did get the fade in it was about 7ms, like in my screenshot. Seems like a pretty minor problem. In my screenshot, track one is the original, track two is the Audacity recording, with the fade in.

It would probably help if you could post screenshot of your result with Stereo Mix in Audition.
-
Attachments
PLAY FROM FULL SCALE START.PNG
(65.46 KiB) Not downloaded yet

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by S-EH » Sat Jun 01, 2019 7:22 am

Can this be related to the buffer settings in Audio Device(s)
I can't get any fade-in if I start a wav sine or pulse exactly at 0 with my stuff !?

and turn off the

"Perform Short Fade In/Out When Starting/Stopping Playback"


Audio Buffer settings in WL 9.5.50 tried with 16 and 32 no difference

regards S-EH
RME Fireface 800, WaveLab, Cubase...

bob99
Senior Member
Posts: 2526
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Play - Auto fade in (unwanted)

Post by bob99 » Sat Jun 01, 2019 10:39 am

S-EH wrote:
Sat Jun 01, 2019 7:22 am
Can this be related to the buffer settings in Audio Device(s)
I can't get any fade-in if I start a wav sine or pulse exactly at 0 with my stuff !?

and turn off the

"Perform Short Fade In/Out When Starting/Stopping Playback"


Audio Buffer settings in WL 9.5.50 tried with 16 and 32 no difference

regards S-EH
Buffer seems to make no difference. Fade-In pref is off.

If I put a 7ms fade-in on a 1KHz sine I can't hear the difference. For me, that would require a record into Audacity to see the difference. A Wavelab single pulse I can't hear if I play from 7ms before, so a 7ms fade-in would make no difference to me.

I tried doing the same thing, same file playing back in Reaper, and I got the same thing as in Elements - a tiny fade-in if recorded into Audacity. Then I found what seems to be a default pref in Reaper, called "tiny fade-in on playback". I turned that off and the record in Audacity was as I would expect - no fade-in at all.

if I do all this in Wavelab Pro, "record what is played back" (which is not available in Elements) I don't get any of this. That works perfectly, no fade in at all. So I'll try that with and without the fade-in pref turned on to see what happens.

But I still wonder about the fade-in pref, if it's that short, is it certain that it's not on even though it's unchecked?

ps this is all with Realtek internal stuff like would be found on a notebook computer.

nazardo
New Member
Posts: 13
Joined: Tue Jun 11, 2013 2:53 pm
Contact:

Re: Play - Auto fade in (unwanted)

Post by nazardo » Mon Jun 03, 2019 10:00 am

bob99 wrote:
Sat Jun 01, 2019 5:28 am
I reproduced your problem, but got inconsistent results based on the (I think) level of the starting sample. I know I got a few with no fade in at all when started from different spots in the waveform, but I'm not sure why. When I did get the fade in it was about 7ms, like in my screenshot. Seems like a pretty minor problem. In my screenshot, track one is the original, track two is the Audacity recording, with the fade in.

It would probably help if you could post screenshot of your result with Stereo Mix in Audition.
-
Well, I was worrying about looking like a visionary :lol:
Yes, a good idea to increase the level of first sample to better ear the difference.

May be was not so visible but I put already the audio result of my test. Anyway I link again the result: It's about 10 ms.
S-EH wrote:
Sat Jun 01, 2019 7:22 am
Can this be related to the buffer settings in Audio Device(s)
Not at all.
S-EH wrote:
Sat Jun 01, 2019 7:22 am
I can't get any fade-in if I start a wav sine or pulse exactly at 0 with my stuff !?
To eliminate any doubt, use your sine and eliminate the fisrt 10 samples. So you should to ear a big Tock al the start, but WL smoth this Tock.
To listen the Tock you must add some zero-samples on head.

bob99
Senior Member
Posts: 2526
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Play - Auto fade in (unwanted)

Post by bob99 » Mon Jun 03, 2019 10:39 am

btw, the fade-in pref works ok in Wavelab Pro using "record what is played back". When off, no fade in. When on, you get a 7-8ms fade in.
But when playing out to another program or another recording system it's like the 7-8ms fade-in is always on, no matter what the pref setting. That's what I get anyway, and it's different from what I get playing out of Reaper to another program with all the same conditions. That follows the fade-in pref set in Reaper.

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 2 guests