Page 1 of 1

Exporting audio file with loop points

Posted: Sat Jun 22, 2019 11:41 pm
by jmgotsoul
I am a fairly new user of Wavelab Elements 9.5. My only purpose for using it is to embed loop points in audio files that are samples I have created with the intent of importing them into a digital synth to do some sound design.

When I render the audio file with "Copy Markers" selected the loop points are not included in the wav file but rather an additional marker file. The only way I've been able to get this to work is to save a copy of the file. I guess I'm wondering if that is the way to do this or is there a better way?

Re: Exporting audio file with loop points

Posted: Sun Jun 23, 2019 8:21 am
by PG
It should work with this:
2019-06-23_09-20-11.png
(54.56 KiB) Not downloaded yet

Re: Exporting audio file with loop points

Posted: Sun Jun 23, 2019 4:31 pm
by jmgotsoul
PG wrote:
Sun Jun 23, 2019 8:21 am
It should work with this:
2019-06-23_09-20-11.png
I actually have those settings checked. It works as expected when saving as but not when rendering. Here is a short video showing what I'm talking about https://youtu.be/RKk1URABCNs

Re: Exporting audio file with loop points

Posted: Sun Jun 23, 2019 5:17 pm
by PG
I just tried and don't have the problem. However, you seem to do things right in your video.
Try this: uncheck the option to write a mrk file and render. Then render and open the file in WaveLab. Do you see the markers? If use (I do), then the markers are properly written in the file.

Re: Exporting audio file with loop points

Posted: Sun Jun 23, 2019 11:12 pm
by jmgotsoul
PG wrote:
Sun Jun 23, 2019 5:17 pm
I just tried and don't have the problem. However, you seem to do things right in your video.
Try this: uncheck the option to write a mrk file and render. Then render and open the file in WaveLab. Do you see the markers? If use (I do), then the markers are properly written in the file.
Great suggestion! I unchecked the "Write Markers in Separate File" option in Audio File Preferences. Also, just for this experiment I checked the render option, "Open Resulting Audio File". I then rendered the file. When it opened up on Wavelab I could see the markers. So, at least from a Wavelab perspective, they appear to be there. I guess I'll have to reach out to Spectrasonics to see if they can shed some light on why it doesn't work in Omnisphere when rendered. Thanks for the help!

Re: Exporting audio file with loop points

Posted: Wed Jun 26, 2019 11:22 pm
by jmgotsoul
PG wrote:
Sun Jun 23, 2019 5:17 pm
I just tried and don't have the problem. However, you seem to do things right in your video.
Try this: uncheck the option to write a mrk file and render. Then render and open the file in WaveLab. Do you see the markers? If use (I do), then the markers are properly written in the file.
One quick question for you. When you say "I just tried and don't have the problem" is that to say you rendered a file out of Wavelab with the loop markers and then imported it into Omnisphere and it was able to loop fine in Omnisphere?

I just want to confirm that your success included actually trying it in Omnisphere.

Re: Exporting audio file with loop points

Posted: Thu Jun 27, 2019 5:32 am
by PG
No, I imported it back to WaveLab. I did not try recently, but I could import audio files with markers in some other application.
You have certainly encountered an Omnisphere bug, and you should send them a file as reference.

Re: Exporting audio file with loop points

Posted: Fri Jun 28, 2019 12:40 am
by jmgotsoul
PG wrote:
Thu Jun 27, 2019 5:32 am
No, I imported it back to WaveLab. I did not try recently, but I could import audio files with markers in some other application.
You have certainly encountered an Omnisphere bug, and you should send them a file as reference.
Yep, I have already reached out to Spectrasonics and they have reviewed this post but interpreted your response of "I just tried and don't have the problem" as you tried it in Omnisphere. So, I wanted to verify what you meant so that I could correctly communicate that to them. So, thanks so much for responding!