Solved: Import Audio CD doesn't work.

All topics on WaveLab 9 and WaveLab Elements 9
Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Solved: Import Audio CD doesn't work.

Post by Mljung » Mon May 23, 2016 2:44 pm

Very strange thing has happened.

I wanted to import an audio CD (done it many times before in Wavelab, including a few times in WL9).
The thing is, that now, all of a sudden, I can't see the drives anymore, in WL9. I have two CD/DVD an old Plextor and a newer Pioneer, but there's nothing to see on the source drop-down list, in the audio cd import dialog. How do I get them back?

Windows has no problems seeing both drives and plays what's on them without any issues - what can be wrong, why can't Wavelab 9 see them?

::
Mads
Last edited by Mljung on Wed May 25, 2016 10:06 am, edited 1 time in total.

User avatar
Justin P
Senior Member
Posts: 2451
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Import Audio CD doesn't work.

Post by Justin P » Mon May 23, 2016 2:56 pm

Do you see the drives if you try to burn a CD? I know from viewing this forum there are some Windows driver related issues with optical drives and chances are you need to install or update those. I don't think this is rare case.

I'm sure PG will point you to the right direction.

Perhaps related to this thread?:
viewtopic.php?f=244&t=96153&p=533000&hi ... ve#p533000
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Mon May 23, 2016 3:49 pm

Thanks Justin

Seems related yes, still I can't fix it. "GEAR ASPI Filter Driver" is there all right, but it's not started. The question is how to do this - how to make it start?

::
Mads

PG
Moderator
Posts: 6967
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Import Audio CD doesn't work.

Post by PG » Mon May 23, 2016 4:10 pm

Philippe

User avatar
MrSoundman
Senior Member
Posts: 2371
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Import Audio CD doesn't work.

Post by MrSoundman » Mon May 23, 2016 9:10 pm

Perhaps you made a change in the BIOS setting? Avoid enabling a thing called "Aggressive LPM Support".
viewtopic.php?f=209&t=97348
Windows 10 • Cubase 10.5.0 • WaveLab 10.0.0 • SpectraLayers 6.0.20 • HALion 6.3.1 • Groove Agent 5.0.20 • Midex

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Mon May 23, 2016 9:42 pm

I did - I also tried to remove it, and then did a fresh install - but that didn't help either.

::
Mads

bob99
Senior Member
Posts: 2527
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Import Audio CD doesn't work.

Post by bob99 » Mon May 23, 2016 10:16 pm

Mljung wrote:"GEAR ASPI Filter Driver" is there all right, but it's not started. The question is how to do this - how to make it start?
Did you try double clicking on Filter Driver, and trying to start it manually?
(EDIT: sorry, that doesn't work from System Information).

But mostly, what do you get when you run the 32 or 64 bit checker app at the top of this page:
http://www.gearsoftware.com/wiki/index. ... _correctly
Last edited by bob99 on Tue May 24, 2016 2:57 am, edited 1 time in total.

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Mon May 23, 2016 10:44 pm

bob99 wrote:
Mljung wrote:"GEAR ASPI Filter Driver" is there all right, but it's not started. The question is how to do this - how to make it start?
Did you try double clicking on Filter Driver, and trying to start it manually?
(EDIT: that doesn't work. Thought it would be controllable like a Service).

But mostly, what do you get when you run the 32 or 64 bit checker app at the top of this page:
http://www.gearsoftware.com/wiki/index. ... _correctly
It says that drivers are not installed correctly...
I'll give it another go.

::
Mads

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 12:46 am

Tried again to reinstall the gear drivers, after removing every GEARAspi dlls.
Still no luck
Also did the check again - and uploaded the results - hopefully this can help

::
Mads
Attachments
GEARAspi Verifier.jpg
(116.51 KiB) Not downloaded yet

Rat
Member
Posts: 711
Joined: Thu Dec 16, 2010 6:33 am
Contact:

Re: Import Audio CD doesn't work.

Post by Rat » Tue May 24, 2016 5:21 am

FWIW, after years of exceptional (it just works) performance from Pioneer drives ... I've had two now (one just out of the box) that just refuse to "work". Neither Windoze 7 Professional or 10 seem to be able to "see them" even though they declare that drivers have been downloaded and installed. The Pioneer site isn't terribly helpful. I have given up on them.
Regards

Paul

Paul Rat Blakey
12th & Vine Post

Studio: Windows 10 Pro (x64), Intel Core i7 7700 Quad Core LGA 1151 3.6 GHz CPU, 32 GB RAM, Gigabyte Z270M-D3H LGA 1151 mATX Motherboard, 2 x Intel Pro 5400S Series 256GB SSD (system and session drives), RME HDSPe AIO, Mytek converters

Laptop: Windows 10 Pro (x64), Razor Blade Gaming Intel Core i7 8750H 6 cores/12 threads 4,1GHz CPU, 16 GB RAM SSD & HHD

WaveLab 9.5 Pro and 10 Pro current release, ProTools, iLok, DMG (Dave Gamble), Sony Oxford, Weiss

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 6:53 am

Regarding Pioneer, I don't think this is "it". I have two drives (Plextor and Pioneer), and Windows 7 can "see" both, I can play music from them etc, and WL9 could too until recently (not sure what happened).

I have an idea that the issue might be related to the "UpperFilters value", that are not present in my system. I can find several articles about removing it, but not much about restoring it. Hopefully someone can help me here, I need to get it to work again as soon as possible.

I wonder if a re-installation of WL9 will fix it, tried to "repair" the WL9 installation but without result. Do I need to reinstall using the original installer and then install the latest patch afterwords?

::
Mads

PG
Moderator
Posts: 6967
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Import Audio CD doesn't work.

Post by PG » Tue May 24, 2016 7:26 am

Did you really check carefully this:
http://www.gearsoftware.com/wiki/index. ... _correctly

Espescially the link at the bottom of this page:
http://www.gearsoftware.com/wiki/index. ... stry_entry

Reinstall WaveLab won't help you by itself. When you install WaveLab, the following driver is installed:
http://www.gearsoftware.com/support/drivers.php
and you can do this directly, without (re)installing WaveLab.
Philippe

bob99
Senior Member
Posts: 2527
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Import Audio CD doesn't work.

Post by bob99 » Tue May 24, 2016 7:27 am

I can't imagine why the uninstall and reinstall is not working for you, but if you no longer have the Gear drivers in add/remove, I thought there was an uninstaller on their website, but maybe I'm wrong, because all I see is a rather long manual uninstall.
http://www.gearsoftware.com/wiki/index. ... wer_64-bit

The problem might be because of another Gear Powered product (iTunes, Norton), but it hasn't affected my ability to the re-install Gear in the past. I encountered a Gear file missing because of Norton once, but uninstalling and reinstalling Gear fixed it. Other than a system restore back to when it was working, maybe PG or Gear would have an idea what to do?
Last edited by bob99 on Tue May 24, 2016 8:45 am, edited 1 time in total.

User avatar
MrSoundman
Senior Member
Posts: 2371
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Import Audio CD doesn't work.

Post by MrSoundman » Tue May 24, 2016 8:33 am

Have people checked the BIOS setting called "Aggressive LPM Support"? This must be disabled on the SATA bus for most optical drives, but I believe the default for most motherboards is to leave it enabled. So check this setting first because otherwise you're on a wild goose chase.
viewtopic.php?f=209&t=97348
Windows 10 • Cubase 10.5.0 • WaveLab 10.0.0 • SpectraLayers 6.0.20 • HALion 6.3.1 • Groove Agent 5.0.20 • Midex

bob99
Senior Member
Posts: 2527
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Import Audio CD doesn't work.

Post by bob99 » Tue May 24, 2016 8:47 am

Would that affect the ability to uninstall and properly re-install the Gear drivers? The driver checker is showing basically nothing installed.
Last edited by bob99 on Tue May 24, 2016 8:03 pm, edited 2 times in total.

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 9:18 am

PG wrote:Did you really check carefully this:
http://www.gearsoftware.com/wiki/index. ... _correctly

Espescially the link at the bottom of this page:
http://www.gearsoftware.com/wiki/index. ... stry_entry
Just tried the solution using regedit - problem is the UpperFilters entry isn't there, so I can't back it up.

::
Mads

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Import Audio CD doesn't work.

Post by S-EH » Tue May 24, 2016 9:32 am

Hi,

Have you tried tips from Microsoft !?
"Upperfilters" and maybe "Lowerfilters" as well Google this

regards S-EH
RME Fireface 800, WaveLab, Cubase...

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 9:55 am

S-EH wrote:Hi,

Have you tried tips from Microsoft !?
"Upperfilters" and maybe "Lowerfilters" as well Google this

regards S-EH
Yes I searched several times, and just did again. But almost everything is about deleting Upperfilters and LowerFilter, as a troubleshooting trick for making CD/DVD drives work in windows. I need the opposite - at least to have my UpperFilters back.

::
Mads

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 9:59 am

MrSoundman wrote:Have people checked the BIOS setting called "Aggressive LPM Support"? This must be disabled on the SATA bus for most optical drives, but I believe the default for most motherboards is to leave it enabled. So check this setting first because otherwise you're on a wild goose chase.
viewtopic.php?f=209&t=97348
I have checked, but I can't that specific bios setting - anyhow the drives work perfectly in Windows, no warnings in device manager or anything - Still WL doesn't "see" the drives.

::
Mads

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 10:24 am

bob99 wrote:I can't imagine why the uninstall and reinstall is not working for you, but if you no longer have the Gear drivers in add/remove, I thought there was an uninstaller on their website, but maybe I'm wrong, because all I see is a rather long manual uninstall.
http://www.gearsoftware.com/wiki/index. ... wer_64-bit

The problem might be because of another Gear Powered product (iTunes, Norton), but it hasn't affected my ability to the re-install Gear in the past. I encountered a Gear file missing because of Norton once, but uninstalling and reinstalling Gear fixed it. Other than a system restore back to when it was working, maybe PG or Gear would have an idea what to do?
If you run the installer and the software is already installed, the installer gives you two options: You can either repair the installation or remove the software, I've tried both, with no success. Yes it seems like the installer isn't working properly on my system. But I remember reinstalling Gear software earlier on, and it worked. (I don't have Norton or iTunes btw)

::
Mads
Last edited by Mljung on Tue May 24, 2016 11:26 am, edited 1 time in total.

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 10:45 am

Just for further information about this issue, the report I get when I look at driver-details of both my optical drives is the default microsoft and nothing else.
Attachments
driver file detail.jpg
(93.76 KiB) Not downloaded yet

User avatar
MrSoundman
Senior Member
Posts: 2371
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Import Audio CD doesn't work.

Post by MrSoundman » Tue May 24, 2016 12:06 pm

When you run the Gear installer, are you logged in with an account that has administrative privileges?
(e.g. "Run as Administrator ....")
Windows 10 • Cubase 10.5.0 • WaveLab 10.0.0 • SpectraLayers 6.0.20 • HALion 6.3.1 • Groove Agent 5.0.20 • Midex

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Re: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 2:36 pm

MrSoundman wrote:When you run the Gear installer, are you logged in with an account that has administrative privileges?
(e.g. "Run as Administrator ....")
Thanks for your suggestion - but no - Run as Administrator didn't make any difference...
Still no solution :?:

::
Mads

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: Import Audio CD doesn't work.

Post by S-EH » Tue May 24, 2016 2:59 pm

Possible to step back in history/Windows to working version
or to clean Register and start over to find new hardware and drivers !?

regards S-EH
RME Fireface 800, WaveLab, Cubase...

Mljung
Junior Member
Posts: 97
Joined: Wed May 08, 2013 9:03 am
Contact:

Solved: Import Audio CD doesn't work.

Post by Mljung » Tue May 24, 2016 3:25 pm

Problem solved! :mrgreen: :!: :D

I was right about the lack of UpperFilters in the registry. This fix for iTunes in Win XP did the trick:
http://ccm.net/forum/affich-77186-itune ... gs-missing

After a lot of messing around I am relieved.

Thanks to all for trying to help

::
Mads

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 4 guests