Page 1 of 1

Add player and layout problem

Posted: Wed Nov 02, 2016 3:47 pm
by oldlayclerk
I have enjoyed trying Dorico out with a custom set of players (flutes and clarinets with various doublings). All has gone pretty well, and I can certainly see its potential as it develops, and I look forward to developing with it.
However, there are two specific things which have caused problems:
1. I had forgotten to add a second saxophone. When I did so (add solo player in Setup) it added at the bottom (below the bass clarinet). When I try to move it up (either by dragging or ctl-up) the program crashes.
2. When I tried to set up a new combination - in the correct order - now every time I add a new player it gets added to every layout, so all part layouts end up as full scores. I have tried removing the players laboriously but then the saved version won't load (causes 'Dorico has stopped working') I'm guessing I have pressed something in error.
Any thoughts?

Re: Add player and layout problem

Posted: Thu Nov 03, 2016 2:04 am
by Daniel at Steinberg
Dragging instruments in the Players panel should work pretty reliably. Certainly we haven't seen any crashes in this area. You might try moving the player with a keyboard shortcut instead: Alt+up arrow moves the selected player up in the Players panel in Setup mode.

The problem with your layouts getting all players and flows by default is indeed caused by a bug that quite a few people have unfortunately been bitten by, but which we have fixed for the 1.0.10 update. See this thread for a way around it for now.

Re: Add player and layout problem

Posted: Thu Nov 03, 2016 10:48 am
by oldlayclerk
Thank you for your response, Daniel. I have tried the alt-up arrow with the same result on this specific file, but it (and dragging) works on other projects. One of those things, I guess.
I'll rootle around in the Dorico sub-directory, to see if I can cure my other problem.

Incidentally, I have just tried printing my first draft of this piece and it looks splendid. Thank you.

Re: Add player and layout problem

Posted: Thu Nov 03, 2016 10:58 am
by Daniel at Steinberg
Can you zip up the project that crashes when dragging players and attach it here? Another option that might get you where you need to go is to right-click the existing saxophone player and choose Duplicate Player, which will insert the new player directly below the existing one.

Re: Add player and layout problem

Posted: Thu Nov 03, 2016 3:36 pm
by oldlayclerk
Goodness, thanks for getting back to me, Daniel. Your suggestion to duplicate and edit a player worked excellently. I have copied the music over and deleted the wrongly-placed player, and it looks as I want it.
I hope I have attached a zipfile of the opening.
Ian

Re: Add player and layout problem

Posted: Mon Nov 07, 2016 1:39 am
by Daniel at Steinberg
Sorry to take so long to come back to this thread.

There's something funny about the groups you've managed to create in your project that I'm unable to reproduce in a new project. If you run into any further problems with this project, I would suggest deleting the various groups you currently have in the Players panel in Setup mode, then recreate them as necessary.