Tempo Marking Disappears in Page View

Discussions about our next-generation scoring application, Dorico.
Post Reply
User avatar
tonywardarts
Junior Member
Posts: 161
Joined: Sat Oct 15, 2016 6:26 pm
Location: Madison, WI
Contact:

Tempo Marking Disappears in Page View

Post by tonywardarts » Mon Mar 20, 2017 8:13 pm

I'm finishing up a score for submission and I have a weird problem: on page 1, where the two vocal staves are hidden, I am trying to insert a "poco rit." marking. It will show up in Galley View, but not in Page View in either Write or Engrave. Any ideas? I've tried deleting and re-creating, same problem.
Tony Ward
tonywardarts.com
Dorico 1.1.1, MacOS 10.12.6

I dive into new/beta versions like birds dive into plate glass.

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Mon Mar 20, 2017 11:46 pm

Can you attach the project here, or send it to me by email?

User avatar
tonywardarts
Junior Member
Posts: 161
Joined: Sat Oct 15, 2016 6:26 pm
Location: Madison, WI
Contact:

Re: Tempo Marking Disappears in Page View

Post by tonywardarts » Tue Mar 21, 2017 12:10 am

Done. Thank you, Daniel!

I faked it with a text object to move the project along.
Tony Ward
tonywardarts.com
Dorico 1.1.1, MacOS 10.12.6

I dive into new/beta versions like birds dive into plate glass.

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Tue Mar 21, 2017 12:26 am

This is in bar 8, is it? It seems to work OK for me – do you see "poco rit." in the attached project?
Attachments
Song of Thanksgiving (ANNA CECILIA) (Ward).dorico.zip
(109.39 KiB) Downloaded 15 times

User avatar
tonywardarts
Junior Member
Posts: 161
Joined: Sat Oct 15, 2016 6:26 pm
Location: Madison, WI
Contact:

Re: Tempo Marking Disappears in Page View

Post by tonywardarts » Tue Mar 21, 2017 2:00 am

I do. So weird. Could not get that mark to display for anything. Thank you? =)
Tony Ward
tonywardarts.com
Dorico 1.1.1, MacOS 10.12.6

I dive into new/beta versions like birds dive into plate glass.

User avatar
tonywardarts
Junior Member
Posts: 161
Joined: Sat Oct 15, 2016 6:26 pm
Location: Madison, WI
Contact:

Re: Tempo Marking Disappears in Page View

Post by tonywardarts » Tue Mar 21, 2017 4:38 am

Just in: happened again tonight with a different file.
Tony Ward
tonywardarts.com
Dorico 1.1.1, MacOS 10.12.6

I dive into new/beta versions like birds dive into plate glass.

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Tue Mar 21, 2017 10:40 am

Very odd. Can you send me that file, too, and tell me where it's happening?

User avatar
tonywardarts
Junior Member
Posts: 161
Joined: Sat Oct 15, 2016 6:26 pm
Location: Madison, WI
Contact:

Re: Tempo Marking Disappears in Page View

Post by tonywardarts » Tue Mar 21, 2017 11:45 pm

Will do, but I'd like to email it this time. (address?) In the meantime, I tried to create the bug in a new file and couldn't (see attached).
Tempo Markings Bug à 3 Full score 1.png
(98.82 KiB) Not downloaded yet
Tony Ward
tonywardarts.com
Dorico 1.1.1, MacOS 10.12.6

I dive into new/beta versions like birds dive into plate glass.

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Wed Mar 22, 2017 1:00 am

My email address is d dot spreadbury at steinberg dot de.

pianoleo
Member
Posts: 275
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Tempo Marking Disappears in Page View

Post by pianoleo » Sun Jul 16, 2017 1:12 pm

Bumping this as I think I can recreate this problem (or at least a similar one) in Dorico 1.1.

What's shown in the gif is two systems, where in the first system the vocal line is empty and thus hidden.
The accel. shows fine in page view as long as the attachment line only runs to the end of the system. If it runs on to the new system the whole object disappears.

This behaviour doesn't seem to happen unless there are hidden staves involved.

Anybody got a workaround?

Image
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius 8.5, Logic Pro X, Dorico 1.1 etc.
Sibelius user since Sibelius 7 (Acorn, 1997)

Derrek
Member
Posts: 906
Joined: Sun Aug 07, 2016 6:23 pm
Contact:

Re: Tempo Marking Disappears in Page View

Post by Derrek » Sun Jul 16, 2017 5:07 pm

What happens if you extend the accel. line in Galley view and then go back to Page view?
Dorico 1.1.10, Finale (v25.4), GPO, JABB3, GWI
Windows 7 (also Mac Sierra as alternate)
US English Keyboard

András at Steinberg
Steinberg Employee
Posts: 45
Joined: Wed Oct 26, 2016 8:20 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by András at Steinberg » Sun Jul 16, 2017 5:26 pm

If you slowly move the mouse further down towards and over the piano staves, does the line reappear?

pianoleo
Member
Posts: 275
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Tempo Marking Disappears in Page View

Post by pianoleo » Sun Jul 16, 2017 9:45 pm

I'm away from my desk just now, but I believe it'll show in galley view but not in page view. Will happily confirm with a gif in the morning.
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius 8.5, Logic Pro X, Dorico 1.1 etc.
Sibelius user since Sibelius 7 (Acorn, 1997)

pianoleo
Member
Posts: 275
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Tempo Marking Disappears in Page View

Post by pianoleo » Mon Jul 17, 2017 12:34 pm

Image

Gif to show that no, if I move the mouse down and over the piano staves the line doesn't reappear. Though the act of selecting galley view is off shot, the end of the clip is galley view after the object has disappeared in page view. The object's still there, it's just not showing on the page.

Derrek, if I extend the accel. line in galley view the line doesn't show in page view. If I reduce the line to only cover up to the end of bar 53 the line reappears in page view. If I force measure 54 onto the previous system the line reappears.

edit: the file in question has previously been tweaked by Daniel to do something completely unrelated. Just to ensure it's not an isolated case I started a new project - see attachment. There's an accel. in bar 3 to halfway through bar 5. It only shows in Galley view, and it plays.
Attachments
Hidden Accel.dorico.zip
(597.79 KiB) Downloaded 6 times
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius 8.5, Logic Pro X, Dorico 1.1 etc.
Sibelius user since Sibelius 7 (Acorn, 1997)

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Thu Jul 20, 2017 10:33 pm

The problem appears to be that when you have a gradual tempo change, a score in which empty staves are hidden, and you try to drag the end of a tempo line from one system to the next, the tempo line won't draw until the end of it has passed all of the chord symbols in that flow. This is definitely a bug and we'll try to sort it out when we can.

pianoleo
Member
Posts: 275
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Tempo Marking Disappears in Page View

Post by pianoleo » Thu Jul 20, 2017 10:48 pm

Many thanks. I have a workaround in this instance (forcing a four-bar system) and alternatively I could always lose the attachment line - it's pretty clear anyway.
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius 8.5, Logic Pro X, Dorico 1.1 etc.
Sibelius user since Sibelius 7 (Acorn, 1997)

pianoleo
Member
Posts: 275
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Tempo Marking Disappears in Page View

Post by pianoleo » Fri Jul 21, 2017 7:35 am

Daniel, sorry to come back to this thread, but I have to disagree with your analysis of the problem:

See the attachment "Hidden Accel.dorico.zip", a few messages up. It contains no chord symbols whatsoever but still displays the problem.
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius 8.5, Logic Pro X, Dorico 1.1 etc.
Sibelius user since Sibelius 7 (Acorn, 1997)

User avatar
Daniel at Steinberg
Moderator
Posts: 5210
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Tempo Marking Disappears in Page View

Post by Daniel at Steinberg » Fri Jul 21, 2017 9:33 am

Right, that file actually demonstrates a separate but related problem.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: jonathanhughes and 11 guests