generic asio driver issue

Discussions about our next-generation scoring application, Dorico.

generic asio driver issue

Postby batwell » Tue Apr 11, 2017 11:10 pm

The generic asio that installs with cubase apparently overwrites the one that ships with Dorico and it is not quite compatible. Dorico wants a 44.1k sample rate while the cubase driver only seems to support 48k. Can one change the sample rate on this driver? If yes, please tell me how and if not, why not? Or alternatively can cubase work with the Dorico driver and if so how can I get it back?
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Daniel at Steinberg » Wed Apr 12, 2017 12:08 am

As far as I know (though we will need Ulf to confirm for sure), Dorico should be compatible with the version of the Generic Low-latency ASIO Driver that is installed with Cubase, and it should also be OK with a 48kHz sample rate, as well. If you change the sample rate in Dorico's Device Setup dialog, then quit and restart Dorico, do you find that the sample rate is reported correctly and that playback works?
User avatar
Daniel at Steinberg
Steinberg Employee
 
Posts: 4201
Joined: Mon Nov 12, 2012 10:35 am
Has thanked: 104 times
Been thanked: 3377 times

Re: generic asio driver issue

Postby batwell » Wed Apr 12, 2017 4:49 am

Thanks Daniel but right now if I start playback in the middle of a score, the line and counter start but the actual sound is delayed by some significant time. (5 to 10 seconds) This gets worse the further along in the score that you start the playback. Paul Walmsley claimed that this is fixed in the next version but it is really screwing me for now.
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Ulf » Wed Apr 12, 2017 7:35 am

First of all, Cubase and Dorico ship with exactly the same Generic Low Latency Driver, so there is no such thing as Cubase can only 48kHz and Dorico only 44.1kHz. What sample rate is supported depends solely on the actual hardware device that is used.
Even more interestingly, you can set Cubase to any sample rate between 11kHz and 192kHz even if the hardware doesn't support it. Of course, this may lead to funny effects, but that's at the user's responsibility.
Dorico is not that advanced and only offers the sample rates that the actual hardware is capable of. Dorico asks the driver what sample rates are available and the driver interrogates the actual hardware.
As Daniel already mentioned, when you go to Edit > Device Setup there is a drop down box with all the available/supported sample rates of the currently chosen driver.
Similarly in Cubase, there instead it is Project > Project Setup...
Steinberg employee
User avatar
Ulf
Steinberg Employee
 
Posts: 472
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarter
Has thanked: 42 times
Been thanked: 129 times

Re: generic asio driver issue

Postby PaulWalmsley » Wed Apr 12, 2017 12:00 pm

Hi Bob,

I've just tried on my own system and found that if I use the ASIO Generic Low Latency device then it only gives me a choice of a single sample rate (44.1k). If I tick the 'Allow ASIO host to take exclusive control' in the ASIO control panel then this gives me a choice of sample rates. However this will mean that other applications may not be able to use the soundcard at the same time.

I guess in your case, your soundcard has defaulted to 48k. Can you try clicking on the speaker icon that's on the windows taskbar and selecting 'Playback devices' (or you can just type that into the search window) and then in the Playback tab, select your soundcard, click Properties and then in Advanced try to change the default format to 44.1k
device.jpg
(46.82 KiB) Not downloaded yet
Architect & Developer - Steinberg London
User avatar
PaulWalmsley
Steinberg Employee
 
Posts: 501
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Has thanked: 25 times
Been thanked: 423 times

Re: generic asio driver issue

Postby batwell » Thu Apr 13, 2017 12:45 am

It has only gone from bad to worse. Now I get no playback at all from Dorico and nothing I do in Dorico's device setup has any effect. See the attached video. I couldn't even play back to my midi keyboard because the setup device is not working. I could input from the keyboard just fine.
Attachments
Vid_002.gif
(899.62 KiB) Not downloaded yet
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Ulf » Thu Apr 13, 2017 7:36 am

That the Device Control Panel does not appear is because in your Preferences you have the option "Suspend audio device in background" ticked. Choose Edit > Preferences and scroll down to the last, the Play section and untick it.

Alternatively, one can also invoke the GLLD Device Control Panel by invoking C:\Program Files\Steinberg\Asio\asioglldsetup.exe
Steinberg employee
User avatar
Ulf
Steinberg Employee
 
Posts: 472
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarter
Has thanked: 42 times
Been thanked: 129 times

Re: generic asio driver issue

Postby batwell » Thu Apr 13, 2017 9:58 pm

OK, now I can get the control panel to open but I still change the sample rate and I CAN'T GET ANY SOUND!
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Ulf » Fri Apr 14, 2017 4:54 pm

Ok, we are trying to help, but why are you shouting?

Could you please create a simple piano project with just a handful of notes and post here? Before attaching you need to zip it up, otherwise it will get refused. From the project data I might be able to tell more.
Steinberg employee
User avatar
Ulf
Steinberg Employee
 
Posts: 472
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarter
Has thanked: 42 times
Been thanked: 129 times

Re: generic asio driver issue

Postby batwell » Fri Apr 14, 2017 7:52 pm

Thanks Ulf. My deepest apologies but I was feeling very frustrated. I just now started a new score with only piano and playback is working. Let me do a bunch more testing on the problem score and see if I can figure anything out. If necessary I will send you a truncated version of that one.
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby batwell » Fri Apr 14, 2017 8:09 pm

Here is a test file that does not play back. As I said in the last post, a new project with only is playing back fine so apparently the problem does lie in my project and not with Dorico per se.
Attachments
Test_Case.zip
(529.03 KiB) Downloaded 10 times
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Ulf » Fri Apr 14, 2017 8:47 pm

Apologies accepted.

Now for your project: I see why it is not playing back. It is the well known port mapping issue, actually a bug in Dorico. Once the project gets into this state of missing port mapping information, it stays muted forever, unless one applies a little trick. We have also a proper fix for it and it's waiting to be released in the next Dorico update.
I've attached a new version of your project. If you load that and go to Play Mode and choose Play > Apply Default Playback Template, then the project shall sound again.
You said it is a strip down version of a larger project. You could post the original file for me to do the trick again, or you could try yourself, it is not so difficult.
- Choose your favourite zipper tool (mine is 7zip) and unzip the Dorico project. That's right, despite the ending .dorico it is just a zipped archive.
- After unpacking you'll find 2 *.dtn files and 2 folders. Navigate to supplementary_data\vstaudioengine\enginedata and delete that file
- Go back to the level where the *.dtn files are and zip up the whole lot again. Instead of *.zip give it the ending *.dorico
- That's it, load into Dorico and do the Apply Default Playback Template. And don't forget to save again.
Attachments
Test_Case2.zip
(149.87 KiB) Downloaded 8 times
Steinberg employee
User avatar
Ulf
Steinberg Employee
 
Posts: 472
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarter
Has thanked: 42 times
Been thanked: 129 times

Re: generic asio driver issue

Postby batwell » Fri Apr 14, 2017 11:55 pm

Thank you very much. I think I will send you the full file. It is only a tiny bit bigger that the stripped down version as I am very early in this project. There is no urgency so whenever you can get to it. Have a great Easter.

Bob.
Attachments
Eigenvectors_II.zip
(565.52 KiB) Downloaded 9 times
batwell
New Member
 
Posts: 45
Joined: Sun Oct 23, 2016 12:05 am
Has thanked: 6 times
Been thanked: 1 time

Re: generic asio driver issue

Postby Ulf » Sat Apr 15, 2017 8:19 am

Hi Bob, no problem, it's easy for me. Please see attachement; don't forget the Apply Default Playback Template.
And now off to the golf course ;-)
Happy Easter to you and everyone on this forum.
Attachments
Eigenvectors_II 2.zip
(185.87 KiB) Downloaded 9 times
Steinberg employee
User avatar
Ulf
Steinberg Employee
 
Posts: 472
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarter
Has thanked: 42 times
Been thanked: 129 times


Return to Dorico

Who is online

Users browsing this forum: JackvL, L3B, rgonski, Robby Poole and 12 guests