Dorico becomes very slow after a while...

Discussions about our next-generation scoring application, Dorico.
User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Wed Jul 19, 2017 2:03 pm

We are still looking into this problem, but I believe you should see an improvement in the responsiveness of the application if you go into Layout Options, and on the Staves and Systems page, set the 'Fixed number of systems per frame' option to 1. You should also find that inputting and editing is faster in galley view than in page view.

User avatar
Andre
Member
Posts: 425
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico becomes very slow after a while...

Post by Andre » Wed Jul 19, 2017 3:37 pm

Daniel at Steinberg wrote:
Wed Jul 19, 2017 2:03 pm
We are still looking into this problem, but I believe you should see an improvement in the responsiveness of the application if you go into Layout Options, and on the Staves and Systems page, set the 'Fixed number of systems per frame' option to 1. You should also find that inputting and editing is faster in galley view than in page view.
Daniel, it's a miracle! Setting 'Fixed number of systems per frame' option to 1 made everything back to normal. Input notes work as it should. Thanks so much! Also the lyric input is at normal speed now, which was very slow as well before. I am still working in Page view btw. I like that better than Galley view. Btw, does this mean that changing this frame setting will always slow down the note input or is this some kind of bug?
My music and tutorials on http://www.andrevanharen.com
iMac 2,8 GHz Intel Core i5, 16 GB ram, macOS High Sierra.
Sibelius 6.2, Sibelius 8.5. Cubase 8.5.30, Dorico 1.2. Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, NotePerformer 2.0 etc etc...

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Thu Jul 20, 2017 11:17 am

To return to this issue: the reason that your project is so slow is because you have deleted the 'First' master page pair from the master page set being used by your project. When you have no 'First' pair, then even if you have the option in Layout Options to make new flows start on new pages set, in fact Dorico will try to make a new flow fit at the end of the previous frame if possible. This is perhaps unexpected, but not a bug (and on balance after discussion here we have decided that we will change this behaviour, so if you have that option set to always use a new frame, it will do so even if there's no 'First' master page pair set).

So what is going on in your project, André, is that each new flow is trying to get squeezed into the same frame as the end of the previous flow, and this is having a knock-on effect on the amount of casting off that Dorico is doing. Casting off is computationally expensive and can also result in other processing being done, and overall this makes the application less responsive when a larger and larger range needs to be cast off.

You therefore have two further options you can use to restore snappy performance in your project:

1. Duplicate your current 'Default' master page pair and set it to be have the special 'First' role. Even though it doesn't look any different, it will then allow the "new flows start new frames" option to work as you expect, and that will eliminate the need for extra casting off; or

2. Insert a frame break at the start of each flow, which tells Dorico that the flow should definitely start in a new frame and hence it shouldn't try to squeeze it in the previous one.

Once you do either or both of the above steps, you can switch off the 'Fixed number of systems per frame' option in Layout Options again.

As a result of looking into this we've decided both to change the behaviour of the option to control where new flows start (which we expect to be in the next minor update) and to look further into the casting-off code to see if we can detect this case and handle it more efficiently (which is a bigger job and will have to wait for the future), but you should be all set anyway if you follow either or both of the steps described above.

User avatar
Andre
Member
Posts: 425
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico becomes very slow after a while...

Post by Andre » Thu Jul 20, 2017 12:12 pm

Thanks for the explanation Daniel, I am glad that you were able to find out what caused the problem and that it's acutally my unusually use of the program that gave this effect. Well, all these unexpected uses help to make Dorico become the best notation software around :)
My music and tutorials on http://www.andrevanharen.com
iMac 2,8 GHz Intel Core i5, 16 GB ram, macOS High Sierra.
Sibelius 6.2, Sibelius 8.5. Cubase 8.5.30, Dorico 1.2. Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, NotePerformer 2.0 etc etc...

eheilner
New Member
Posts: 36
Joined: Sat Mar 18, 2017 5:10 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by eheilner » Sat Aug 12, 2017 9:22 pm

Daniel -
I too am experiencing significant slowdown. My problem appears related to the size of my project. If I take a subset of my piece (first 3 pages) everything works fine, but it takes anywhere from 10 to 60 seconds for my screen to refresh when working with the full score. Given that my piece is scored for a quartet and is only about 200 bars long, clearly this should not be happening. I can continue work by splitting my piece up, but that is obviously not a good solution.

I have tried the usual fixes - restarting Mac, closing and opening Dorico - but no luck.

I am running late 2012 Mac Mini, Sierra 10.12.6, with 16 Gig

I will e-mail you files. Hopefully I am doing something dumb.

AndreasB
New Member
Posts: 36
Joined: Sat Jul 16, 2016 6:26 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by AndreasB » Sat Nov 11, 2017 4:47 pm

Hi,

I'm currently running a trialversion of Dorico 1.1.1 on my 2015 MacBook-Pro and have a similar issue:

Dorico gets ridiculously slow after just a minute after launching the software.
By the way - even if I just have 1 Player and just some bars of music!!

It suddenly takes 100% CPU-Usage (according to activity-monitor).

Looking for the reason, I've discovered, that it obviously has something to do with the "MIDISERVER" background process:

If I kill this process (via activity-monitor) Dorico's CPU Usage immediately falls back to under 1 % in idle state or just a very few percent, when I'm working with it and is responsive as it should be.

Additional Information:

I'm using a Roland A-88 Master-Keyboard, which has, by the way, strange issues with the MIDI-Server-task anyway.
Sometimes the MIDIServer-Process itself takes too much CPU-Power.
BUT - when I was facing the described issue, the A-88 was not even connected to the computer. (!)

Maybe this information is helpful for the developers.

Thanks for your attention.

Best -

Andreas

User avatar
PaulWalmsley
Steinberg Employee
Posts: 761
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Dorico becomes very slow after a while...

Post by PaulWalmsley » Sat Nov 11, 2017 8:28 pm

That all sounds very odd. MIDIserver isn't part of Dorico, and we've not heard reports of this before.
Architect & Developer - Steinberg London

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Sat Nov 11, 2017 11:39 pm

We have certainly experienced problems where a MIDI keyboard or other MIDI device is flooding Dorico with MIDI data, which then ends up choking the application and making it unresponsive. Can you try following the steps on this page and zip up and attach the results of the Snoize MIDI Monitor process? Also, please do Help > Create Diagnostic Report from Dorico’s menus and attach the resulting zip file, which is saved on your desktop, to a reply here too.

AndreasB
New Member
Posts: 36
Joined: Sat Jul 16, 2016 6:26 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by AndreasB » Mon Nov 13, 2017 12:10 pm

Hi,

thanks for your replies.

I have attached a screenshot and the Diagnostics-ZIP.

I will also go on searching for the reason(s) for this strange behaviour.

Best -

Andreas
Attachments
Dorico Screenshot 100% CPU.jpeg
(381.26 KiB) Not downloaded yet
Dorico Diagnostics.zip
100% CPU Usage
(301.03 KiB) Downloaded 71 times

AndreasB
New Member
Posts: 36
Joined: Sat Jul 16, 2016 6:26 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by AndreasB » Mon Nov 13, 2017 12:15 pm

Hey guys,

I've probably found the reason:

As the problem only occurred in my studio I tried to disconnect all USB-Devices step by step.
When I disconnect my "RME ARC USB"-Remote device for my Fireface UFX Dorico is immediately as responsive as expected again.

Obviously, the continuous MIDI-Data generated by the ARC is causing this slow down.
Maybe it is an idea to implement a MIDI-filter option in order to ignore the Input of a certain MIDI-Port or filter certain MIDI-events?

Best -
Andreas

andgle
Member
Posts: 376
Joined: Wed Aug 10, 2016 6:36 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by andgle » Mon Nov 13, 2017 12:27 pm

Paul describes a way to disable midi devices manually in this post:
viewtopic.php?p=642106#p642106
Note that you'll need to find the correct name of your midi device. Daniel describes a method for this right below Pauls answer.
Anders

AndreasB
New Member
Posts: 36
Joined: Sat Jul 16, 2016 6:26 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by AndreasB » Mon Nov 13, 2017 12:56 pm

Hi Anders,

thanks for your reply!
It works!

Best -

Andreas

User avatar
PaulWalmsley
Steinberg Employee
Posts: 761
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Dorico becomes very slow after a while...

Post by PaulWalmsley » Mon Nov 13, 2017 1:46 pm

If it's SysEx data that the ARC is outputting then that's something that should be fixed in the next update
Architect & Developer - Steinberg London

Cherylhoad
New Member
Posts: 31
Joined: Tue Nov 15, 2016 3:48 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by Cherylhoad » Wed Nov 15, 2017 12:33 pm

Dear Daniel,

I'm also experiencing really slow input in Dorico - reading through this post, it seems the best idea to send you a copy of the score file at your email address?

best and many thanks,
Cheryl

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Wed Nov 15, 2017 12:43 pm

Yes, please do send me your project and we’ll take a look. Please also do Help > Create Diagnostic Report, and attach the zip file saved to your desktop to the email as well. If you’re on Mac, it would also be useful if you could attach a system profile: choose About this Mac from the Apple menu at the top left-hand corner of the screen, click the System Report button, then choose File > Save Report, and attach that report to the email too.

Thomas Eberth
Junior Member
Posts: 103
Joined: Wed Aug 10, 2016 10:08 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Thomas Eberth » Fri Nov 17, 2017 3:24 pm

For me too Dorico showed a latency at MIDI input. Daniel, I sent you my files on wednesday.

I closed and restartet Dorico, I closed any other aplication, I restartet Mac OS - nothing helped.

Today I came back to work on a Dorico project that was allready opened and that had the MIDI input latency yesterday. But today everything is fine. I only have a very small latency. Very strange!

Thomas
_______________________________________
working for http://www.butz-musikverlag.de

Mac OS 10.11 El Capitan
Finale 3.7 to 2014.5
MuseScore 2.0.3
Dorico 1.2

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Fri Nov 17, 2017 6:23 pm

Thomas, what kind of MIDI hardware do you have? It might be interesting to install and run Snoize MIDI Monitor to see whether it’s chucking out a continuous stream of MIDI controller or system exclusive messages – we have added some filtering to the forthcoming update so that Dorico will ignore these messages and they can thus not cause the program to become slower or unresponsive as it tries to handle all of the incoming messages.

User avatar
PaulWalmsley
Steinberg Employee
Posts: 761
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Dorico becomes very slow after a while...

Post by PaulWalmsley » Fri Nov 17, 2017 6:31 pm

If you have multiple MIDI devices and one of them is some kind of remote controller that outputs lots of sysex then there's also a method of disabling a single device in dorico. See viewtopic.php?f=246&t=106600&p=648570&h ... es#p642106
Architect & Developer - Steinberg London

Thomas Eberth
Junior Member
Posts: 103
Joined: Wed Aug 10, 2016 10:08 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Thomas Eberth » Fri Nov 17, 2017 6:51 pm

Daniel,
I use a Behriner U-Control UMX49 MIDI Keyboard for note input. It is connected via USB directly to my iMac.
I've sent you an email on wednesday with some diagnostic files and a Dorico file attached.

I tried Snoize MIDI Monitor and it seems that my MIDI keyboard continously sends MIDI data. See the attached and zipped Snoize file.

Thomas
MIDI data.mmon.zip
(6.48 KiB) Downloaded 55 times
_______________________________________
working for http://www.butz-musikverlag.de

Mac OS 10.11 El Capitan
Finale 3.7 to 2014.5
MuseScore 2.0.3
Dorico 1.2

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Fri Nov 17, 2017 7:11 pm

Why is your keyboard sending out “Chorus Send Level” messages continuously? Perhaps you can make sure that all of the various knobs and sliders etc. are set to 0 and are not being nudged or twiddled unnecessarily.

Thomas Eberth
Junior Member
Posts: 103
Joined: Wed Aug 10, 2016 10:08 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Thomas Eberth » Fri Nov 17, 2017 7:29 pm

All knobs are set to 0, no buttons pressed. I don't know why there's continously data sent. I'll try to find it out. Turning the keyboard off and on again did not help.

Thomas
_______________________________________
working for http://www.butz-musikverlag.de

Mac OS 10.11 El Capitan
Finale 3.7 to 2014.5
MuseScore 2.0.3
Dorico 1.2

Thomas Eberth
Junior Member
Posts: 103
Joined: Wed Aug 10, 2016 10:08 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Thomas Eberth » Fri Nov 17, 2017 8:13 pm

I reset my keyboard to factory settings. Now it doesn't send any continous messages and Dorico doesn't have any latency anymore.

Thank you Daniel for your advice to use Snoize MIDI Monitor, which I did not know before.

Thomas
_______________________________________
working for http://www.butz-musikverlag.de

Mac OS 10.11 El Capitan
Finale 3.7 to 2014.5
MuseScore 2.0.3
Dorico 1.2

User avatar
Daniel at Steinberg
Moderator
Posts: 5954
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Sat Nov 18, 2017 1:00 am

Great, I’m glad you were able to sort this out!

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: DaddyO, lbuckley, normberk and 11 guests