Dorico becomes very slow after a while...

Discussions about our next-generation scoring application, Dorico.
User avatar
Daniel at Steinberg
Moderator
Posts: 5396
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Wed Jul 19, 2017 2:03 pm

We are still looking into this problem, but I believe you should see an improvement in the responsiveness of the application if you go into Layout Options, and on the Staves and Systems page, set the 'Fixed number of systems per frame' option to 1. You should also find that inputting and editing is faster in galley view than in page view.

User avatar
Andre
Member
Posts: 359
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico becomes very slow after a while...

Post by Andre » Wed Jul 19, 2017 3:37 pm

Daniel at Steinberg wrote:
Wed Jul 19, 2017 2:03 pm
We are still looking into this problem, but I believe you should see an improvement in the responsiveness of the application if you go into Layout Options, and on the Staves and Systems page, set the 'Fixed number of systems per frame' option to 1. You should also find that inputting and editing is faster in galley view than in page view.
Daniel, it's a miracle! Setting 'Fixed number of systems per frame' option to 1 made everything back to normal. Input notes work as it should. Thanks so much! Also the lyric input is at normal speed now, which was very slow as well before. I am still working in Page view btw. I like that better than Galley view. Btw, does this mean that changing this frame setting will always slow down the note input or is this some kind of bug?
My music and tutorials on http://www.andrevanharen.com
iMac 2,8 GHz Intel Core i5, 16 GB ram, macOS High Sierra.
Sibelius 6.2, Sibelius 7.5, Sibelius 8.5. Cubase 8.5, Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, NotePerformer 2.0 etc etc...

User avatar
Daniel at Steinberg
Moderator
Posts: 5396
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico becomes very slow after a while...

Post by Daniel at Steinberg » Thu Jul 20, 2017 11:17 am

To return to this issue: the reason that your project is so slow is because you have deleted the 'First' master page pair from the master page set being used by your project. When you have no 'First' pair, then even if you have the option in Layout Options to make new flows start on new pages set, in fact Dorico will try to make a new flow fit at the end of the previous frame if possible. This is perhaps unexpected, but not a bug (and on balance after discussion here we have decided that we will change this behaviour, so if you have that option set to always use a new frame, it will do so even if there's no 'First' master page pair set).

So what is going on in your project, André, is that each new flow is trying to get squeezed into the same frame as the end of the previous flow, and this is having a knock-on effect on the amount of casting off that Dorico is doing. Casting off is computationally expensive and can also result in other processing being done, and overall this makes the application less responsive when a larger and larger range needs to be cast off.

You therefore have two further options you can use to restore snappy performance in your project:

1. Duplicate your current 'Default' master page pair and set it to be have the special 'First' role. Even though it doesn't look any different, it will then allow the "new flows start new frames" option to work as you expect, and that will eliminate the need for extra casting off; or

2. Insert a frame break at the start of each flow, which tells Dorico that the flow should definitely start in a new frame and hence it shouldn't try to squeeze it in the previous one.

Once you do either or both of the above steps, you can switch off the 'Fixed number of systems per frame' option in Layout Options again.

As a result of looking into this we've decided both to change the behaviour of the option to control where new flows start (which we expect to be in the next minor update) and to look further into the casting-off code to see if we can detect this case and handle it more efficiently (which is a bigger job and will have to wait for the future), but you should be all set anyway if you follow either or both of the steps described above.

User avatar
Andre
Member
Posts: 359
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico becomes very slow after a while...

Post by Andre » Thu Jul 20, 2017 12:12 pm

Thanks for the explanation Daniel, I am glad that you were able to find out what caused the problem and that it's acutally my unusually use of the program that gave this effect. Well, all these unexpected uses help to make Dorico become the best notation software around :)
My music and tutorials on http://www.andrevanharen.com
iMac 2,8 GHz Intel Core i5, 16 GB ram, macOS High Sierra.
Sibelius 6.2, Sibelius 7.5, Sibelius 8.5. Cubase 8.5, Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, NotePerformer 2.0 etc etc...

eheilner
New Member
Posts: 23
Joined: Sat Mar 18, 2017 5:10 pm
Contact:

Re: Dorico becomes very slow after a while...

Post by eheilner » Sat Aug 12, 2017 9:22 pm

Daniel -
I too am experiencing significant slowdown. My problem appears related to the size of my project. If I take a subset of my piece (first 3 pages) everything works fine, but it takes anywhere from 10 to 60 seconds for my screen to refresh when working with the full score. Given that my piece is scored for a quartet and is only about 200 bars long, clearly this should not be happening. I can continue work by splitting my piece up, but that is obviously not a good solution.

I have tried the usual fixes - restarting Mac, closing and opening Dorico - but no luck.

I am running late 2012 Mac Mini, Sierra 10.12.6, with 16 Gig

I will e-mail you files. Hopefully I am doing something dumb.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: bobk and 10 guests