Page 1 of 2

Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:03 am
by Terry Jones
Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro, which is a shame as i was hoping to be able to use the new features to score a film I'm working on while I'm forced to work on my laptop away from my main studio setup.

I've tried most of the recommended codec/container combinations listed on the Steinberg help page here: https://helpcenter.steinberg.de/hc/en-u ... and-Dorico including DV/DVCPro, MJPEG/PhotoJPEG, H264 and Avid DNxHD in the appropriate containers.

The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:
Screenshot 2018-06-23 23.50.27.png
blank video window in thumbnail
(85.8 KiB) Not downloaded yet
The strange thing is that the very same videos seem to to attach to a Cubase 9 Artist (9.0.30) project on the same machine with no issues whatsoever and play flawlessly. I was under the impression that both programs make use of the same video playback technology so at this point I'm stumped as to what the issue could be.

I'd really like to get this working before I fly out of the country on Monday, so if anyone has any suggestions about how to fix this problem I'd be very glad to hear them. :)

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:07 am
by andgle
IIRC, the video will only be as long the flow it is attached to. Try adding a few more beats or measures

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:25 am
by Terry Jones
andgle wrote:
Sun Jun 24, 2018 12:07 am
IIRC, the video will only be as long the flow it is attached to. Try adding a few more beats or measures
Yeah I tried that already multiple times, added 50 bars to the flow, no difference.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:28 am
by pianoleo
Are you in the right mode (Play mode) ?

I may be preaching to the choir here, but do read the instructions in the Version History here if you haven’t already: http://download.steinberg.net/automated ... istory.pdf

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:34 am
by Terry Jones
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?

I may be preaching to the choir here, but do read the instructions in the Version History here if you haven’t already: http://download.steinberg.net/automated ... istory.pdf
I've been attaching it in Setup Mode directly onto the Flow itself, the video dialogue even comes up to let me set the framrate, timing offsets etc so I don't think that's the issue here.

Right now I'm considering just reinstalling Dorico from scratch and seeing if that resolves the problem.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:40 am
by -steve-
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode.
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro[...]
That just looks totally wrong. Are you able to open the Video Properties window? What's in there?

Maybe the install is screwed up, uninstall/reinstall doesn't take much time, have you checked that?

Edit- we typed at the same time, lemme know how it goes. I'm using video in Dorico as we speak. What are you using to convert the video? I can share settings if you like.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:52 am
by -steve-
Here're the settings I used in Resolve for a video that attaches properly, and plays back, etc. (the audio is 48k PCM) Note the frame rate for the video and audio is constant, not variable. (but really, the reinstall seems a more likely fix.)

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 12:53 am
by pianoleo
-steve- wrote:
Sun Jun 24, 2018 12:40 am
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode
Steve, I’ve never touched video in Dorico, but I did read and comprehend the documentation.

I’d like to suggest you do the same, preferably before shouting users down.

Dorico 2 Version History, Page 4.

“In Play mode, drag the video file from the folder where it is located and drop it on the timeline at the position where you want the video to be attached.”

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 1:06 am
by Terry Jones
-steve- wrote:
Sun Jun 24, 2018 12:40 am
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode.
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro[...]
That just looks totally wrong. Are you able to open the Video Properties window? What's in there?

Maybe the install is screwed up, uninstall/reinstall doesn't take much time, have you checked that?

Edit- we typed at the same time, lemme know how it goes. I'm using video in Dorico as we speak. What are you using to convert the video? I can share settings if you like.
Hi Steve,

Yes reinstalling is the option i'm seriously considering right now. I'm using a progam I've used for years called Pavtube HD Video Convertor for this and it's served me well before with getting videos into the correct format for Sibelius and Cubase. I also attempted re-rendering the video from inside Sony Vegas 14 to see if I had any more luck there.

I can certainly get the video properties box up and that's looks fine to my eyes (aside from the fps discrepancy):
video properties.png
(99.11 KiB) Not downloaded yet
I do have Dorico installed on my main machine as well so I'll see if I get the same behaviour there.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 1:47 am
by Terry Jones
Ok, so after some testing I think I definitely need to reinstall Dorico 2 on my laptop as I managed to attach the video without issue on my desktop machine:
Dorico 2 desktop.png
(437.23 KiB) Not downloaded yet
The exact same video file gave me the result I described before on the laptop Dorico installation. I'll report back on how this goes.

<edit> Ok reinstalling didn't seem to solve the issue, but then I didn't trash my preferences or anything like that either... my previous files still showed up in the hub for instance. I'm wondering if I have to hose my system completely of the program before it'll work.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 2:27 am
by Terry Jones
Ok so it looks like I've got it working again, although I'll have to redo all my preferences probably, or import them from my desktop setup.

Just in case anybody else comes across the same issue I basically uninstalled Dorico then deleted any related folders in the following locations (Windows 10):

C:\Program Files\Steinberg\Dorico 2
C:\Users\<username\AppData\Roaming\Steinberg\Dorico 2
C:\Users\<username>\AppData\Roaming\Steinberg\VSTAudioEngine2_64

I also cleaned up the registry a bit.

The video import is now running perfectly for me. :)

Re: Dorico 2 Pro - cannot get video import to work

Posted: Sun Jun 24, 2018 2:27 am
by -steve-
Great news.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 4:35 pm
by Terry Jones
I'm sorry to say the problem keeps reoccurring for no good reason. I'll be working away just fine on a score with the same video for some time then suddenly when I decide to reopen my score in Dorico later on to do more work the video decides to stop working again... and no amount of restarting or rebooting the PC resolves it.

I'm getting a bit tired of having to fully uninstall Dorico, clear all the my preferences and any files then reinstall it all again just to get working video in my projects, there must be good reason this keeps happening (maybe a bug in video playback system) but I haven't figured it out yet.

<edit> Trying a different approach after doing a bit of research on Cubase video issues (as I imagine they use the same engine), I'm now busy converting the video to ProRes format using this tool: https://audiospot.audio/audiospot-creativetools

I'll report back on whether this works or not (without reinstalling Dorico).

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 9:04 pm
by Terry Jones
OK, so that didn't work. I'm really starting to think it's actually a random bug with the video engine in Dorico rather than anything I'm doing wrong as far as conversion goes, the same video file opens and plays perfectly in Cubase Artist 9.0.30. Ironically the last time I posted about this here the issue was on my laptop, this time it's on my main PC. ;)

I don't know if it's of any help as far as possible bug testing goes but i decided to go poking around in the files for both Cubase and Dorico and noted that videoengine.dll for each is slightly different:
videoengine.dll comparison.png
(23.64 KiB) Not downloaded yet
Whether this has a bearing on my issue I don't know, I'm not a programmer by trade, but I thought it was interesting nonetheless.

So I guess I'm going to have to do what I did last time; uninstall Dorico, trash all my preferences and start over again. This is only annoying because when everything is working as it should it's pretty much flawless, synchronisation is rock solid and navigating through the video using the shortcuts is quick and painless... just generally writing to film in Dorico is a joy. Hopefully whatever is going on here can be resolved eventually.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 9:25 pm
by -steve-
I read through your posts about this, and I don't see anywhere that you tried re-attaching (aka re-importing) the video file. Have you done this?

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 9:31 pm
by Terry Jones
-steve- wrote:
Thu Jul 19, 2018 9:25 pm
I read through your posts about this, and I don't see anywhere that you tried re-attaching (aka re-importing) the video file. Have you done this?
Yes I tried multiple times in both the original project I was working on and in a completely fresh solo piano template from the default menu to make sure, it's the same issue every time. Currently reinstalling...

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 9:52 pm
by Terry Jones
Interestingly now I've reinstalled the ProRes video is showing up in the project but I only have audio, I'll try re-encoding to Avid DNxHD and see if that works any better.

<edit> Well I don't have a license for that codec but it certainly let me know that in the video window itself in Dorico, so I presume it would work in that case.
Avid DNxHD Notice.JPG
(139.63 KiB) Not downloaded yet
I'll try the H264 codec in the conversion tool I mentioned as a last resort before I go back to what I was using before the issue started.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 9:52 pm
by arco
When it fails, perhaps send the log so they can check.
Perhaps try another video converter (or try any video file from another source).

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 10:22 pm
by Terry Jones
arco wrote:
Thu Jul 19, 2018 9:52 pm
When it fails, perhaps send the log so they can check.
Perhaps try another video converter (or try any video file from another source).
I tried converting the original file again to the H264 codec in a .mov container using the same utility and now it's working fine, however it remains to be seen just how long it will keep working for this time... I'm not entirely convinced about the stability of the Dorico video playback engine yet.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Thu Jul 19, 2018 11:17 pm
by Daniel at Steinberg
Sorry you're having these kinds of problems, Terry. Would it be possible for you to share the original file with us, for the purposes of troubleshooting? If so, please send it to me via WeTransfer (to d dot spreadbury at steinberg dot de) so I can ask the video engine team if they have any ideas.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Fri Jul 20, 2018 12:26 am
by Terry Jones
Daniel at Steinberg wrote:
Thu Jul 19, 2018 11:17 pm
Sorry you're having these kinds of problems, Terry. Would it be possible for you to share the original file with us, for the purposes of troubleshooting? If so, please send it to me via WeTransfer (to d dot spreadbury at steinberg dot de) so I can ask the video engine team if they have any ideas.
Ah well, this is the thing, it's all working again now so I'm not sure me sending you the Dorico file will help that much as I replaced the original video with a newly encoded version. however I can if you like. It does use quite a few third party plugins (Kontakt and Engine mainly) and Noteperformer 3 as well though.

<edit> The file for the previous cue I was working on (which had similar issues to begin with) does still have the filename for the original video attached although the file itself has since been deleted, I could send that instead.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Fri Jul 20, 2018 4:04 am
by pianoleo
I think I read on another thread that a) video paths should not contain unusual characters, b) should not be more than a certain number of characters (128 IIRC) and c) should be stored on a local drive, not a network location.

It was at least weeks ago if not months ago, and I’ve not done any research recently to back up these criteria, but just in case my memory is working properly you could double-check that your video file meets these three criteria...

Re: Dorico 2 Pro - cannot get video import to work

Posted: Fri Jul 20, 2018 8:10 am
by Ulf
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:

Screenshot 2018-06-23 23.50.27.png
Hi Terry,
pretty late, but it is just now that I read this thread. Looking at the screenshot, I think this is the same issue that I am sometimes running into. On the taskbar the video window gets shown as a small preview, but it does not appear on the screen, because it is shifted off-screen outside of the visible area. How it gets there? I have no idea, but this is how I get it back:

Hover with the mouse over the Dorico icon in the taskbar, so that the small preview video window appears. Move the mouse to the middle of it and do a right click. From the then appearing context menu choose 'Move'. The mouse cursor will change to an arrow pointing into all 4 directions (and will move somewhere to the edge of the screen). Now, press one of the cursor keys (up, down, left or right), but only once. The cursor shape will then change back to normal, but if you now move the mouse, the video window's position will follow the mouse cursor. Position it at a convenient location, make one left-click and the video window will stay.

Hope this helps.

Re: Dorico 2 Pro - cannot get video import to work

Posted: Fri Jul 20, 2018 9:41 pm
by Terry Jones
Ulf wrote:
Fri Jul 20, 2018 8:10 am
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:

Screenshot 2018-06-23 23.50.27.png
Hi Terry,
pretty late, but it is just now that I read this thread. Looking at the screenshot, I think this is the same issue that I am sometimes running into. On the taskbar the video window gets shown as a small preview, but it does not appear on the screen, because it is shifted off-screen outside of the visible area. How it gets there? I have no idea, but this is how I get it back:

Hover with the mouse over the Dorico icon in the taskbar, so that the small preview video window appears. Move the mouse to the middle of it and do a right click. From the then appearing context menu choose 'Move'. The mouse cursor will change to an arrow pointing into all 4 directions (and will move somewhere to the edge of the screen). Now, press one of the cursor keys (up, down, left or right), but only once. The cursor shape will then change back to normal, but if you now move the mouse, the video window's position will follow the mouse cursor. Position it at a convenient location, make one left-click and the video window will stay.

Hope this helps.
Hi Ulf,

Cheers, that's very interesting and yes that certainly what appears to be what's happening in my case when it does go wrong, I'll keep that one in mind if I run into the issue again. :)

Terry

Re: Dorico 2 Pro - cannot get video import to work

Posted: Mon Aug 20, 2018 9:18 pm
by Terry Jones
For the record I just had this issue pop up again (in Dorico Pro 2.1) and Ulf's advice worked just fine. I still find it very odd because it hasn't done that for ages and seems very random, but at least it's easy to correct now. :)