Page 1 of 1

UAD-1 Plugins not working on Cubase 9 !

Posted: Thu Dec 08, 2016 12:37 am
by geko
Hey there,
I've just made the upgrade and to be honest I didn't saw any news from steinberg about discontinue 32-bit plugs,
well I can understand that and I think its a good move , I'm still using very little amount of 32bit (and important one that I use every project) but I can find a new plugs to replace them to work with since the old one don't have any 64bit versions.
the big problem is my UAD-1, unfortunately the latest version you can use from them is v6.1.0 that not support 64bit
(I tried to download the latest version but it doesn't recognise the card)
so my question is what can I do?
the plugs I can replace but my UAD-1 I can't, there is any other possibility to work with that?
I will be more then happy to know since all my projects use my UAD-1 plugs
thanks and hopefully that someone will find any solution