REV-X plugins not working after update, elicenser confusion

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
User avatar
Tantroniq
New Member
Posts: 28
Joined: Wed Oct 03, 2012 3:02 pm
Contact:

REV-X plugins not working after update, elicenser confusion

Post by Tantroniq » Fri Feb 02, 2018 10:36 pm

After updating Cubase 9 artist during the process of downloading it to a second computer (havent used it on that laptop yet. nor removed the licenser from my main pc) and updating the elicenser, I now no longer appear to have licenses (according to Cubase) to use the REV-X plugins that came with my version of Cubase. Now there is some confusion was to whether I am right about them coming with Cubase, but after being told on another forum that they are NOT steinberg plugins I was later told they came with certain Steinberg UR models (I have the UR44). As far as I can tell they were never not in the list of available reverb plugins.

In any case they are being used in projects, and I would like to continue using them. This problem of getting a cubase error message about them only happened after what I gather to be an update of the licenser software. Here is what someone on a facebook forum said:

"The REV-X plug-ins are bundled with The Steinberg audio interfaces that have DSP like the UR 242 and higher.
I think that there is a sheet with the license codes on it for the included plug ins."

Anyway, attached ais the error message I am getting from within Cubase:
elicenser rev ex.JPG
(25.69 KiB) Not downloaded yet
And of course I cant select a license that is not there. And notice I cant click "help!" since its not there.

Any ideas/ solutions appreciated.

Below is the link to the post on this forum on this same issue that was resolved (somehow? its unclear reading the posts) perhaps as suggested by placing the elicenser into another USB port, which makes little sense to me since the missing license is so very ultra specific.


viewtopic.php?f=250&t=119879&p=651006&h ... EV#p651006

User avatar
Tantroniq
New Member
Posts: 28
Joined: Wed Oct 03, 2012 3:02 pm
Contact:

Re: REV-X plugins not working after update, elicenser confusion

Post by Tantroniq » Sat Feb 03, 2018 2:11 am

I just tried to update the UR44 driver and got a message box along the lines of asking me if I want to "undo" my setup, and I opted for No Thanks.

(sigh) Will be glad when I have this figured out.

Romantique Tp
External Moderator
Posts: 3011
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: REV-X plugins not working after update, elicenser confusion

Post by Romantique Tp » Sat Feb 03, 2018 2:51 am

Yes, REV-X and Guitar Amp Classics aren't stock Cubase plugins, they're a bonus for owners of certain Steinberg UR interfaces. You can download their latest version from here:
https://www.steinberg.net/en/support/do ... _ur44.html

Go to your MySteinberg and check if you can see the Basic FX Suite license. If it's not there, you might have not activated or registered them properly.
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

User avatar
Tantroniq
New Member
Posts: 28
Joined: Wed Oct 03, 2012 3:02 pm
Contact:

Re: REV-X plugins not working after update, elicenser confusion

Post by Tantroniq » Sat Feb 03, 2018 7:06 pm

OK now I am beginning to suspect a much larger eLicenser problem. I'll spare the details and assume I have now fixed that one and now just need to get these UR44 tools REinstalled Its a little confusing because I do not see a .exe among the items extracted from the compressed zip download.

Anyone have any experience with installing these tools? The instructions do not match what I am seeing (no .exe ) AND nothing I have tried seems to load those licenses for the Basic FX suite. :(

Romantique Tp
External Moderator
Posts: 3011
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: REV-X plugins not working after update, elicenser confusion

Post by Romantique Tp » Sat Feb 03, 2018 7:35 pm

There's an .exe file inside almost every folder in that .zip. Try redownloading it.
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

User avatar
Tantroniq
New Member
Posts: 28
Joined: Wed Oct 03, 2012 3:02 pm
Contact:

Re: SOLVED REV-X plugins not working after update, elicenser confusion

Post by Tantroniq » Mon Feb 05, 2018 8:31 pm

Ok so Im just sharing this in case anyone else runs into this.

Shortest possible summary: I had an old dongle for a legacy version of Cubase, I had a newer dongle for the new version of Cubase. For reasons that arent clear the new licenses for the UR44 plugins were placed on the old dongle (eventhough I purchased the UR44 after purchasing Cubase 9 and had not used those plugins in anything BUT Cubase 9). Then the old dongle DIED. This explains why it was a sudden issue, why ONLY those plugins were affected, etc etc etc. Also why there were changes in the licenses shown in the eLicenser.

So I implemented Steinbergs Zero Downtime and it all worked like it was supposed to. If you end up with a defective dongle not all hope is lost. They deactivated the old dongle and gave me new activation codes for the things on the old dongle. Yay.

Post Reply

Return to “General”

Who is online

Users browsing this forum: Lasso and 4 guests