ilok can't load protection component? - SOLVED - Launch as admin

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
misnoma
Junior Member
Posts: 57
Joined: Sun Jan 02, 2011 11:00 pm
Contact:

ilok can't load protection component? - SOLVED - Launch as admin

Post by misnoma » Wed Jun 13, 2018 3:17 pm

To help future fellow users searching for help . . .

Since installing the Windows 10 April update, I had an issue with Cubase pro 9.5 (and other VST hosts) where none of my iLok-protected plugins would validate or instantiate.

"ilok can't load protection component os error 0x05"

I contacted PACE/iLok support. After providing much information, and running their diagnostics, they said their software was working correctly and i should contact the DAW and plugin developers for further assistance. (Steinberg, Soundtoys, Sony Oxford, TC ELectronic etc).

I was disappointed with iLok/PACE support's level of knowledge and interest. They seemed to wash their hands of the problem.

After much uninstalling, re-installing, etc, I found the fix/workaround:

Right-click the Cubase icon and choose "Launch as administrator".

Maybe this is because I have permissions issue on my hard disk? But it's good to have a workaround.

Now I have adjusted the Cubase executable's properties>compatibility>always launch as admin, and the plugins work ok.

I hope this helps someone.
Cubase Pro 9.5, Windows 10 Fall Creators Update. i7-7700K. RME 9632. Waves. Sonnox.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests