Page 1 of 1

10 Licence work with old versions?

Posted: Wed Feb 27, 2019 9:34 pm
by ferrisio
Hi, I want to buy Cubase 10 Pro but the computer at a studio I use has 8 installed. Will my new e-Licenser with a 10 licence on work to run v8 on the other computer on the rare occasions I work there? I understand obviously I can only run one version at once, and I'd need to bring my v10 e-Licenser with me and plug it in.

Re: 10 Licence work with old versions?

Posted: Thu Feb 28, 2019 10:44 am
by Martin.Jirsak
Hi and welcome,

Yes. With Cubase Pro 10 license you can start Cubase Pro 9.5/9/8.5/8... and older Cubase versions.

Re: 10 Licence work with old versions?

Posted: Thu Feb 28, 2019 12:09 pm
by Melyssa48
Would be nice to see one back though.

Re: 10 Licence work with old versions?

Posted: Fri Mar 01, 2019 1:40 am
by Scab Pickens
Melyssa48 wrote:
Thu Feb 28, 2019 12:09 pm
Would be nice to see one back though.
:?

Re: 10 Licence work with old versions?

Posted: Fri Mar 01, 2019 3:05 am
by -steve-
Melyssa48 is a spam artist, but wasn't playing close enough attention to make a sensible reply to the topic. So bye bye. :lol: