Cubase 10.5 audio performance vs CPU usage

Use this forum for an overview of issues and to report new ones.
Post Reply
User avatar
Gibsonion2
New Member
Posts: 38
Joined: Tue Feb 21, 2017 6:56 am
Contact:

Cubase 10.5 audio performance vs CPU usage

Post by Gibsonion2 » Tue Dec 17, 2019 7:27 am

What are other peoples experiences of how much of their system is used by Cubase when it's pushed to the limit?

Using 10.5 but had this problem across multiple versions and PCs for years, I've got a fairly powerful system (see specs in my signature), so I'm sure Cubase should be able to handle a hell of a lot more than I'm throwing at it, but my audio performance is peaking out even when my system says only around 30% of RAM and CPU are being used and the disk usage is about 5-10% during playback.
  • I've tried buffers upto 2048 & 4096
  • Disabling all other programs
  • Switching off antivirus etc.
  • Disabling background processes
  • Dozens of setting variations
  • Boosted Audio Priority
  • ASIO guard on and off
  • Switching GFX card to high performance mode
  • Audio Power Scheme on and off
  • Disabling unnecessary services
  • Changing Windows power scheme options to be all high performance
  • Changing BIOS settings
I've tried every performance tip I can find, but nothing seems to give any significant improvement.

Using the following plugins with a buffer setting of 2048 32bit float 44.1KHz my audio performance is maxing out at 100% even while idle 30% CPU 32% RAM and won't even playback:
90 x Tracks
74 x FabFilter Q2
44 x SB Vintage Compressor
9 x Waves SSL Channel Mono
9 x SB GEQ 10
8 x STL Tonality
8 x Waves Scheps Omni Channel
7 x SB Studio Chorus
7 x Fabfilter C2
6 x Slate Trigger 2
5 x SB Stereo Enhancer
4 x Fabfilter MB
4 x Fabfilter L
3 x Waves Scheps Omni Channel
2 x Slate Virtual Mix Rack
2 x Waves H-Reverb
2 x Fabfilter G
2 x Waves Doubler to Stereo
1 x SB Stereo Delay
1 x Roomworks SE
1 x Pingpong Delay
1 x Ozone 8 Dynamic EQ
1 x Ozone 8
1 x Mono Delay
1 x Melodyne
1 x Magneto II
1 x Fabfilter Saturn
1 x SB Distroyer
1x TSE BOD


That might look like a lot, but most of them are basic compressors and EQs that could easily run hundreds on a 10 year old machine, as for ones that are have any noticeable load increase at all there's maybe 30 low 10-15 high increase, which isn't that many IMO

I remember using almost that many plugins 15 years ago on Cubase SX3 and 4 with 3 gigs of RAM, a 2Ghz Pentium on with Windows XP

Am I right to think there's bottle neck somewhere and I should be getting a lot more out of my specs? Or is there some limitation of Cubase's audio processing I'm hitting that means it can't use all of the resources available to it? I'm at a loss, I'd love to know if this is what other people's experiences are with how much of their full system Cubase uses when maxed out.
System:
Windows 10 Pro 64bit, Cubase 10.5 Pro, i7 5960X @ 3.7Ghz, MSI X99A SLI PLUS, 64GB DDR4 @ 3Ghz, MSI 980ti GFX 6GB, 500GB 970 EVO (OS Drive), 6TB NAS HD (Audio Drive), 2TB SSHD (Sample Libraries), L6 UX2, M-Audio Delta 1010
(My drivers are always up to date.)

User avatar
Gibsonion2
New Member
Posts: 38
Joined: Tue Feb 21, 2017 6:56 am
Contact:

Re: Cubase 10.5 audio performance vs CPU usage

Post by Gibsonion2 » Sun Dec 29, 2019 1:32 am

No ideas?
System:
Windows 10 Pro 64bit, Cubase 10.5 Pro, i7 5960X @ 3.7Ghz, MSI X99A SLI PLUS, 64GB DDR4 @ 3Ghz, MSI 980ti GFX 6GB, 500GB 970 EVO (OS Drive), 6TB NAS HD (Audio Drive), 2TB SSHD (Sample Libraries), L6 UX2, M-Audio Delta 1010
(My drivers are always up to date.)

cubace
Member
Posts: 664
Joined: Sat Jan 01, 2011 6:41 pm
Contact:

Re: Cubase 10.5 audio performance vs CPU usage

Post by cubace » Sun Dec 29, 2019 9:57 am

It is annoying that VST cpu runs out long time before machine cpu resources do. And I see the same on my systems. I can't get buffers like 4096. Are you not using any VSTi? Freezing tracks are the option left, and that works best with vsti's.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 5 guests