Page 1 of 1

CI 2+ pops and cracks loudly while playing demanding games

Posted: Mon Apr 09, 2018 10:25 pm
by Thesk
Hi
it pops and cracks loudly (at random). It's not White static noise or humming (50Hz) it is just random singular pops and cracks at a time. though it's all the time while playing demanding games.
sometimes the sound would go away with a pop and then return a couple of seconds later.
iv'e had the issue for a long time and i just thought it was a random thing that would go away again, but it didn't.

i'm using a external USB Souncard: Steinberg CI 2+ (https://www.steinberg.net/en/products/a ... n_kit.html)

is it the motherboard that can't power the External USB soundcard while i'm gaming?
or
is it the soundcard it self that is faulty?
or
Maybe the Drivers for it doesn't work properly with Win 10?
and
why are the noises there?

btw:
My rig:
  • FX-8350 4GHz-octa core (Coolermaster Seidon 120V)
    Asus GTX 1050 DUAL 2Gb 2V
    12G Ram
    Asrock Pro3 R2.0 (newest bios update)
    Energon 550watts PSU
    Soundcard: Steinberg CI 2+ Advanced integrating Studio (newest drivers x64 TOOLS for CI2+ V1.9.9 for Windows)
    Windows 10 Professional x64
Any and all help would be deeply appreciated.

Cheers ! :D

Re: CI 2+ pops and cracks loudly while playing demanding games

Posted: Sun Apr 15, 2018 8:53 am
by DaveFry
The latest driver ( Dec 28th 2017 ) is Version 1.10.0 https://www.steinberg.net/en/support/do ... river.html

If you still get dropouts , then :
Windows Control Panel > All Control Panel Items
Open the Yamaha Steinberg USB Driver entry
In the ASIO tab raise the Buffer Size one increment at a time and test until the dropouts stop .

Re: CI 2+ pops and cracks loudly while playing demanding games

Posted: Tue Aug 14, 2018 11:57 am
by djw
DaveFry wrote:
Sun Apr 15, 2018 8:53 am
The latest driver ( Dec 28th 2017 ) is Version 1.10.0 https://www.steinberg.net/en/support/do ... river.html
*June 1, 2018