Ogg exporting less samples than it should

All topics on WaveLab 7 and WaveLab Elements 7
Post Reply
User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Ogg exporting less samples than it should

Post by dorremifasol » Mon Jan 30, 2012 5:37 pm

I'm encoding some .ogg files for a game, but there seems to be a bug in the encoder and it actually encodes less samples than it should. The result: if I encode a looped ambient sound, the end and start don't match because the encoder cuts the size for whatever the reason. Tried lots of combinations, sample rates, bit rates, file sizes, with the same result.

I needed to put my 500+€ professional sound editing program aside, and download a free one (oggenc2) to get the job done right. And it's not the first time.

I'm sorry to say it that way, but it's depressing.
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

PG
Moderator
Posts: 7177
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Ogg exporting less samples than it should

Post by PG » Mon Jan 30, 2012 5:55 pm

I once had a similar report, but couldn't reproduce the problem.
Can you give an exact example? What sample rate, how many samples, the encoding parameters, and with method do you use in WaveLab (Save as, render, batch processor, batch encoding...).

Thanks
Philippe

User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Re: Ogg exporting less samples than it should

Post by dorremifasol » Mon Jan 30, 2012 6:46 pm

I'm using "Save As" with the following options

type: "Ogg Vorbis",
Channels: match input stream (currently stereo)
Sample rate: match input stream (currently 44100 Hz)
Encoding: VBR, but I tried several combinations of fixed ratio and VBR qualities with the same result.
Bit resolution: 16 bit

The original file is 162831 samples long, and the encoded, once decoded is 161792.

At first I thought it was a limitation of the ogg encoding scheme (needing full frames or something like that), but the other encoder makes files which, once decoded, have exactly the same size as the original uncompressed file.

I can send you the audio file if necessary.
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

PG
Moderator
Posts: 7177
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Ogg exporting less samples than it should

Post by PG » Tue Jan 31, 2012 6:36 am

With WaveLab 7.2.1, I have taken a stereo wav, cut it to 161792 samples as you, then use the Save As function, and saved as VBR, and the result is 161792 samples. No lost.
What do you do different than me?
Philippe

User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Re: Ogg exporting less samples than it should

Post by dorremifasol » Tue Jan 31, 2012 8:15 am

Please notice I said the original file is 162831 samples long, and the decoded one is 161792.

I realized that, if we measure the length of both files in chunks of 2 kilobytes, the original would be 79,50732421875 chunks and the final one exactly 79 chunks. Maybe this is a clue.
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

PG
Moderator
Posts: 7177
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Ogg exporting less samples than it should

Post by PG » Tue Jan 31, 2012 9:21 am

Oops, I have to redo the test.
Philippe

PG
Moderator
Posts: 7177
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Ogg exporting less samples than it should

Post by PG » Tue Jan 31, 2012 9:30 am

I can reproduce now. Same thing in WaveLab 6. I note to fix this in the future.
Philippe

User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Re: Ogg exporting less samples than it should

Post by dorremifasol » Tue Jan 31, 2012 9:36 am

Thank you very much, Philippe.
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

wavcatcher
Junior Member
Posts: 185
Joined: Thu Dec 16, 2010 8:31 am
Contact:

Re: Ogg exporting less samples than it should

Post by wavcatcher » Wed Feb 01, 2012 12:53 am

Hey Phillippe,

Today I finally had a chance in between projects to send you some examples of the Wavelab OGG encoder problems I encountered a few weeks ago.

Not sure if they are the same as the issues you found with this thread but wanted to post here as well to let you know I sent the files for you to review.

And, thanks for checking into this further- I'll be curious to hear if my missing audio issues are resolved by whatever you found out in this thread.
~Chris
Wavetrap
Sound Design | Audio Recording & Mixing
--------------------------------------------------------
Macbook Pro i7 17" 8GB RAM, and Macbook Pro Retina 15" 16GB Ram and 512GB SSD | RME UCX | Metric Halo 2882 2dexpanded | Kush GainTrain | Steinberg CC121 | Logic 9, Nuendo 6 + NEK, Wavelab 8, PT10.3.6, Reason 7, NI Komplete Ultimate 9. Omnisphere. GRM Tools, Waves, Izotope, Sonnox, + standard & esoteric plug ins. | Moog & Access Synths, Guitars and FX. Coffee and Motorbikes.

User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Re: Ogg exporting less samples than it should

Post by dorremifasol » Fri Nov 09, 2012 11:46 am

Can we expect a fix for the Ogg export size mismatch bug soon? :)

Cheers
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

User avatar
dorremifasol
Member
Posts: 456
Joined: Wed Dec 15, 2010 5:20 pm
Contact:

Re: Ogg exporting less samples than it should

Post by dorremifasol » Tue Mar 19, 2013 2:43 pm

bump...
Intel i5 750, Windows 7 64 bit, 16g RAM, Cubase 9, Halion 6, Wavelab 9.5 RME Fireface 802

PG
Moderator
Posts: 7177
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Ogg exporting less samples than it should

Post by PG » Tue Mar 19, 2013 2:45 pm

This will be fixed in next version.
Philippe

Post Reply

Return to “WaveLab 7 | WaveLab Elements 7”

Who is online

Users browsing this forum: No registered users and 5 guests