Page 1 of 1

Shortcut to Spectrum Editor Changes to Spectral Damping

Posted: Sat Jan 19, 2013 10:01 am
by tonyyoungblood
I made a keyboard shortcut to the Spectrum Editor (called Spectrum Selection under Customize Commands). Note that I mean the actual Spectrum Editor, not the Spectrum view that is accessible by the tabs at the bottom of the screen. Incidentally, using the keyboard shortcut is the only way I can get the Spectrum Editor to work. Selecting it via Workspace > Specific Tool Windows > Spectrum Editor will bring it up, but all the commands are grayed out and inaccessible. That's annoying, but it's not the issue I'm posting about.

The issue is this: Occasionally, my shortcut to Spectrum Editor will cease to bring up Spectrum Editor. Instead, it processes "Spectral Damping" wherever my cursor happens to be. If I close the program and bring it back up, the shortcut works again.

The shortcut I use is Shift-V. I won't get into my reasons for this specific shortcut; just know that it's important for my workflow. (So please, no responses like, "Why not just change the shortcut???")

I discovered another way to reset the shortcut. I bring up Customize Commands and search for Spectrum Selection. It still shows Shift-V as the shortcut. But underneath, a message says, "Already used by Copy from Cursor To Replace Selection." See attachment. Note that it only shows this message AFTER the shortcut stops bringing up Spectrum Editor.

I clear the shortcut and then set it to Shift-V again. That clears the assignment to "Copy from Cursor To Replace Selection," and, presto, Shift-V brings up the Spectrum Editor again.

For a while.

Eventually, it inexplicably goes back to Spectral Damping. Something is automatically setting Shift V to "Copy from Cursor To Replace Selection," which has the effect of Spectral Damping. What's going on here?

Re: Shortcut to Spectrum Editor Changes to Spectral Damping

Posted: Sat Jan 19, 2013 10:14 am
by PG
Selecting it via Workspace > Specific Tool Windows > Spectrum Editor will bring it up, but all the commands are grayed out and inaccessible.
This shows the window, this does not enter.
Use this instead:
C:\Users\Philippe\Documents\Pictures\2013-01-19_10-13-28.png

Re: Shortcut to Spectrum Editor Changes to Spectral Damping

Posted: Sun Jan 20, 2013 2:28 am
by tonyyoungblood
Thanks, Philippe. That's good to know.

Still, any idea why my shortcut keeps getting set to spectral damping?