UR824 disappearing

This section is about Steinberg's UR and UR-RT USB audio interfaces product range
Post Reply
ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

UR824 disappearing

Post by ptram » Sat Apr 14, 2012 11:18 pm

Hi,

I did a radical change to my system, by purchasing a new Mac with a new OS (Lion). I installed the new driver, and connected the UR824. Everything went fine the first time.

Then, again, the awful thing happening with the older computer happened again: the UR could not be found by all music applications (Sound control panel, Audio and Midi Setup, Logic, Kontakt). This time it was not seen as "stopped", but it was totally non-existant.

At the same time, System Profiler says the interface is there. So, the hardware is recognized; the driver is not.

Again, by restarting the Mac everything started working again. Turning the UR off and then on there were no problems. Putting the Mac to sleep with the UR did not cause any problem.

So, it is something happening over time. Something is causing the driver to disappear, or something like this. The only trace it leaves is this kind of error message in the system log:

14/04/12 22:31:47,448 Yamaha Steinberg USB Control Panel: kCGErrorInvalidConnection: CGSGetWindowTags: Invalid connection
14/04/12 22:31:47,448 Yamaha Steinberg USB Control Panel: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Paolo

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Tue Apr 24, 2012 1:22 am

I've been using an RME FireFace USB on the old MacBook I was using with the UR for a few days, and it is working flawlessly (after a few days of use). At the same time, the UR keeps disappearing from my new Mac, as it did on the old one.

If someone from Steinberg is listening, I would like to ask them to not turn their Macs off, but to put them to sleep and check what will happen after a few days. The UR is the only problematic device on my systems, so I've some reason to believe there is something wong with the Mac driver.

Making the report on the Console a bit more "chatty" would probably help tracking this issue. I've not yet sold the UR, despite purchasing my new RME, because the sound quality is so good that I hope the manufacturer will want to solve this issue, and not continue denying it even exists.

Regards,
Paolo

Guest

Re: UR824 disappearing

Post by Guest » Wed Apr 25, 2012 12:49 pm

Could you provide the exact Mac model you have and the TOOLS for UR824 you currently use?
Which OS version exactly is currently installed?
Do you work in the 64-bit domain or is everything on 32-bit?
Have you tried different USB ports on your Mac?

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Thu Apr 26, 2012 10:49 am

Hi Ed, thank you very much for your interest.

The Mac was a MacBook Pro Early 2008 with the latest version of Snow Leopard and 6GB or memory; now it is a Mac mini 2011 with the latest version of Lion and 8GB or memory.

As far as I know, Lion is all 64-bit; by reading the data in Activity Monitor, it seems that nearly all apps are 64-bit. Kontakt 4, one of the apps that cannot see the UR after a while, is 64-bit.

The UR Tools are, as reported by the dspFXMix console, version 1.0.4. Boot 1.00, Main 1.00, Sub 1.00. Incidentally, in this moment the console saw the UR being turned on; but it is still not seen among the audio devices in Lion's Audio MIDI Setup. In this situation, the only way to make it reappear is usually rebooting the Mac.

I've tried different ports and different USB cables. The UR is connected to its own USB port (even if the way the Mac mini manages these ports might make it share it with the computer's keyboard). It was connected to its own USB port in the MacBook Pro (that one was a separate USB bus).

Do you see any pattern here? I will be happy to send you any report from the Mac's console, or the like.

Best regards,
Paolo

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Thu Apr 26, 2012 10:53 am

Ed, maybe this log can help you track this issue. They are the relevant messages received since I turned the UR on (keep in mind it is not working as an audio device).

26/04/12 11:41:04,232 Kontakt 4: Error loading /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: dlopen(/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: no matching architecture in universal wrapper
26/04/12 11:41:04,232 Kontakt 4: Cannot find function pointer NewPlugIn for factory C5A4CE5B-0BB8-11D8-9D75-0003939615B6 in CFBundle/CFPlugIn 0x101edc820 </Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin> (bundle, not loaded)
26/04/12 11:41:04,233 Kontakt 4: Error loading /Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere: dlopen(/Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere: no matching architecture in universal wrapper
26/04/12 11:41:04,233 Kontakt 4: Cannot find function pointer New_SHP_PlugIn for factory 834FC054-C1CC-11D6-BD01-00039315CD46 in CFBundle/CFPlugIn 0x101edc8b0 </Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin> (bundle, not loaded)
26/04/12 11:42:22,216 [0x0-0x313313].com.native-instruments.Kontakt 4: Latency (Input: 1, Samplerate: 16000) device: 16, stream: 0, securityoffset: 21, buffer: 512, total: 549
26/04/12 11:42:22,216 [0x0-0x313313].com.native-instruments.Kontakt 4: Latency (Input: 1, Samplerate: 16000) device: 16, stream: 0, securityoffset: 21, buffer: 512, total: 549
26/04/12 11:44:30,514 [0x0-0x314314].com.yamaha.dspMixFx_UR824: Qt: QCursor: Cannot create bitmap cursor; invalid bitmap(s)
26/04/12 11:46:18,876 dspMixFx_UR824: -_continuousScroll is deprecated for NSScrollWheel. Please use -hasPreciseScrollingDeltas.
26/04/12 11:46:18,877 dspMixFx_UR824: -deviceDeltaX is deprecated for NSScrollWheel. Please use -scrollingDeltaX.
26/04/12 11:46:18,877 dspMixFx_UR824: -deviceDeltaY is deprecated for NSScrollWheel. Please use -scrollingDeltaY.
26/04/12 11:46:25,495 Audio MIDI Setup: Error loading /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: dlopen(/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: no matching architecture in universal wrapper
26/04/12 11:46:25,496 Audio MIDI Setup: Cannot find function pointer NewPlugIn for factory C5A4CE5B-0BB8-11D8-9D75-0003939615B6 in CFBundle/CFPlugIn 0x7f8a58c64620 </Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin> (bundle, not loaded)
26/04/12 11:46:25,496 Audio MIDI Setup: Error loading /Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere: dlopen(/Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin/Contents/MacOS/WireTapAnywhere: no matching architecture in universal wrapper
26/04/12 11:46:25,497 Audio MIDI Setup: Cannot find function pointer New_SHP_PlugIn for factory 834FC054-C1CC-11D6-BD01-00039315CD46 in CFBundle/CFPlugIn 0x7f8a58c62bd0 </Library/Audio/Plug-Ins/HAL/WireTapAnywhere.plugin> (bundle, not loaded)
26/04/12 11:49:19,828 com.apple.usbmuxd: _handle_timer heartbeat detected detach for device 0x2b-192.168.1.193:0!
26/04/12 11:49:28,068 com.apple.usbmuxd: _SendDetachNotification (thread 0x7fff76cf4960): sending detach for device 28:6a:ba:37:ed:9d@fe80::2a6a:baff:fe37:ed9d._apple-mobdev._tcp.local.: _BrowseReplyReceivedCallback got bonjour removal.

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Wed May 02, 2012 3:37 pm

I did another try, and the problem is all there. But I guess I must exclude an issue with USB communication as a whole.

The UR works fine on both Macs after a reboot. It disappears as an audio device from all software after one or more sleeps.

However, dspMixFx continues to see the audio meters. When audio enters a channel, the meters in the console show the signal.

So, USB communication still exists. But no software on the Mac (including the Finder) can see it as an audio device.

I wonder if Steinberg did the test I suggested (put the Mac on sleep, and not turn it off). It should be easy to see if this issue can be reproduced or not.

Paolo

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Wed May 02, 2012 3:46 pm

By the way, I would like to know if there is a way to restart the UR driver only, without restarting the Mac. A few months ago there was a problem with Adobe's Creative Suite, and someone created an utility to reset part of that software, while waiting for a solution from Adobe (that arrived a few weeks later).

Also, I remember having used the Reset Audio Driver command in Logic with the MOTU 828mkII, when something like what I'm experiencing with the UR happened. It worked, and I could continue working without having to restart the Mac. I tried the same with the UR, and Logic 8 crashed.

Paolo

Guest

Re: UR824 disappearing

Post by Guest » Wed May 02, 2012 4:17 pm

We haven't been able to reproduce this here so far.
So you say that the UR has always been connected directly to the Macs without any USB hubs involved?
And it also happend on Mac OS X 10.6.x?

Is there anything specific you do before putting the computer to sleep? The sleep mode used is the default Safe Sleep mode?

There is a reset option in Cubase in the VST audio system category in the Device Setup at the bottom of the windows. Does this help to bring the device back to life?

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Wed May 02, 2012 4:57 pm

Ed, thank you very much for your answer.

The UR was connected to its own separate port on the MacBook Pro Early 2008 - and that one is a totally separate USB bus (as far as I can understand).
It is connected to a separate USB port on the Mac mini 2011, and this should be a separate port of an internal hub. The other device connected to the hub seems to be the alphanumeric keyboard. I'll try to connect the keyboard to a different port, and see what will happen.

The issue happened with OS X 10.6.8 and is happening with 10.7.3. These systems are working on two different computers (MacBook and Mac mini).

The sleep mode is the default one in both cases. It should be Safe Sleep, since I recently suffered a power shortage, and the Mac mini restarted with the previous situation. I guess this is due to Safe Sleep enabled?
There is nothing special I do before putting the Macs on sleep. I just choose the Sleep command. I don't know if there are other processes going on, but there is nothing that I can see in the Console.

Cubase AI cannot see the UR now that it is not showing in the system. When I'm in the Devices > Device Setup > VST Audio System section, the only choice I can have is Integrated Audio. Pressing the Reset button does not seem to produce any result (no new message appears in the Console either).

Is there any other test I can try? For example, may I kill the Steinberg/Yamaha audio driver in Activity Monitor, and then let it relaunch? If so, which is the process I must kill?

Best regards,
Paolo

Guest

Re: UR824 disappearing

Post by Guest » Fri May 04, 2012 9:56 am

I have forwarded the information to development. Due to some bank holidays in Japan, they will only have the chance to look at this after the weekend.

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Fri May 11, 2012 11:50 am

Hi Ed,

Please keep in mind that I would be happy to try a beta with a more "verbose" report in the Console.

In the meantime I can report this test:

A) I disconnected from the USB port an RME Fireface UC audio interface, and it disappeared from the list of available audio devices in Preferences > Sound and Audio MIDI Setup. I reconnected it, and it immediately reappeared.

B) I disconnected from the USB port a Logitech Fusion camera (not officially supported by Logitech on the Mac), and it disappeared from the list of available audio devices in Preferences > Sound and Audio MIDI Setup. I reconnected it, and it immediately reappeared.

C) At the same time, the UR824 is not seen among the audio devices (while being connected, turned on and seen by the dspMixFx console). With all other audio devices disconnected, I disconnected the UR and it disappeared from the dspMixFx console. I reconnected it, and it reappeared in the dspMixFx console; but, alas, it was still not among the audio devices.

This test was only conducted on a Mac mini 2011 with Lion (not on my other Mac).

Best regards,
Paolo

ptram
Member
Posts: 347
Joined: Thu Nov 24, 2011 6:37 pm
Contact:

Re: UR824 disappearing

Post by ptram » Mon Jun 04, 2012 3:45 pm

Since the latest Mac OS X upgrade (10.7.4), the 824 seems to be behaving correctly. I've not been using it extensively, but I'll keep it connected to my main system, and see if this will last. Since I reported my issue to Apple as well, maybe they could catch out the problem and fix it.

Paolo

Guest

Re: UR824 disappearing

Post by Guest » Fri Jun 08, 2012 8:44 am

Sorry, I was on vacation. Sounds promising and I hope it still works!

Post Reply

Return to “Steinberg UR Series”

Who is online

Users browsing this forum: No registered users and 1 guest