Audio recording to VST Transit Join in Bitwig not working properly.

Post all topics related to the VST Transit Join plug-in for third party sequencers here.
Post Reply
gezz
New Member
Posts: 5
Joined: Thu Jul 26, 2018 5:43 pm
Contact:

Audio recording to VST Transit Join in Bitwig not working properly.

Post by gezz »

Dear guys,

I thought I'd give the VST Transit Join beta a try using Bitwig 2.3.5 on Windows 7 (64 bit).

The Transit Join plugin is picked up nicely by Bitwig, login and setting up a project work fine. But unfortunately when trying to record audio I did not manage to record anything so far. When I route the output of the plugin to master I only hear a very distorted version of what I am trying to record.

The setup is very simple, just for testing. 1 audio track with about 40 seconds, stereo, sound. VST Transit Join plugin on an instrument track and is "preceded" by the Bitwig "Audio Receiver" internal device. This device is picking up the audio from the first track. I can see the VU meters in action. But hear only distortion.

Any suggestions?

Thanks,

Gerry

Tino Degen
Moderator
Posts: 45
Joined: Tue Jan 11, 2011 12:10 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by Tino Degen »

Hello Gerry,

thank you for your feedback and information. I´m sorry to hear that. We´ll verify this next week. best wishes, Tino

gezz
New Member
Posts: 5
Joined: Thu Jul 26, 2018 5:43 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by gezz »

Thank you Tino,

I am very willing to assist you with troubleshooting. I do have limited time, my feedback might take a few days.

Gerry

Tino Degen
Moderator
Posts: 45
Joined: Tue Jan 11, 2011 12:10 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by Tino Degen »

Hi Gerry,

we checked it now and could reproduce and can confirm the described behaviour.
The next will be finding the course and fix the issue in one of the next updates. I´ll
inform you when we solved it. We might ask you for confirming the fix before it´s
release. Thanks agian & best wishes, Tino

User avatar
Spork
Moderator
Posts: 328
Joined: Mon Nov 18, 2013 12:20 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by Spork »

Hi,

we found the problem. The bug is in Bitwig. The host audio buffer size will not be sent to a VST3 Plug-In. And a Plug-In needs this information. We are already in contact with Bitwig to get the issue fixed.

Meanwhile you could configure your Bitwig with an audio buffer size of 1024 and it will work. Yes?

See you,
Michael.
Michael Spork, Developer
Hamburg, Germany

gezz
New Member
Posts: 5
Joined: Thu Jul 26, 2018 5:43 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by gezz »

Hi Michael,

Wow that is quick good troubleshooting. I will try tonight (Sunday 5th) to see if this fixes the issue.

Regards,

Gerry

gezz
New Member
Posts: 5
Joined: Thu Jul 26, 2018 5:43 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by gezz »

Success! I managed to record a track of a about 45 seconds. In Bitwig's "Settings" go to "Audio" and set the "Block size" to 2014. I have a Focusrite Scarlett 6i6 configure for USB ASIO. When setting the Bitwig block size it automatically adjust the Focusrite ASIO driver to the correct audio buffers. By the way 23.22ms is an eternity ..... I will see if I can try smaller buffer sizes later.

Recording was very hit and miss. The interface is not quite evident at what moment the plugin will start recording. Is there a (short) manual available yet?

I discovered that if there is no output selected for the track, it won't record either. Unfortunately when trying to record it does switch all settings back to no-record. So I had to add silence at the beginning of my audio track otherwise I won't have enough time to click the three buttons to start recording.

Regards,

Gerry

User avatar
Spork
Moderator
Posts: 328
Joined: Mon Nov 18, 2013 12:20 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by Spork »

Hi,
gezz wrote:
Sun Aug 05, 2018 6:39 pm
Success! I managed to record a track of a about 45 seconds. In Bitwig's "Settings" go to "Audio" and set the "Block size" to 2014. I have a Focusrite Scarlett 6i6 configure for USB ASIO. When setting the Bitwig block size it automatically adjust the Focusrite ASIO driver to the correct audio buffers. By the way 23.22ms is an eternity ..... I will see if I can try smaller buffer sizes later.
Disable the "auto" option and move the buffer size slider to 1024. Then it should work.
gezz wrote:
Sun Aug 05, 2018 6:39 pm
Recording was very hit and miss. The interface is not quite evident at what moment the plugin will start recording. Is there a (short) manual available yet?
No, I am sorry. There is no manual available.
gezz wrote:
Sun Aug 05, 2018 6:39 pm
I discovered that if there is no output selected for the track, it won't record either. Unfortunately when trying to record it does switch all settings back to no-record. So I had to add silence at the beginning of my audio track otherwise I won't have enough time to click the three buttons to start recording.
In VST Transit Join there is a button (record sync) in the transport toolbar, a brown one, next to the the metronome button. This one should be enabled if you want to record. Transit Join is then in sync with the host. That means : if you hit the record button in Bitwig, the record state in Transit will be activated, too.
For Bitwig : You managed to route the audio you want to record to Transit? You need to add a Bitwig Audio Recorder module before the Transit Join module, choose the audio source and there you are. Yes?

And of course. Transit supports drag and drop. I.e., you can move clips from a host to the Join editor. Or a file from the Explorer/Finder to the Join Editor. But Bitwig does not support to drag clips to the Join Editor or any other VSTi editor :( But you could export your audio stuff to your Explorer and then drag it to Join.
Maybe I can talk to the Bitwig development team about that missing puzzle.

See you,
Michael.
Michael Spork, Developer
Hamburg, Germany

gezz
New Member
Posts: 5
Joined: Thu Jul 26, 2018 5:43 pm
Contact:

Re: Audio recording to VST Transit Join in Bitwig not working properly.

Post by gezz »

Hi Michael,

Thanks for the tip, I wondered what the strange brown icon was for. I kept switching it off, as it stopped me clicking the record button next to it. This works perfect:
  1. Add VST transit join to and empty Bitwig instrument track
  2. Add before the VST an Audio Receiver
  3. Set the source to whatever track or master audio you want to sent to the VST Transit plugin
  4. Arm the VST Transit plugin track for record (make sure brown button is on :D )
  5. Play/record and it works.
It might be a good idea just to make a screenshot of the interface for an open track and label the icons with some text on the screenshot. I might do this anyway to remind me of the functionality of the buttons.

I am trying to collaborate with another musician. I will keep you posted how that is going.

Regards,

Gerry

Post Reply

Return to “VST Transit Join Beta”

Who is online

Users browsing this forum: No registered users and 1 guest