"F" doesn't make a stationary cursor in the Project page ...

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

"F" doesn't make a stationary cursor in the Project page ...

Post by alexis » Tue Dec 13, 2016 12:43 am

Hi - In Cubase 7.5.40, I had a key command where F would toggle the scroll to be a stationary cursor or a stationary page.

That key command is still in there, but it doesn't seem functional in the project page anymore. The cursor moves L>R across the page, and when it hits the right border, the page snaps to a newer one and the cursor appears on the left border to start moving L>R again. Very difficult to edit that way.

I can't remember, but I *think* it may be properly functional in the Lower Zone - that part I'm not sure about.

Any ideas?

Thanks much!
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Martin.Jirsak
Forum Elder
Posts: 18631
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by Martin.Jirsak » Tue Dec 13, 2016 12:56 am

Hi,

The F Key Command is assigned to the Auto-Scroll function, by default. It means, if this is On, and the cursor goes out of the screen, the page changes.

It works here. It's independent for the Project page, and the Editor page, in the Project window. It depend, where the focus is. Only if the Link Project and Lower Zone Cursors is enabled, then even the Auto-Scroll is in sync.

When you start to edit something on the page, the Auto-Scroll is switched Off automatically (by default, thanks to the Suspend Auto-Scroll when Editing settings).
Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 1:05 am

Martin.Jirsak wrote:Hi,

The F Key Command is assigned to the Auto-Scroll function, by default. It means, if this is On, and the cursor goes out of the screen, the page changes.

It works here. It's independent for the Project page, and the Editor page, in the Project window. It depend, where the focus is. Only if the Link Project and Lower Zone Cursors is enabled, then even the Auto-Scroll is in sync.

When you start to edit something on the page, the Auto-Scroll is switched Off automatically (by default, thanks to the Suspend Auto-Scroll when Editing settings).
Thanks, I'll go look at those preferences.
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

stingray
Senior Member
Posts: 1052
Joined: Thu Dec 16, 2010 12:55 am
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by stingray » Tue Dec 13, 2016 1:15 am

The 'F' key was never specifically for selecting stationary cursor behaviour. It is for activating auto scroll, where the cursor automatically follows playback in either page scroll or stationary cursor mode.

To clarify, try the following:

- select 'Stationary Cursor' on the small downward pointing arrow on the project window toolbar (next to the auto scroll button
- start playback
- press the 'F' key to Follow the playback (or not Follow the playback) in stationary cursor mode

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 2:49 am

stingray wrote:The 'F' key was never specifically for selecting stationary cursor behaviour. It is for activating auto scroll, where the cursor automatically follows playback in either page scroll or stationary cursor mode.

To clarify, try the following:

- select 'Stationary Cursor' on the small downward pointing arrow on the project window toolbar (next to the auto scroll button
- start playback
- press the 'F' key to Follow the playback (or not Follow the playback) in stationary cursor mode
Thank you! It was the stationary cursor I didn't have selected. Very happy now :) .
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 6:56 am

So sorry - it still seems a little odd here: When I'm in the project page, and the cursor is off the screen, if I hit "F", Cubase brings me to the part of the project that makes the cursor visible. That's nice, and it's like it was in Cubase 7.5.40.

It used to be the same way if I were in the Edit page when I was in 7.5.40. But now, if I'm editing, and the cursor is off the page, I can't find it by hitting "F", no matter what combination of buttons I try up at the top (the Autoscroll button, and the Switch Auto Scroll Settings dialogues).

Can someone help me with the bolded part please (if it's possible in Cubase 9)?

Thanks!
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Martin.Jirsak
Forum Elder
Posts: 18631
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by Martin.Jirsak » Tue Dec 13, 2016 8:43 am

Hi,

Is Cubase playing back or is it stop at the moment, you describe?
Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 9:09 am

Playing, thank you.

And almost certain, but not quite, that it occurs with Cubase stopped too.

Thanks-
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Martin.Jirsak
Forum Elder
Posts: 18631
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by Martin.Jirsak » Tue Dec 13, 2016 10:28 am

It works as expected here on both Mac and Windows.

Sorry to ask again... Are you 100% sure the focus is in the Lower Zone editor, while pressing the F Key Command? Is there the while frame around the Lower Zone Editor, please?
Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

stingray
Senior Member
Posts: 1052
Joined: Thu Dec 16, 2010 12:55 am
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by stingray » Tue Dec 13, 2016 1:43 pm

alexis wrote:It used to be the same way if I were in the Edit page when I was in 7.5.40. But now, if I'm editing, and the cursor is off the page, I can't find it by hitting "F", no matter what combination of buttons I try up at the top (the Autoscroll button, and the Switch Auto Scroll Settings dialogues).

Ditto what Martin says. It works OK here. Are you sure you have the focus on the editor?

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 5:09 pm

Can you guys try it in VariAudio please? It's the only window I can find that acts this way - while playing, if the cursor is off the screen I can't get Cubase to show it to me.

Thanks much!
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

stingray
Senior Member
Posts: 1052
Joined: Thu Dec 16, 2010 12:55 am
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by stingray » Tue Dec 13, 2016 5:41 pm

Works as expected here, with or without variaudio. Auto scroll and all scrolling behaviour is entirely as expected.
Last edited by stingray on Tue Dec 13, 2016 5:50 pm, edited 2 times in total.

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by alexis » Tue Dec 13, 2016 5:49 pm

Thx, Stingray.

I'll put together a repro. As of now, if my cursor is off the page in a VariAudio window, I can't have Cubase bring me to the cursor 's play position by hitting "F", like I can in Cubase 7.5.40.
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

stingray
Senior Member
Posts: 1052
Joined: Thu Dec 16, 2010 12:55 am
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by stingray » Tue Dec 13, 2016 5:51 pm

Strange.

Variaudio should make no difference to playback and autoscroll behaviour. All playback and autoscroll behaviour is entirely normal and predictable here. Please tell us exactly what you are doing in a precise step-by-step procedure.

Martin.Jirsak
Forum Elder
Posts: 18631
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: "F" doesn't make a stationary cursor in the Project page

Post by Martin.Jirsak » Tue Dec 13, 2016 7:18 pm

Hi,

It works here, in the Sample Editor (VariAudio) as expected as well.
Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests