Can Parts Keep Color when added to a folder?

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Sun Jan 22, 2017 4:33 am

I've tried different settings but can't seem to get this working.
I searched the Manual and online and nuthin.

I have my tracks colored the way I want but whenever I add them to a folder the parts (Not the Track itself) get changed to the folder color.

So IOW,
Outside of the folder, the tracks and parts have their default color that I created for it.
Put Inside the folder and the Track keeps the color but the parts get changed to the folder color.

Is there a setting I am over looking so that this DOESN'T happen?

I've spent hours setting up my colors and defaults and can't get this to work...it's very annoying to have to do it manually every damn time.

Thank u.

:geek:
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

User avatar
ZeroZero
Senior Member
Posts: 1041
Joined: Sat Jan 08, 2011 10:58 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by ZeroZero » Sun Jan 22, 2017 10:22 am

This is not happening here. Have you tried different settings in Prefs/Event Display/ tracks, auto track color mode?
Cubase 9, 64 bit Intel 8700k, Asus Rog Strix z390 mobo, 64 gig RAM PC, Win10, Focusrite Liquid 56 Running in Surround 5.1 British Rail sandwich circa 1967, a singing fish and an inert K9.

http://memory-alpha.org/wiki/Zero_Zero

User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Sun Jan 22, 2017 10:29 am

ZeroZero wrote:This is not happening here. Have you tried different settings in Prefs/Event Display/ tracks, auto track color mode?
If you only knew...lol
I have gone nuts trying the settings...

Mind you, i'm speaking of the parts not the actual tracks.
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

User avatar
orchetect
Member
Posts: 530
Joined: Fri Jan 14, 2011 1:28 am
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by orchetect » Tue Jan 24, 2017 6:12 am

I'm not sure what's going on there. I have no problems and can't replicate what you're describing.

ie: Tracks are colored red, inside a folder colored orange. The regions on those tracks still show up as red. (The regions already have the 'Default Color' property by default, and so they auto-inherit).

Am I missing something?
Steffan Andrews | Composer for Film/TV | Custom iPad control surface developer | website | imdb
DAW: Mac Pro 6,1 (trashcan) 3.5GHz 6-core 64GB RAM, 4TB SSD, macOS 10.14.6, Cubase 10.5.0 GM, Dorico 2.1
Converters/Monitoring: UA Apollo Duo Thunderbolt x 2, Apollo 16 Thunderbolt, Focal Trio6/Sub6
Gear: Vertigo VSM-2, Pultec EQM-1S3 pair, Manley Massive Passive, Neve Portico II Master Buss Processor, Manley ELOP, Manley Nu Mu, API 2500, Smart C2, Dangerous Compressor, Millennia STT-1 & HV-3C, Aurora GTQ2 x 2, Manley Core, Neumann M149 / U87ai / TLM170R pair / KM184 mt, Schoeps CMC64 stereo pair, Gefell UM70S, AT5040 & AT5045, Yamaha CP33, 5 iPads running custom DAW control surface software

User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Tue Jan 24, 2017 10:03 am

orchetect wrote:I'm not sure what's going on there. I have no problems and can't replicate what you're describing.

ie: Tracks are colored red, inside a folder colored orange. The regions on those tracks still show up as red. (The regions already have the 'Default Color' property by default, and so they auto-inherit).

Am I missing something?
Snapshot coming up...
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Tue Jan 31, 2017 10:34 pm

SO again,
Here's my Issue.
When I put the tracks in folders, the tracks keep the colors but parts get folder color...
I want the track AND parts to keep their original colors.
I tried different settings and can't get them to keep their colors.
:geek:
No Folder.png
Tracks and Parts have their color
(1.34 MiB) Not downloaded yet
Folder.png
Parts get changed to Folder color.
(1.36 MiB) Not downloaded yet
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

User avatar
orchetect
Member
Posts: 530
Joined: Fri Jan 14, 2011 1:28 am
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by orchetect » Wed Feb 01, 2017 12:14 am

I'm scratching my head here. Don't have Cubase in front of me to poke around. Are you sure it's not a preference somewhere? I'm not advocating it, but I wonder about moving your pref folder to the desktop (while Cubase is quit) then reopening your project and see if the effect changes. (Obviously quit and move it back after).

What if you start a new empty session (not from a template, just totally empty) and add some colored tracks to a folder, does the same thing happen?

I'm almost wondering if I should post an empty project with tracks set up working correctly and you open it or vice versa to see if the effect is a pref or a project setting.
Steffan Andrews | Composer for Film/TV | Custom iPad control surface developer | website | imdb
DAW: Mac Pro 6,1 (trashcan) 3.5GHz 6-core 64GB RAM, 4TB SSD, macOS 10.14.6, Cubase 10.5.0 GM, Dorico 2.1
Converters/Monitoring: UA Apollo Duo Thunderbolt x 2, Apollo 16 Thunderbolt, Focal Trio6/Sub6
Gear: Vertigo VSM-2, Pultec EQM-1S3 pair, Manley Massive Passive, Neve Portico II Master Buss Processor, Manley ELOP, Manley Nu Mu, API 2500, Smart C2, Dangerous Compressor, Millennia STT-1 & HV-3C, Aurora GTQ2 x 2, Manley Core, Neumann M149 / U87ai / TLM170R pair / KM184 mt, Schoeps CMC64 stereo pair, Gefell UM70S, AT5040 & AT5045, Yamaha CP33, 5 iPads running custom DAW control surface software

Accel0001
Junior Member
Posts: 112
Joined: Mon May 11, 2015 6:32 am

Re: Can Parts Keep Color when added to a folder?

Post by Accel0001 » Wed Feb 01, 2017 12:29 am

Parts with default color inherit the color from its parent.
Image
DAW: Cubase 10.0.50 (6.5 - 10), FL Studio 20.6 (8 - 20.6), Ableton Live 10 (8-10), Reaper, Studio One, etc.
PC: Win7 Ultimate, i7 3930K 4.2GHz (OC), 32GB RAM

Razzia
Junior Member
Posts: 97
Joined: Thu Oct 13, 2016 3:31 am
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by Razzia » Wed Feb 01, 2017 12:31 pm

Funny.. I WANT this to happen and I don't think it does. Almost always when I move something into a group I want everything to be the same color so it's easier to spot different sections on the mixer. Pretty sure I always have to change it by hand.
Cubase Pro 9 / Ableton Live 9 Suite / Ableton Push 2 / Novation LaunchKey 25 / Steinberg CMC-CH
Audient iD4 / ART Voice Channel
Win 10 Pro x64 / i7 6700k / 200 GB SSD / 2TB HDD / 16 GB RAM

Accel0001
Junior Member
Posts: 112
Joined: Mon May 11, 2015 6:32 am

Re: Can Parts Keep Color when added to a folder?

Post by Accel0001 » Wed Feb 01, 2017 2:33 pm

Cubase color inheritance test.gif
(924.91 KiB) Not downloaded yet
DAW: Cubase 10.0.50 (6.5 - 10), FL Studio 20.6 (8 - 20.6), Ableton Live 10 (8-10), Reaper, Studio One, etc.
PC: Win7 Ultimate, i7 3930K 4.2GHz (OC), 32GB RAM

User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Wed Feb 01, 2017 6:45 pm

Accel0001 wrote:
Cubase color inheritance test.gif
Thx for the gif... it took me a couple of tries to understand but clicked when I read the previous post about "Default Color" and "Parent"

See, Now is there a way to turn that off. I DON'T want it to change color to the parent.

I spent hours configuring all my colors in the settings and want them to stay that way when I put them in the folder.
I don't want to spend anymore time in a project working on colors...
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

User avatar
peakae
Grand Senior Member
Posts: 3053
Joined: Sat Jan 05, 2013 8:15 pm
Location: Bedroom
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by peakae » Wed Feb 01, 2017 8:44 pm

I tried to move varius yellow and red tracks into a purple folder, they keep their color including parts.
Tried all available preference settings and changing the global default color versus the track color, no difference.

Try starting Cubase in safe mode, it could be a corrupt preference file.
Or something completely different, never encountered that behaviour.
Cubase Pro 10, Wavelab Elements 9, I7 3770K , win10x64, 16Gb Ram, RME Raydat, Steinberg MR816x, Motu 828mkII, Behringer ADA8200, Yamaha moXF6, Steinberg UR242, Yamaha THR 10, Grace Design m900, CMC TP, CMC CH.

stingray
Senior Member
Posts: 1052
Joined: Thu Dec 16, 2010 12:55 am
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by stingray » Thu Feb 02, 2017 2:20 am

peakae wrote:I tried to move varius yellow and red tracks into a purple folder, they keep their color including parts.
Tried all available preference settings and changing the global default color versus the track color, no difference.
Tested here too. Works flawlessly.

Accel0001
Junior Member
Posts: 112
Joined: Mon May 11, 2015 6:32 am

Re: Can Parts Keep Color when added to a folder?

Post by Accel0001 » Sat Feb 04, 2017 1:25 am

'Default color' is not just a shortcut for color, its behavior is different from other colors'. I think 'Default color' is not the specific color but an attribute for inheriting the color from its parent.

This behavior seems to be same on older versions of Cubase (I checked it on 6.5, 7, 7.5, 8, 8.5 with clean settings). On Cubase6.5, default color is not changeable. They are all grey.

The fact that 'Default color' track head indicates the color defined in Preference (not the inherited color) may have been confusing users. It should be called 'Color for inherit mode' 'Color for follow mode' or something like that.

Old similar topics
Events default wrongly to folder colour
viewtopic.php?t=6703
Is this intended? Auto coloring issue
viewtopic.php?t=37331
Last edited by Accel0001 on Sat Feb 04, 2017 10:58 pm, edited 3 times in total.
DAW: Cubase 10.0.50 (6.5 - 10), FL Studio 20.6 (8 - 20.6), Ableton Live 10 (8-10), Reaper, Studio One, etc.
PC: Win7 Ultimate, i7 3930K 4.2GHz (OC), 32GB RAM

Accel0001
Junior Member
Posts: 112
Joined: Mon May 11, 2015 6:32 am

Re: Can Parts Keep Color when added to a folder?

Post by Accel0001 » Sat Feb 04, 2017 3:07 pm

Here are some macros.

PLE Preset - Set Color1 to Selected Audio Tracks
Property, Property is set, Event is selected, And
Container Type is, Equal, Track, And
Media Type is, Equal, Audio
Set Color, Set to fixed value, Color 1
Transform


Macro - Add Audio Track and Set Color1
Add Track - Audio
Process Project Logical Editor - Set Color1 to Selected Audio Tracks
(If you add multiple tracks, Color1 is applied to only last added track)

Macro - Set MyColors to Selected Tracks
Process Project Logical Editor - Set Color1 to Selected Audio Tracks
Process Project Logical Editor - Set Color2 to Selected MIDI Tracks
Process Project Logical Editor - Set Color3 to Selected Group Tracks
Process Project Logical Editor - Set Color4 to Selected FX Tracks
...
Cubase Macro - Apply different colors at a time.gif
Apply different colors to tracks depending on their type at a time
(37.8 KiB) Not downloaded yet
Both MIDI and Instrument Tracks are recognized as MIDI Tracks.
These macros need PLE window closed.
DAW: Cubase 10.0.50 (6.5 - 10), FL Studio 20.6 (8 - 20.6), Ableton Live 10 (8-10), Reaper, Studio One, etc.
PC: Win7 Ultimate, i7 3930K 4.2GHz (OC), 32GB RAM

User avatar
theRoyal1
Member
Posts: 474
Joined: Fri Nov 04, 2011 5:08 pm
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by theRoyal1 » Sun May 28, 2017 7:03 am

TY... I'll be doing some more checks but seems the latest update fixed this issue...

I think..lol
Custom WS: i7 3930k | Corsair H100 | Sapphire HD7950 Dual X | 64GB Patriot Viper III DDR3 1866 | MSI BigBang XPower II | 8xSamsung EVO=12TB + 2xWD4001=8TB HDD | Enermax 1200w 80+ Platinum | CM Cosmos II
Cubits : Cubase 10.5
CMC-TP | CMC-CH | CMC-PD | CMC-AI | 2xCMC-FD | CMC-QC

Main Gear: Access Virus Ti + Virus C | Maschine Studio + Jam | Korg Triton pro 76 | Novation SL MKII | Roland XV-5080 + JV-2080 | Goliath HD | Barefoot MicroMain27 Gen2 | Mackie HR824 | Yamaha AW4416 | MOTU MidiXT | Roland TR-8, TB-3, VT-3 | Seiki SE50UY04

Bodegaempire
Junior Member
Posts: 140
Joined: Fri Mar 09, 2012 6:24 am
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by Bodegaempire » Sat Jul 15, 2017 9:14 pm

theRoyal1 - did it get fixed on your system? Still a problem over here on OSX.

I started a separate thread about it and it seems like mine and yours have merged, now that I realize folders are the culprit.
OSX 10.14.3; Cubase 9.5.41
2011 Macbook Pro w/16GB ram
2015 iMac 21.5" i7
RME Babyface; MOTU Traveler, UAD-2 Satellite Thunderbolt

User avatar
Stephen57
Senior Member
Posts: 1762
Joined: Sat May 30, 2015 5:32 pm
Location: New York, NY
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by Stephen57 » Mon Jul 17, 2017 12:08 am

Accel0001 wrote:
Sat Feb 04, 2017 3:07 pm
Here are some macros.

PLE Preset - Set Color1 to Selected Audio Tracks
Property, Property is set, Event is selected, And
Container Type is, Equal, Track, And
Media Type is, Equal, Audio
Set Color, Set to fixed value, Color 1
Transform


Macro - Add Audio Track and Set Color1
Add Track - Audio
Process Project Logical Editor - Set Color1 to Selected Audio Tracks
(If you add multiple tracks, Color1 is applied to only last added track)

Macro - Set MyColors to Selected Tracks
Process Project Logical Editor - Set Color1 to Selected Audio Tracks
Process Project Logical Editor - Set Color2 to Selected MIDI Tracks
Process Project Logical Editor - Set Color3 to Selected Group Tracks
Process Project Logical Editor - Set Color4 to Selected FX Tracks
...

Cubase Macro - Apply different colors at a time.gif
Both MIDI and Instrument Tracks are recognized as MIDI Tracks.
These macros need PLE window closed.
Gold +1 Thank you!
-------------------------------------------------------
DAW: Cubase Pro 10 (Main), Cubase Pro 9.5 (Backup); PC: HP Z230, i5 CPU quad-core 3.5 Ghz, 16 Gigs RAM; OS: Win 7 Pro 64-bit; Audio Converters, Scarlett 2I4, Zoom UCR-8; USB MIDI Controller, Akai Advance 49. VST-Is: Spectrasonics Omnisphere 2.5, Stylus RMX; Air Music: Hybrid, Transfuser 2, Vacuum Pro, Velvet, Xpand2; Novation: Bass Station; Sonovox Grand Piano; Rack: Proteus 2000, Korg 03R/W, Yamaha TG 33. Monitoring with KRK Rokit 8/G3, Tannoy PBM 6.5 II, Mics. Scheops, Sennheiser, Rode, Lectrosonics RF, etc.

Help with Cubase:
Documentation: https://steinberg.help/
Location/file paths of presets in Cubase and Nuendo: https://helpcenter.steinberg.de/hc/en-u ... nd-Nuendo-
Preferences: https://helpcenter.steinberg.de/hc/en-u ... and-Nuendo

User avatar
Stephen57
Senior Member
Posts: 1762
Joined: Sat May 30, 2015 5:32 pm
Location: New York, NY
Contact:

Re: Can Parts Keep Color when added to a folder?

Post by Stephen57 » Mon Jul 17, 2017 12:31 am

Accel0001 wrote:
Sat Feb 04, 2017 3:07 pm
Here are some macros.
Excellent macros, thank you. I'm wondering, can Cubase pause during Macro execution to allow for user input?

I'd like the Macro to Pause and allow for a Color value to be selected. If possible, it would let related tracks be selected and the then a Color could be applied to them during the Macro's execution. Is that possible? Marcos are still challenging for me, but the ones I have working are very useful.

Take care for now. :-)
-------------------------------------------------------
DAW: Cubase Pro 10 (Main), Cubase Pro 9.5 (Backup); PC: HP Z230, i5 CPU quad-core 3.5 Ghz, 16 Gigs RAM; OS: Win 7 Pro 64-bit; Audio Converters, Scarlett 2I4, Zoom UCR-8; USB MIDI Controller, Akai Advance 49. VST-Is: Spectrasonics Omnisphere 2.5, Stylus RMX; Air Music: Hybrid, Transfuser 2, Vacuum Pro, Velvet, Xpand2; Novation: Bass Station; Sonovox Grand Piano; Rack: Proteus 2000, Korg 03R/W, Yamaha TG 33. Monitoring with KRK Rokit 8/G3, Tannoy PBM 6.5 II, Mics. Scheops, Sennheiser, Rode, Lectrosonics RF, etc.

Help with Cubase:
Documentation: https://steinberg.help/
Location/file paths of presets in Cubase and Nuendo: https://helpcenter.steinberg.de/hc/en-u ... nd-Nuendo-
Preferences: https://helpcenter.steinberg.de/hc/en-u ... and-Nuendo

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 5 guests