Project launch stuck at 60%

Discussions about our next-generation scoring application, Dorico.
Post Reply
JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Project launch stuck at 60%

Post by JonathanK » Sun Jan 21, 2018 8:46 pm

Using Dorico 1.2 on a MacBook Pro running 10.12.6 (Sierra). I have an existing project which up until a few minutes ago, ran perfectly. I experimented with some sounds in Play Mode using Halion and Kontakt 5. I have had no issues doing this in the recent past. The project was closed. Now, when I attempt to open it, the progress bar stays stuck at 60% and the project won't open. Cancelling causes the little watch icon to prohibit me from performing any other action in the Steinberg Hub so I must Force Quit Dorico even though there is no mention of it "not responding".

Is there a way to launch a project without using any sample libraries as I think I did something to cause this snafu. BTW, all of my other projects open without issue.

--Jonathan

LSalgueiro
Member
Posts: 953
Joined: Tue Oct 18, 2016 12:51 am
Contact:

Re: Project launch stuck at 60%

Post by LSalgueiro » Sun Jan 21, 2018 9:49 pm

I've suffered from a series of consistent, reproducible crashes (whose reason I don't yet know, unfortunately) that eventually made Dorico behave exactly the way you're describing, and they were always stuck consistently at 60% as well. It might not have anything to do with the sample libraries (though one can speculate that it might be traceable to the playback engine on the whole). Simply rebooting the computer got everything back on track.

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Re: Project launch stuck at 60%

Post by JonathanK » Sun Jan 21, 2018 10:38 pm

Thanks. I tried a system reboot but the same project remains stuck at 60% on launch.

User avatar
Ulf
Steinberg Employee
Posts: 1621
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Project launch stuck at 60%

Post by Ulf » Mon Jan 22, 2018 8:15 am

Could you please send the project file to u dot stoermer at steinberg dot de so we can analyze it and see why it gets stuck all the time?
I would have also suggested to reboot, but since that does not help in your case, there must be something fundamentally wrong with the project data.
We want to have a look at that.
Steinberg employee

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Re: Project launch stuck at 60%

Post by JonathanK » Mon Jan 22, 2018 11:49 pm

Hi Ulf,

Thank you for your response. It didn't open after a few reboots yesterday, but...today, Jan. 22 in the early evening after the MacBook Pro was turned off for 10 hours, the project opened!

When it opened, I immediately went to Play Mode and much to my surprise, the Kontakt instruments I setup were reverted to Halion. I saved that version, closed it, and when I attempted to open it, it froze at 60% once again.

I tried opening the version of the file in the backup folder, but the same freeze-up occurred.

I shut down the MacBook, booted it up again, attempted to launch the file, and the freeze-up at 60% occurred once again. I will send you the file.

Jonathan

User avatar
Ulf
Steinberg Employee
Posts: 1621
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Project launch stuck at 60%

Post by Ulf » Tue Jan 23, 2018 9:18 am

Jonathan, thanks for the data. Your project loads fine with me but I don't have Aria and only a very basic Kontakt installation without any sound library. I will discuss with the London guys and come back soon.

In the meantime, could you please stop Dorico, go to /Library/Audio/Plug-ins/VST and temporarily rename that folder to e.g. something like __VST ?
The in that folder contained Kontakt and Aria plug-ins are then not "seen" by Dorico's audio engine on the next start-up.
Does your project then load? This is just to find out if it is a plug-in issue.
If the project loads under that condition, please create a new folder called VST and just copy over Kontakt or just Aria. What happens then?
When it opened, I immediately went to Play Mode and much to my surprise, the Kontakt instruments I setup were reverted to Halion. I saved that version, closed it, and when I attempted to open it, it froze at 60% once again.
If by chance you still have that version with only HALion (and stuck at loading) then please also send that one to me.
Steinberg employee

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Re: Project launch stuck at 60%

Post by JonathanK » Tue Jan 23, 2018 11:45 am

I'll try later today, Ulf.

Yesterday, I recreated the music for the project in Dorico from a musicXML file originally created in Sibelius using the default Halion sounds without any third-party libraries. It loads without incident.

The issue seems to have something to do with Kontakt, Aria or the UVI Workstation. I have all three of those enabled in Dorico.

--Jonathan

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Re: Project launch stuck at 60%

Post by JonathanK » Wed Jan 24, 2018 12:01 am

Hi Ulf,

I renamed the VST folder, launched Dorico, selected the offending file and it opened. I quit Dorico, and performed the launch process again. The project opened. In the VST Instruments Panel of Play Mode, the Halion is listed. There are two blank slots for libraries. I must have instantiated Kontakt and Aria but since the VST folder was renamed, the libraries were not found and the two slots were left blank on launching.

I placed the Kontakt 5 16out.vst in the new VST folder (without any other VSTs) and the project launched successfully.

I swapped the Kontakt VST with the Aria VST in the new VST folder (without any other VSTs) and the project launched successfully.

I placed both the Kontakt and the Aria VSTs in the new VST folder and the project launched successfully.

I added the UVIWorstation.vst to the group in the new VST folder since I whitelisted it even though I did not instantiate it for this project and the project launched.

I renamed the original VST folder and tried that. Guess what? The project hung at 60%.
There are a LOT of VSTs in that folder. I have Logic Pro X, MixBus 32C and more plugins than I know what to do with. I'll see if I can find the offending combination later this week and get back to you whether I find anything or not. It's odd that the only one project is affected by this.

Thanks for your help, Ulf.

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

UPDATE Re: Project launch stuck at 60%

Post by JonathanK » Wed Jan 24, 2018 1:43 am

Ulf,

I found the VST causing the problem with the Dorico project.

Kontakt has three VSTs in the VST folder:
- Kontakt 5 8out.vst
- Kontakt 5 16out.vst
and
- Kontakt 5.vst

Kontakt 5.vst is causing the hangup. Removing it, or renaming it, it fixes the launch problem. The standalone Kontakt application still seems to run properly without that vst so I am not sure what its purpose is.

--Jonathan

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

2nd UPDATE Re: Project launch stuck at 60%

Post by JonathanK » Wed Jan 24, 2018 2:07 am

Oops, I wrote too soon. The Kontakt plugin will not launch within Dorico's Play Mode without Kontakt.vst present in the VST folder.
I recreated the project from the musicXML file that I originally started with. I used Halion, Aria and Kontakt in Play Mode just as I did in the problematic project. The new project has no problem opening. I also have other projects with mixed VST instruments and have no problem opening them.

The problematic file remains a mystery but at least it is not fatal.

--Jonathan

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

3rd Update Re: Project launch stuck at 60%

Post by JonathanK » Wed Jan 24, 2018 3:20 am

Sorry for belaboring this, but I found a different project which uses the Kontakt library and hangs at 60% on opening. Removing Kontakt.vst from the VST folder fixes the launch issue, but of course, that means I can't use the Kontakt Library for that project. Bummer.

And yet, other projects using Kontakt have no problem.

-Jonathan

Estigy
Member
Posts: 441
Joined: Thu Nov 10, 2016 11:56 am
Location: Austria
Contact:

Re: Project launch stuck at 60%

Post by Estigy » Wed Jan 24, 2018 8:18 am

Just to chime in with a little thing I noticed:

Yesterday when I opened a project I've been working on for the last weeks, it at first also seemed to stop at 60%. After about a 45 seconds (knowing this thread, it felt like half an hour, with me already panicking), the project opened successfully.
I do not have any other player or VST instruments here, this is a vanilla Dorico installation with HALion.

Is there anything happening at the 60% mark that can bring the opening process to a halt and that does not necessarily have something to do with Jonathan's VST instruments?

Greetings, E.
Dorico 3 on Windows 10
www.dorico-resources.net

User avatar
Ulf
Steinberg Employee
Posts: 1621
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Project launch stuck at 60%

Post by Ulf » Wed Jan 24, 2018 9:17 am

This all sounds weird in my ears, that the Kontakt.vst should cause a problem. Kontakt has different "flavours" of the plug-in because they offer different output configurations, i.e. stereo out, 8 and 16 individual outs. Don't know really for what purpose, most likely the stereo out uses a little less CPU than the multi out. By default we have only the Kontakt 16out whitelisted, because that is what we assume the users most likely want to have, so that they can tweak the sound of individual instruments in the Dorico mixer.

Have you edited the whitelist and also activated Kontakt and Kontakt 8out?

That what user Estigy mentions is a good point. It could happen that upon loading a plug-in is throwing some notification or error message and is waiting for a prompt, and that the notification window is not visible because it is hidden behind the Dorico window. When loading is stuck at 60%, please try and move the Dorico window to the side or minimize it to see if there is maybe something hidden behind.
Steinberg employee

JonathanK
New Member
Posts: 28
Joined: Tue May 24, 2016 2:33 am
Contact:

Re: Project launch stuck at 60%

Post by JonathanK » Wed Jan 24, 2018 12:04 pm

As you suggested, Ulf, I whitelisted Kontakt and Kontakt 8out. The project still hangs at 60%. I waited ten minutes but nothing changed. I moved the windows around but there was no other notification of any kind. I agree that the program is waiting for something. To get out of this situation, I close the 60% window. The little watch icon remains so I can't do anything else with Dorico. I have to Force Quit Dorico even though it does NOT say it is "not responding". It looks perfectly normal in the Force Quit window.

I would think cancelling the 60% window would allow Dorico to return to a usable state, but it doesn't. Not that I would know, but it seems like Dorico is in an endless loop or not receiving a notification of some kind.

Then again, sometimes I think Kontakt should be renamed Kryptik.

In an earlier message, I mentioned that I recreated the Yedikule project from a musicXML file. That uses the Halion, Aria, Kontakt and UVI Workstation sample libraries. It opens. It stayed at 60% for a nervous 10-15 seconds, but it finally did open and works beautifully.

I'll play with this later today.

--Jonathan

User avatar
Ulf
Steinberg Employee
Posts: 1621
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Project launch stuck at 60%

Post by Ulf » Wed Jan 24, 2018 1:18 pm

Could you please send me also the new, for you working project file?
Then I can compare the project data, maybe that gives a hint...
Steinberg employee

User avatar
Ulf
Steinberg Employee
Posts: 1621
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Project launch stuck at 60%

Post by Ulf » Wed Jan 24, 2018 4:09 pm

Jonathan, thanks for the new data.
I compared the two and one major difference I saw was, that the sticking project is set up to use your Apollo Thunderbolt device, whereas the new, loading project is set up to use Built-in Audio.

Could it be that the Apollo is making trouble? How about if you make a copy of the now working project, then change that project to use the Apollo (Edit > Device Setup), save it, then close and open again? Does that work fine?
Steinberg employee

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: gdball, Makumbaria, pianoleo and 14 guests