Dorico 2 Pro - cannot get video import to work

Discussions about our next-generation scoring application, Dorico.
User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 12:03 am

Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro, which is a shame as i was hoping to be able to use the new features to score a film I'm working on while I'm forced to work on my laptop away from my main studio setup.

I've tried most of the recommended codec/container combinations listed on the Steinberg help page here: https://helpcenter.steinberg.de/hc/en-u ... and-Dorico including DV/DVCPro, MJPEG/PhotoJPEG, H264 and Avid DNxHD in the appropriate containers.

The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:
Screenshot 2018-06-23 23.50.27.png
blank video window in thumbnail
(85.8 KiB) Not downloaded yet
The strange thing is that the very same videos seem to to attach to a Cubase 9 Artist (9.0.30) project on the same machine with no issues whatsoever and play flawlessly. I was under the impression that both programs make use of the same video playback technology so at this point I'm stumped as to what the issue could be.

I'd really like to get this working before I fly out of the country on Monday, so if anyone has any suggestions about how to fix this problem I'd be very glad to hear them. :)

andgle
Member
Posts: 595
Joined: Wed Aug 10, 2016 6:36 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by andgle » Sun Jun 24, 2018 12:07 am

IIRC, the video will only be as long the flow it is attached to. Try adding a few more beats or measures
Anders

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 12:25 am

andgle wrote:
Sun Jun 24, 2018 12:07 am
IIRC, the video will only be as long the flow it is attached to. Try adding a few more beats or measures
Yeah I tried that already multiple times, added 50 bars to the flow, no difference.

pianoleo
Senior Member
Posts: 2475
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by pianoleo » Sun Jun 24, 2018 12:28 am

Are you in the right mode (Play mode) ?

I may be preaching to the choir here, but do read the instructions in the Version History here if you haven’t already: http://download.steinberg.net/automated ... istory.pdf
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius Ultimate, Logic Pro X, Dorico 2 etc.
& HP ZBook Studio G3 15.6” UHD quad-i7, 16gb RAM, Windows 10 Pro
Sibelius user since Sibelius 7 (Acorn, 1997), Ex-Sibelius user since Dorico 1.0

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 12:34 am

pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?

I may be preaching to the choir here, but do read the instructions in the Version History here if you haven’t already: http://download.steinberg.net/automated ... istory.pdf
I've been attaching it in Setup Mode directly onto the Flow itself, the video dialogue even comes up to let me set the framrate, timing offsets etc so I don't think that's the issue here.

Right now I'm considering just reinstalling Dorico from scratch and seeing if that resolves the problem.

-steve-
External Moderator
Posts: 7964
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by -steve- » Sun Jun 24, 2018 12:40 am

pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode.
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro[...]
That just looks totally wrong. Are you able to open the Video Properties window? What's in there?

Maybe the install is screwed up, uninstall/reinstall doesn't take much time, have you checked that?

Edit- we typed at the same time, lemme know how it goes. I'm using video in Dorico as we speak. What are you using to convert the video? I can share settings if you like.
Cubase Pro, Nuendo, and Dorico Pro; latest versions available.
Windows Pro 10 | i7-3770k | GA-77x-UD5h | 32 Gb | UR-RT2 | MOTU Ultralite mk3 hybrid
Macbook Pro 2011 | Mac OS 10.11
not a steinberg employee

-steve-
External Moderator
Posts: 7964
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by -steve- » Sun Jun 24, 2018 12:52 am

Here're the settings I used in Resolve for a video that attaches properly, and plays back, etc. (the audio is 48k PCM) Note the frame rate for the video and audio is constant, not variable. (but really, the reinstall seems a more likely fix.)
Attachments
2018-06-23 18_48_44-Ozod Youtube Video.png
(27.78 KiB) Not downloaded yet
Cubase Pro, Nuendo, and Dorico Pro; latest versions available.
Windows Pro 10 | i7-3770k | GA-77x-UD5h | 32 Gb | UR-RT2 | MOTU Ultralite mk3 hybrid
Macbook Pro 2011 | Mac OS 10.11
not a steinberg employee

pianoleo
Senior Member
Posts: 2475
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by pianoleo » Sun Jun 24, 2018 12:53 am

-steve- wrote:
Sun Jun 24, 2018 12:40 am
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode
Steve, I’ve never touched video in Dorico, but I did read and comprehend the documentation.

I’d like to suggest you do the same, preferably before shouting users down.

Dorico 2 Version History, Page 4.

“In Play mode, drag the video file from the folder where it is located and drop it on the timeline at the position where you want the video to be attached.”
Last edited by pianoleo on Sun Jun 24, 2018 1:08 am, edited 1 time in total.
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius Ultimate, Logic Pro X, Dorico 2 etc.
& HP ZBook Studio G3 15.6” UHD quad-i7, 16gb RAM, Windows 10 Pro
Sibelius user since Sibelius 7 (Acorn, 1997), Ex-Sibelius user since Dorico 1.0

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 1:06 am

-steve- wrote:
Sun Jun 24, 2018 12:40 am
pianoleo wrote:
Sun Jun 24, 2018 12:28 am
Are you in the right mode (Play mode) ?
Videos are attached in Setup mode, not Play mode.
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
Well I've tried everything I can think of but I just can't seem to get video import to work in Dorico 2 Pro[...]
That just looks totally wrong. Are you able to open the Video Properties window? What's in there?

Maybe the install is screwed up, uninstall/reinstall doesn't take much time, have you checked that?

Edit- we typed at the same time, lemme know how it goes. I'm using video in Dorico as we speak. What are you using to convert the video? I can share settings if you like.
Hi Steve,

Yes reinstalling is the option i'm seriously considering right now. I'm using a progam I've used for years called Pavtube HD Video Convertor for this and it's served me well before with getting videos into the correct format for Sibelius and Cubase. I also attempted re-rendering the video from inside Sony Vegas 14 to see if I had any more luck there.

I can certainly get the video properties box up and that's looks fine to my eyes (aside from the fps discrepancy):
video properties.png
(99.11 KiB) Not downloaded yet
I do have Dorico installed on my main machine as well so I'll see if I get the same behaviour there.

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 1:47 am

Ok, so after some testing I think I definitely need to reinstall Dorico 2 on my laptop as I managed to attach the video without issue on my desktop machine:
Dorico 2 desktop.png
(437.23 KiB) Not downloaded yet
The exact same video file gave me the result I described before on the laptop Dorico installation. I'll report back on how this goes.

<edit> Ok reinstalling didn't seem to solve the issue, but then I didn't trash my preferences or anything like that either... my previous files still showed up in the hub for instance. I'm wondering if I have to hose my system completely of the program before it'll work.

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Sun Jun 24, 2018 2:27 am

Ok so it looks like I've got it working again, although I'll have to redo all my preferences probably, or import them from my desktop setup.

Just in case anybody else comes across the same issue I basically uninstalled Dorico then deleted any related folders in the following locations (Windows 10):

C:\Program Files\Steinberg\Dorico 2
C:\Users\<username\AppData\Roaming\Steinberg\Dorico 2
C:\Users\<username>\AppData\Roaming\Steinberg\VSTAudioEngine2_64

I also cleaned up the registry a bit.

The video import is now running perfectly for me. :)
Last edited by Terry Jones on Sun Jun 24, 2018 2:27 am, edited 1 time in total.

-steve-
External Moderator
Posts: 7964
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by -steve- » Sun Jun 24, 2018 2:27 am

Great news.
Cubase Pro, Nuendo, and Dorico Pro; latest versions available.
Windows Pro 10 | i7-3770k | GA-77x-UD5h | 32 Gb | UR-RT2 | MOTU Ultralite mk3 hybrid
Macbook Pro 2011 | Mac OS 10.11
not a steinberg employee

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Thu Jul 19, 2018 4:35 pm

I'm sorry to say the problem keeps reoccurring for no good reason. I'll be working away just fine on a score with the same video for some time then suddenly when I decide to reopen my score in Dorico later on to do more work the video decides to stop working again... and no amount of restarting or rebooting the PC resolves it.

I'm getting a bit tired of having to fully uninstall Dorico, clear all the my preferences and any files then reinstall it all again just to get working video in my projects, there must be good reason this keeps happening (maybe a bug in video playback system) but I haven't figured it out yet.

<edit> Trying a different approach after doing a bit of research on Cubase video issues (as I imagine they use the same engine), I'm now busy converting the video to ProRes format using this tool: https://audiospot.audio/audiospot-creativetools

I'll report back on whether this works or not (without reinstalling Dorico).

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Thu Jul 19, 2018 9:04 pm

OK, so that didn't work. I'm really starting to think it's actually a random bug with the video engine in Dorico rather than anything I'm doing wrong as far as conversion goes, the same video file opens and plays perfectly in Cubase Artist 9.0.30. Ironically the last time I posted about this here the issue was on my laptop, this time it's on my main PC. ;)

I don't know if it's of any help as far as possible bug testing goes but i decided to go poking around in the files for both Cubase and Dorico and noted that videoengine.dll for each is slightly different:
videoengine.dll comparison.png
(23.64 KiB) Not downloaded yet
Whether this has a bearing on my issue I don't know, I'm not a programmer by trade, but I thought it was interesting nonetheless.

So I guess I'm going to have to do what I did last time; uninstall Dorico, trash all my preferences and start over again. This is only annoying because when everything is working as it should it's pretty much flawless, synchronisation is rock solid and navigating through the video using the shortcuts is quick and painless... just generally writing to film in Dorico is a joy. Hopefully whatever is going on here can be resolved eventually.

-steve-
External Moderator
Posts: 7964
Joined: Wed Dec 15, 2010 7:42 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by -steve- » Thu Jul 19, 2018 9:25 pm

I read through your posts about this, and I don't see anywhere that you tried re-attaching (aka re-importing) the video file. Have you done this?
Cubase Pro, Nuendo, and Dorico Pro; latest versions available.
Windows Pro 10 | i7-3770k | GA-77x-UD5h | 32 Gb | UR-RT2 | MOTU Ultralite mk3 hybrid
Macbook Pro 2011 | Mac OS 10.11
not a steinberg employee

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Thu Jul 19, 2018 9:31 pm

-steve- wrote:
Thu Jul 19, 2018 9:25 pm
I read through your posts about this, and I don't see anywhere that you tried re-attaching (aka re-importing) the video file. Have you done this?
Yes I tried multiple times in both the original project I was working on and in a completely fresh solo piano template from the default menu to make sure, it's the same issue every time. Currently reinstalling...

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Thu Jul 19, 2018 9:52 pm

Interestingly now I've reinstalled the ProRes video is showing up in the project but I only have audio, I'll try re-encoding to Avid DNxHD and see if that works any better.

<edit> Well I don't have a license for that codec but it certainly let me know that in the video window itself in Dorico, so I presume it would work in that case.
Avid DNxHD Notice.JPG
(139.63 KiB) Not downloaded yet
I'll try the H264 codec in the conversion tool I mentioned as a last resort before I go back to what I was using before the issue started.
Last edited by Terry Jones on Thu Jul 19, 2018 10:12 pm, edited 1 time in total.

arco
Junior Member
Posts: 121
Joined: Sat May 28, 2016 8:38 am
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by arco » Thu Jul 19, 2018 9:52 pm

When it fails, perhaps send the log so they can check.
Perhaps try another video converter (or try any video file from another source).

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Thu Jul 19, 2018 10:22 pm

arco wrote:
Thu Jul 19, 2018 9:52 pm
When it fails, perhaps send the log so they can check.
Perhaps try another video converter (or try any video file from another source).
I tried converting the original file again to the H264 codec in a .mov container using the same utility and now it's working fine, however it remains to be seen just how long it will keep working for this time... I'm not entirely convinced about the stability of the Dorico video playback engine yet.

User avatar
Daniel at Steinberg
Moderator
Posts: 9826
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Daniel at Steinberg » Thu Jul 19, 2018 11:17 pm

Sorry you're having these kinds of problems, Terry. Would it be possible for you to share the original file with us, for the purposes of troubleshooting? If so, please send it to me via WeTransfer (to d dot spreadbury at steinberg dot de) so I can ask the video engine team if they have any ideas.

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Fri Jul 20, 2018 12:26 am

Daniel at Steinberg wrote:
Thu Jul 19, 2018 11:17 pm
Sorry you're having these kinds of problems, Terry. Would it be possible for you to share the original file with us, for the purposes of troubleshooting? If so, please send it to me via WeTransfer (to d dot spreadbury at steinberg dot de) so I can ask the video engine team if they have any ideas.
Ah well, this is the thing, it's all working again now so I'm not sure me sending you the Dorico file will help that much as I replaced the original video with a newly encoded version. however I can if you like. It does use quite a few third party plugins (Kontakt and Engine mainly) and Noteperformer 3 as well though.

<edit> The file for the previous cue I was working on (which had similar issues to begin with) does still have the filename for the original video attached although the file itself has since been deleted, I could send that instead.

pianoleo
Senior Member
Posts: 2475
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by pianoleo » Fri Jul 20, 2018 4:04 am

I think I read on another thread that a) video paths should not contain unusual characters, b) should not be more than a certain number of characters (128 IIRC) and c) should be stored on a local drive, not a network location.

It was at least weeks ago if not months ago, and I’ve not done any research recently to back up these criteria, but just in case my memory is working properly you could double-check that your video file meets these three criteria...
Pianist/accompanist/engraver/arranger
Macbook Pro 13" Retina 3.1ghz i7, 8gb RAM; running Sibelius Ultimate, Logic Pro X, Dorico 2 etc.
& HP ZBook Studio G3 15.6” UHD quad-i7, 16gb RAM, Windows 10 Pro
Sibelius user since Sibelius 7 (Acorn, 1997), Ex-Sibelius user since Dorico 1.0

User avatar
Ulf
Steinberg Employee
Posts: 1075
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Ulf » Fri Jul 20, 2018 8:10 am

Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:

Screenshot 2018-06-23 23.50.27.png
Hi Terry,
pretty late, but it is just now that I read this thread. Looking at the screenshot, I think this is the same issue that I am sometimes running into. On the taskbar the video window gets shown as a small preview, but it does not appear on the screen, because it is shifted off-screen outside of the visible area. How it gets there? I have no idea, but this is how I get it back:

Hover with the mouse over the Dorico icon in the taskbar, so that the small preview video window appears. Move the mouse to the middle of it and do a right click. From the then appearing context menu choose 'Move'. The mouse cursor will change to an arrow pointing into all 4 directions (and will move somewhere to the edge of the screen). Now, press one of the cursor keys (up, down, left or right), but only once. The cursor shape will then change back to normal, but if you now move the mouse, the video window's position will follow the mouse cursor. Position it at a convenient location, make one left-click and the video window will stay.

Hope this helps.
Steinberg employee

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Fri Jul 20, 2018 9:41 pm

Ulf wrote:
Fri Jul 20, 2018 8:10 am
Terry Jones wrote:
Sun Jun 24, 2018 12:03 am
The ones that do attach to a project do not seem to want to play at all, in fact I just end up with a blank video window that I can't bring to the front of the project and which appears to be completely white:

Screenshot 2018-06-23 23.50.27.png
Hi Terry,
pretty late, but it is just now that I read this thread. Looking at the screenshot, I think this is the same issue that I am sometimes running into. On the taskbar the video window gets shown as a small preview, but it does not appear on the screen, because it is shifted off-screen outside of the visible area. How it gets there? I have no idea, but this is how I get it back:

Hover with the mouse over the Dorico icon in the taskbar, so that the small preview video window appears. Move the mouse to the middle of it and do a right click. From the then appearing context menu choose 'Move'. The mouse cursor will change to an arrow pointing into all 4 directions (and will move somewhere to the edge of the screen). Now, press one of the cursor keys (up, down, left or right), but only once. The cursor shape will then change back to normal, but if you now move the mouse, the video window's position will follow the mouse cursor. Position it at a convenient location, make one left-click and the video window will stay.

Hope this helps.
Hi Ulf,

Cheers, that's very interesting and yes that certainly what appears to be what's happening in my case when it does go wrong, I'll keep that one in mind if I run into the issue again. :)

Terry

User avatar
Terry Jones
Junior Member
Posts: 57
Joined: Tue May 17, 2016 10:25 pm
Contact:

Re: Dorico 2 Pro - cannot get video import to work

Post by Terry Jones » Mon Aug 20, 2018 9:18 pm

For the record I just had this issue pop up again (in Dorico Pro 2.1) and Ulf's advice worked just fine. I still find it very odd because it hasn't done that for ages and seems very random, but at least it's easy to correct now. :)

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: vertbois and 8 guests