Cubase 5.0

For users of legacy Steinberg Cubase software
Post Reply
brandon2521
New Member
Posts: 3
Joined: Sun Nov 18, 2018 5:38 pm
Contact:

Cubase 5.0

Post by brandon2521 » Sun Nov 18, 2018 5:46 pm

I've never used a VST in my life. But now I am ready. I don't want Cubase 10. I love my 5.0. My question is.... Will today's Vst's work with 5.0 or do I have to search eBay for older VST's?

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 6 guests