Latency is Unacceptable - 9.5

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
h20fam
New Member
Posts: 2
Joined: Mon Nov 19, 2018 12:42 am
Contact:

Latency is Unacceptable - 9.5

Post by h20fam » Mon Nov 19, 2018 12:49 am

I've used Cubase since SX, and ever since 7 I've had awful latency. Used to monitor live drums when recording with no problems. In fact, used Cubase as a live drum monitor for a band that opened for Wyclef among others. For whatever reason, the latency is now beyond awful using the same 10 year old plugins. Thought the constrain delay adjustments in 9.5 would help. They don't. I have a very fast computer and an RME Raydat running at 32 samples without issue. Even when I eliminate AISO guard and set the constrain delay to at .2 ms (basically only to allow the channel strips to work), the drums are noticeably behind. Way more latency than I should be experiencing at this buffer satting. I see I am not alone in this based on searches here. Does not appear to be an answer. Why is it that Steinberg cannot pull its head out and solve this problem? Looks like I'm going to have to sell 9.5 and move to a competing product. I apologize if I sound frustrated; it's because I am.

svennilenni
Grand Senior Member
Posts: 4300
Joined: Sat Nov 28, 2015 3:21 pm
Contact:

Re: Latency is Unacceptable - 9.5

Post by svennilenni » Tue Nov 20, 2018 2:00 pm

See your double post

User avatar
planarchist
Senior Member
Posts: 1661
Joined: Sat Sep 10, 2011 10:50 am
Location: UK.
Contact:

Re: Latency is Unacceptable - 9.5

Post by planarchist » Tue Nov 20, 2018 3:47 pm

This is not a general Cubase problem, no problems with low latency here over various manufacturers' interfaces.

If you want some suggestions from this forum I'd suggest you supply more information about your system.
Nic

Cubase Pro 10.5, Abs.Collec.3, i7 4770K 3.5GHz, 32 Gig RAM, Windows 10 Pro 64 bit, RME Digiface, Behringer ADA8200, S'berg Midex 8.
Cubase Pro 10.5. Abs.Collec.3, i7 920 2.67Ghz , 24Gig RAM, Windows 10 Pro 64 bit , Steinberg CI2+.

Cubase Elements 9.40 on Windows 10 Laptop, i7-2760QM 8Gig RAM, Sonic Port VX.
Cubasis 2.5 iPad Mini 4 64GB

User avatar
DLearyUS
Member
Posts: 324
Joined: Sun Nov 25, 2012 3:27 am
Contact:

Re: Latency is Unacceptable - 9.5

Post by DLearyUS » Tue Nov 20, 2018 8:41 pm

no problems here either....10 year old plugins? i assume they are 32bit? perhaps added latency introduced by a bridge plug? or possibly a old computer and/or your interface drivers? without more information on your system/interface its hard to make suggestions.
Cubase v10.5 Pro / Win10-64 Pro/ Tascam FW-1884+FE8+FE8 / ART TubeOpto8 Xpander

User avatar
Sonico
Junior Member
Posts: 87
Joined: Wed Dec 15, 2010 6:36 pm
Contact:

Re: Latency is Unacceptable - 9.5

Post by Sonico » Sun Nov 25, 2018 5:28 pm

O suppose you are referring to a VST drum module, try disabling ASIO guard for the plugin with high latency in the plugin manager? Or play with the ASIO Guard settings to see if it improves
Cubase Pro 10.5
Focusrite Clarett 8pre USB
Desktop: Windows 10 64bit, Intel Core i7 3.2 Ghz, 16 GB RAM.
Laptop: Windows 10 64 bit, Intel Core i7 1.8 Ghz, 16 GB RAM.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests