Dorico not starting up half of the time ...

Discussions about our next-generation scoring application, Dorico.
TootSweet
New Member
Posts: 24
Joined: Fri Jun 17, 2016 2:32 pm
Contact:

Dorico not starting up half of the time ...

Post by TootSweet » Thu Nov 29, 2018 1:51 pm

Very often, Dorico hangs when I start it and I have to force quit it and try again. This happens with version 2.1 and now with 2.2.

Any suggestion as to what I can do about this?

Thanks for your insights.

Toni

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Thu Nov 29, 2018 3:16 pm

Please do Help > Create Diagnostic Report from within Dorico, and attach the zip file that will be produced on your desktop to a reply in this thread.

User avatar
Andre
Senior Member
Posts: 1028
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico not starting up half of the time ...

Post by Andre » Thu Nov 29, 2018 3:51 pm

Unfortunately this happened to me as well today. After 3 times only a bouncing icon for a long time, I restarted the computer and tried again. It still took 2 tries before the program started.
Gothenburg, Sweden.
iMac 3 GHz Intel Core i5, 8 GB ram, macOS Mojave 10.14.6
Cubase X 10.9.40, Dorico 3 with NotePerformer 3.2.0
Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, etc etc...
Dutch is my native language. English 2nd, Swedish 3rd, Spanish 4th (but don't ask me to use it...)
My music and tutorials on http://www.andrevanharen.com

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Thu Nov 29, 2018 3:58 pm

And your diagnostic report zip file so that we can investigate is where, André...?

User avatar
Andre
Senior Member
Posts: 1028
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico not starting up half of the time ...

Post by Andre » Thu Nov 29, 2018 4:05 pm

let me check my pocketjes...

edit: the problem with these things is that it never happens when they "need" to so you can share it. Here is a report from the first time it started normally after the couple of times it didn't.
Attachments
Dorico Diagnostics.zip
(1.59 MiB) Downloaded 36 times
Gothenburg, Sweden.
iMac 3 GHz Intel Core i5, 8 GB ram, macOS Mojave 10.14.6
Cubase X 10.9.40, Dorico 3 with NotePerformer 3.2.0
Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, etc etc...
Dutch is my native language. English 2nd, Swedish 3rd, Spanish 4th (but don't ask me to use it...)
My music and tutorials on http://www.andrevanharen.com

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Thu Nov 29, 2018 4:14 pm

In the cases where Dorico is not starting up for you, it looks as if it's waiting for the eLicenser. I suggest you quit Dorico, run the eLicenser Control Center, and allow it to perform its default maintenance tasks. That should improve matters, and indeed will probably help the original poster, Toni, as well.

User avatar
Andre
Senior Member
Posts: 1028
Joined: Sat Jul 13, 2013 9:49 am
Location: Gothenburg, Sweden
Contact:

Re: Dorico not starting up half of the time ...

Post by Andre » Thu Nov 29, 2018 4:17 pm

Daniel at Steinberg wrote:
Thu Nov 29, 2018 4:14 pm
In the cases where Dorico is not starting up for you, it looks as if it's waiting for the eLicenser. I suggest you quit Dorico, run the eLicenser Control Center, and allow it to perform its default maintenance tasks. That should improve matters, and indeed will probably help the original poster, Toni, as well.
I did it just now and indeed Dorico opens much faster. Thanks!
Gothenburg, Sweden.
iMac 3 GHz Intel Core i5, 8 GB ram, macOS Mojave 10.14.6
Cubase X 10.9.40, Dorico 3 with NotePerformer 3.2.0
Logic Pro X. EWQLSO Gold, Kirk Hunter Diamond Orchestra/Concert Strings 2/Concert Brass 2, etc etc...
Dutch is my native language. English 2nd, Swedish 3rd, Spanish 4th (but don't ask me to use it...)
My music and tutorials on http://www.andrevanharen.com

TootSweet
New Member
Posts: 24
Joined: Fri Jun 17, 2016 2:32 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by TootSweet » Thu Nov 29, 2018 5:44 pm

Dorico Diagnostics.zip
(317.2 KiB) Downloaded 32 times
This is the Diagnostics file. Runny eLicenser maintenance seems to help somewhat: Dorico hang only once the last five times I started it.

PS: Version 2.2 is great - I especially like the new coda/repeat tools!

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Thu Nov 29, 2018 5:52 pm

Yup, your application.log files show the same scenario: Dorico is waiting for the eLIcenser in order to start up. Hopefully having run the maintenance tasks things will run more smoothly for you now.

User avatar
jamesppk
New Member
Posts: 46
Joined: Thu Aug 02, 2018 10:20 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by jamesppk » Thu Nov 29, 2018 9:46 pm

I have been having the same problem since 2.1. I tried the maintenance tasks for e-licenser and now it seems more prone to crashing on startup. Generally it starts 1 out of every 3 or 4 tries). It used to be the other way around. I attached a diagnostic report (.ZIP) after 3 unsuccessful attempt. The fourth worked and the file is attached. I'd love to know what I could do to avoid this problem in the future!

On another note, BRAVO! on 2.2. AMAZING WORK! Every item on my wish list was addressed. Dorico has been my primary notation software since 2.0 and now, I don't foresee workarounds for my needs. So nice! Thank You
Attachments
Dorico Diagnostics.zip
(305.14 KiB) Downloaded 28 times

User avatar
MarkSealey
Member
Posts: 706
Joined: Sat Aug 13, 2016 9:57 pm
Location: Valencia, California
Contact:

Re: Dorico not starting up half of the time ...

Post by MarkSealey » Thu Nov 29, 2018 10:16 pm

Strangely enough, so have I - after moving to Mojave - but also having installed the Mojave-specific update a couple of months back.

Have performed the e-licenser maintenance (twice). But Dorico still fails to launch 50% of the time.

Thanks for any ideas!
jamesppk wrote:
Thu Nov 29, 2018 9:46 pm
…I have been having the same problem since 2.1. I tried the maintenance tasks for e-licenser

Hear Hear!
jamesppk wrote:
Thu Nov 29, 2018 9:46 pm
On another note, BRAVO! on 2.2. AMAZING WORK!
--
Mark Sealey
Dorico 3.0.0.1038/Ivory II/VSL/NotePerformer 3/(Sibelius Ultimate, 18.5.0…) on 'Late 2014' Retina 5K iMac; 4 GHz i7; 32 GB RAM; Mojave, 10.14.6

User avatar
PaulWalmsley
Steinberg Employee
Posts: 1639
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Dorico not starting up half of the time ...

Post by PaulWalmsley » Thu Nov 29, 2018 10:36 pm

MarkSealey wrote:
Thu Nov 29, 2018 10:16 pm
Have performed the e-licenser maintenance (twice). But Dorico still fails to launch 50% of the time.
Mark, please follow the instructions that Daniel mentions above. We can't help you without that.
jamesppk wrote: James - I can see there's something in the audio engine that's crashing, so I've passed that on to Ulf
Architect & Developer - Steinberg London

User avatar
jamesppk
New Member
Posts: 46
Joined: Thu Aug 02, 2018 10:20 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by jamesppk » Thu Nov 29, 2018 11:22 pm

Thank you for the quick response! I can’t believe the customer service on these forums. INCREDIBLE!!

(and to think that Sibelius is only just now compatible with Mojave.) 2.2 dwarfs the Sibelius update. JUST AWESOME!

User avatar
MarkSealey
Member
Posts: 706
Joined: Sat Aug 13, 2016 9:57 pm
Location: Valencia, California
Contact:

Re: Dorico not starting up half of the time ...

Post by MarkSealey » Thu Nov 29, 2018 11:41 pm

Of course, Paul; thanks!

Attached a report from the most recent occasion on which Dorico launched…
PaulWalmsley wrote:
Thu Nov 29, 2018 10:36 pm
…Mark, please follow the instructions that Daniel mentions above. We can't help you without that…
Attachments
Dorico Diagnostics.zip
(520.18 KiB) Downloaded 30 times
--
Mark Sealey
Dorico 3.0.0.1038/Ivory II/VSL/NotePerformer 3/(Sibelius Ultimate, 18.5.0…) on 'Late 2014' Retina 5K iMac; 4 GHz i7; 32 GB RAM; Mojave, 10.14.6

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Fri Nov 30, 2018 12:51 am

Certainly several of those log files show the same symptom, i.e. that Dorico is waiting to hear from the eLicenser, and it's not. Can you please also try downloading and installing the latest version of eLicenser Control Center from here, then let it run its default maintenance tasks, and see if that makes any difference?

User avatar
PaulWalmsley
Steinberg Employee
Posts: 1639
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Dorico not starting up half of the time ...

Post by PaulWalmsley » Fri Nov 30, 2018 12:52 am

EDIT - Daniel beat me to it.

That does look very odd. As far as I can tell from that, it does appear to be the eLicenser initialisation that sometimes hangs. Have you tried rebooting, to clear any old processes that are hanging around? Do you have any other applications running?
Architect & Developer - Steinberg London

User avatar
MarkSealey
Member
Posts: 706
Joined: Sat Aug 13, 2016 9:57 pm
Location: Valencia, California
Contact:

Re: Dorico not starting up half of the time ...

Post by MarkSealey » Fri Nov 30, 2018 1:12 am

Thanks, Daniel, Paul :-).

In my case, I have the eLicenserControlSetup version 6.11.3.1242… updated the other day actually.

Whereas the actual eLicenser Control Center itself is version 2.8.2.0.

On 10.14.1 rebooting makes no difference.

Have certainly run the maintenance tasks (< 60 secs) and waited for the 'Close' button.

FWIW, I have both running in a subdirectory ('eLicenser') of /Applications; though if that were the issue, I'd expect it to fail every time.

No other audio processes - except NotePerformer, which is launched by Dorico, I believe.
--
Mark Sealey
Dorico 3.0.0.1038/Ivory II/VSL/NotePerformer 3/(Sibelius Ultimate, 18.5.0…) on 'Late 2014' Retina 5K iMac; 4 GHz i7; 32 GB RAM; Mojave, 10.14.6

User avatar
jamesppk
New Member
Posts: 46
Joined: Thu Aug 02, 2018 10:20 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by jamesppk » Fri Nov 30, 2018 1:31 am

For what it's worth, I updated the e-license app before commenting above...although it sounds like (from Paul's response) that in my case, it's not the issue.

TootSweet
New Member
Posts: 24
Joined: Fri Jun 17, 2016 2:32 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by TootSweet » Fri Nov 30, 2018 2:32 pm

I had the eLicenser updated and the problem persists ...
Attachments
Dorico Diagnostics.zip
(319.09 KiB) Downloaded 28 times

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Fri Nov 30, 2018 4:00 pm

For the time being I'm afraid I don't think there's a lot else we can do, but I will consult with the eLicenser team and come back to you. Sorry for the inconvenience.

User avatar
Ulf
Steinberg Employee
Posts: 1572
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Dorico not starting up half of the time ...

Post by Ulf » Fri Nov 30, 2018 4:37 pm

Just asking: Is that maybe the problem with the Sysnsopos on OSX 10.14. For the copy protection Dorico needs to start the Sysnsopos process and for security reasons the OS does not allow that and prompts you for it. Maybe that prompt is somewhere hidden behind some other window...?
Steinberg employee

TootSweet
New Member
Posts: 24
Joined: Fri Jun 17, 2016 2:32 pm
Contact:

Re: Dorico not starting up half of the time ...

Post by TootSweet » Fri Nov 30, 2018 5:29 pm

The prompt showed up during or after installation of the 2.2 update and I answered OK, just as I have done the last times when updating!?

User avatar
MarkSealey
Member
Posts: 706
Joined: Sat Aug 13, 2016 9:57 pm
Location: Valencia, California
Contact:

Re: Dorico not starting up half of the time ...

Post by MarkSealey » Fri Nov 30, 2018 6:42 pm

Ulf,

Thanks, but my experience is as TootSweet's: I accepted Dorico's 'request' the first time, expecting it and knowing what it was.

Since I cannot now launch Dorico at all reliably (diagnostics fro the last time I managed it attached…) - despite running eLicenser maintenance twice, should I try adding Dorico to either Accessibility or Full Disk Access, please?
Attachments
Dorico Diagnostics.zip
(518.62 KiB) Downloaded 29 times
Synopsos.png
(78.89 KiB) Not downloaded yet
--
Mark Sealey
Dorico 3.0.0.1038/Ivory II/VSL/NotePerformer 3/(Sibelius Ultimate, 18.5.0…) on 'Late 2014' Retina 5K iMac; 4 GHz i7; 32 GB RAM; Mojave, 10.14.6

User avatar
Ulf
Steinberg Employee
Posts: 1572
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Dorico not starting up half of the time ...

Post by Ulf » Fri Nov 30, 2018 8:14 pm

MarkSealey wrote:
Fri Nov 30, 2018 6:42 pm
Since I cannot now launch Dorico at all reliably (diagnostics fro the last time I managed it attached…) - despite running eLicenser maintenance twice, should I try adding Dorico to either Accessibility or Full Disk Access, please?
To be honest, I don't know, I am not so familiar with Mac, especially not with 10.14.
But must be an OS thing, because we did not have such problems before 10.14.
Steinberg employee

User avatar
Daniel at Steinberg
Moderator
Posts: 13928
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Dorico not starting up half of the time ...

Post by Daniel at Steinberg » Fri Nov 30, 2018 9:10 pm

No, adding Dorico to Full Disk Access and Accessibility won't do anything to help.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: Andre and 8 guests