Imported audio sync'd at start but slowly drifts out of time

For users of legacy Steinberg Cubase software
Post Reply
jlofling
New Member
Posts: 33
Joined: Fri Jan 07, 2011 6:28 pm
Contact:

Imported audio sync'd at start but slowly drifts out of time

Post by jlofling »

I recently multi-tracked a live show which required the use of an additional un-synchronized recorder. I used a buddy's Korg D3200 to record an additional 6 tracks of 44.1kHz/24bit WAV files. I figured if I recorded in 44.1kHz/24bit within Cubase, I would only have to sync the additional 6 tracks once at the beginning and that everything would remain in sync.

Unfortunately this does not seem to be the case. After importing I can easily sync the beginning of the project, but ~20 minutes into the show you can begin to tell that it has drifted. After an hour into the set, it's close to half a second off. The drift seems to be in the negative direction, that is events are coming in early, relative to the natively recorded Cubase tracks.

I opened the pool and noticed all imported audio has "elastique Pro - Time" under Algorithm and a slightly different tempo, (120.05 vs. default 120.00 for the native tracks). Changing the algorithm to "Standard - Mix" to match the native recordings does not appear to have an affect, nor does matching the tempo (note that none of the audio files are in Musical Mode, but my imported tracks do change position if I play with the project tempo).

I'm not sure why a time stretching algorithm is even being applied to my imported audio. Does anyone have an idea as to what it going on? Fortunately, the additional tracks only contain ancillary audio that only need to be present every now and then, but having to re-sync things numerous times will be kind of annoying, and I'd like to know what I'm missing.

Thanks.

jlofling
New Member
Posts: 33
Joined: Fri Jan 07, 2011 6:28 pm
Contact:

Re: Imported audio sync'd at start but slowly drifts out of time

Post by jlofling »

Okay, I've done some more digging/searching and think my problem is related to the fact that my imported audio is being automatically time stretched (elastique algorithm being applied). It seems this is supposed to happen when WAV files are saved in the ACID format (ACID'ized); however, I doubt this is the issue in my case as the Korg D3200 doesn't support this option. Plus this also happens to my FOH stereo crowd track which gets converted by Cubase from a 44.1kHz 320kbps MP3 file.

Importing these audio files into an empty project results in the same issues. Does anyone know why Cubase thinks these WAV files are different? Perhaps I can open them in some other editor and re-save them, stripping any metadata that may be confusing Cubase.


EDIT - I fired up good old Cubase 4 and the same thing happens there as well.

thinkingcap
Grand Senior Member
Posts: 6459
Joined: Tue Dec 21, 2010 3:27 pm

Re: Imported audio sync'd at start but slowly drifts out of time

Post by thinkingcap »

and have you already tried to simply set the tracks with the 120.5 bpm tempo to 120 bpm like the other ones. If the tracks are really timestretched, then setting all to the same tempo (which should be the current project tempo) should solve this
Cubase 5.1.1 (32bit) | Win 7 Pro x64 SP1 | RME Fireface UFX | RME Fireface 800 | Cubase Essential 5 | Win 7 Home Premium x64
-------------------------------------------------------------------------------------------------------------------------------------------
I just took off my thinkingcap, it got filled up with too much crap...

djaychela
Member
Posts: 319
Joined: Thu Dec 16, 2010 4:22 pm
Contact:

Re: Imported audio sync'd at start but slowly drifts out of time

Post by djaychela »

I think you're overcomplicating this.

The key is in the fact that the recorders were unsynchronised, and that being the case it's quite possible that they will drift over time - each recorder may be recording 44100 samples per second, but each one's idea of how long a second is may vary. I've never had a time when I've recorded with unsynched devices (be it video or audio) that haven't needed treatment to get them to be in time over any significant period - finding a sync point at the end of them and timestretching to suit that does the trick, although obviously there are phase issues to take into account whenever you do something like this (not that you can do much about really other than mix-wise, just worth thinking about particularly when planning your recordings).

jlofling
New Member
Posts: 33
Joined: Fri Jan 07, 2011 6:28 pm
Contact:

Re: Imported audio sync'd at start but slowly drifts out of time

Post by jlofling »

djaychela wrote:I think you're overcomplicating this.

The key is in the fact that the recorders were unsynchronised, and that being the case it's quite possible that they will drift over time - each recorder may be recording 44100 samples per second, but each one's idea of how long a second is may vary.
I was wondering how well two separate 44.1kHz/24-bit files from two different clocks would sync up. I think you're right about this being the sole reason for the drift.

I went ahead and created a new project, imported the original natively recorded audio tracks (tracked directly into cubase) and they also get the "elastique Pro - time" algorithm assigned rather than the "Standard - Mix" setting they had in the source project. It seems that Cubase automatically assigns a time-stretching algorithm to all imported audio files just in case you plan on setting the tracks to musical mode. I don't think any stretching is actually occurring in my case.

Fortunately, these additional tracks will not be used in their entirety, so the project isn't a bust. I'll just have to periodically manually re-sync them. Thanks for clearing things up for me.

amberstone
New Member
Posts: 2
Joined: Thu Mar 13, 2014 3:23 pm
Contact:

Re: Imported audio sync'd at start but slowly drifts out of

Post by amberstone »

Hi/Did anybody have a solution to is?
I have the same version of Cubase 5 installed on a laptop and a PC - when importing a wav file (recorded at 116 bpm) to the laptop it syncs fine, but when importing the same wav file to my PC, I have to alter the tempo of the track to 116.045 for it to sync correctly! Any ideas??? Help! I'm supposed to be going to a mastering studio in 5 days time!!

Thanks. Paul

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 4 guests