How to connect Yamaha P-95 keyboard to Cubase

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
kenneho
New Member
Posts: 13
Joined: Sat Jun 20, 2015 2:48 pm
Contact:

How to connect Yamaha P-95 keyboard to Cubase

Post by kenneho » Fri Dec 21, 2018 8:33 pm

Hi.



I'd like to use my Yahama P-95 keyboard for midi recording in Cubase, but can't get it to work properly. I've connected the keyboard to my computer using this cable: https://evenstadmusikk.no/omnitronic/10 ... -interface

In Cubase, I create a new track (not intrument track, but the other one, can't seem to recall the name at the moment), press record, and start playing the keyboard, and see that nothing gets recorded.

I'm pretty new to connecting external devices to Cubase,

A few questions:
  • According to viewtopic.php?t=96064, I should be able to verify that Windows recognizes my keyboard. How do I do that?
  • I didn't find Yamaha P-95 in the devices list in Cubase. Are there any drivers or something I need to install to get this working?
  • May it be that the cable I'm using somehow is not compatible with the keyboard?
Any input on how to get this up and running will be highly appreciated.

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by Prock » Sat Dec 22, 2018 2:14 am

A few thoughts/suggestions for you...

- You really should list what your computer OS is and what version of Cubase you are running.
- Connect your keyboard to your computer. Turn it on. If on a windows PC you should hear or see something that shows that the computer automatically installed a driver for it and it is ready for use.
- Start Cubase
- Set your keyboard to "Local Off". See page 26 in the op manual (link provided) for the procedure to do this.
- Add an "Instrument Track" to your project.
- In the inspector section of your instrument track, click on the arrow to the left of the track name. It will drop down. Choose "All midi inputs" for the input routing field, and assign a VST Instrument (like Halion Sonic SE) in the instrument field.
- Still in the inspector just below and to the right of the instrument field, click on the edit instrument button. This will bring up the Halion Sonic SE edit screen. Choose a sound from what is available.
- Now click on the track "Record Enable" and "Monitor" buttons.
- Play your keyboard and hear the lovely sounds. Hit the record button and record something.
- Disable the track "Record Enable" and "Monitor" functions to hear your recording (this may not be required depending on what CB version you have).

Hope I didn't miss any steps. Have fun.

If you connected the cable properly (again, see the op manual) this should work. No drivers to install manually. Windows should do this automatically.

https://tomzap.com/tomzaptheband/equipm ... Manual.pdf

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

-steve-
External Moderator
Posts: 9007
Joined: Wed Dec 15, 2010 7:42 pm

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by -steve- » Sat Dec 22, 2018 3:15 am

We really do need a thanks or thumbs up button here!
independent manufacturer rep
cubase pro, nuendo, and dorico pro; latest versions
windows pro 10 | i7-3770k | ga-77x-ud5h | 32 Gb | UR-RT2 | k-mix audio interface
hp spectre x360 2018 | 16 Gb

kenneho
New Member
Posts: 13
Joined: Sat Jun 20, 2015 2:48 pm
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by kenneho » Sat Dec 22, 2018 11:32 am

Prock wrote:
Sat Dec 22, 2018 2:14 am
A few thoughts/suggestions for you...

- You really should list what your computer OS is and what version of Cubase you are running.
- Connect your keyboard to your computer. Turn it on. If on a windows PC you should hear or see something that shows that the computer automatically installed a driver for it and it is ready for use.
- Start Cubase
- Set your keyboard to "Local Off". See page 26 in the op manual (link provided) for the procedure to do this.
- Add an "Instrument Track" to your project.
- In the inspector section of your instrument track, click on the arrow to the left of the track name. It will drop down. Choose "All midi inputs" for the input routing field, and assign a VST Instrument (like Halion Sonic SE) in the instrument field.
- Still in the inspector just below and to the right of the instrument field, click on the edit instrument button. This will bring up the Halion Sonic SE edit screen. Choose a sound from what is available.
- Now click on the track "Record Enable" and "Monitor" buttons.
- Play your keyboard and hear the lovely sounds. Hit the record button and record something.
- Disable the track "Record Enable" and "Monitor" functions to hear your recording (this may not be required depending on what CB version you have).

Hope I didn't miss any steps. Have fun.

If you connected the cable properly (again, see the op manual) this should work. No drivers to install manually. Windows should do this automatically.

https://tomzap.com/tomzaptheband/equipm ... Manual.pdf

Regards 8-)
Thanks for the excellent reply!

I'm running Cubase LE AI Elements 8 (trial version for now) on Windows 10.

I followed your suggested steps, but still no MIDI activity registered in Cubase. This is what I tried:
  • Started the Windows computer, and connected my FocusRite Scarlett soundard
  • Connected the Yamaha P-95 keyboard. Verified that the entry "USB2.0-MIDI" showed up in Windows's "Device manager" under the "Sound- and video controllers" (or whatever it's named in English Windows) section. Also got a notification from Windows that the device was configured correctly
  • Set the keyboard to "Local Off". Verified that no sound is output through the keyboard's build-in speakers
  • Started Cubase
  • Added an instrument track, selected "All midi inputs" for the input routing field, and selected "Halion Sonic SE" in the instrument field.
  • Clicked the "Record Enable" and "Monitor" buttons
Still there is no sound when pressing the keyboard keys.

A couple of things I noticed:

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by Prock » Sat Dec 22, 2018 5:14 pm

A few more simple things to check...

- Looks like you are but... make sure you are starting Cubase after you turn on the keyboard and your PC recognizes it.
- Make sure your track is not mistakenly muted.
- Go to the Cubase File>Preferences>MIDI menu and ensure that the "MIDI thru Active" option is enabled.
- Make sure you chose an instrument sound in Halion Sonic SE.
- Make sure that the Halion Sonic SE (HSSE) instrument is active and not bypassed. The "Activate Effect" button is at the top left of the HSSE edit panel. When active it will be blue colored.
- Make sure the gain (volume) control in the mixconsole for that instrument track is set high enough.

Also, you are not using this as an external midi device. So it would not show up in the MIDI Device manager.

One last thing... All of my instructions assumes that your audio interface is setup/connected properly. if it not, you will most likely not hear anything (but you should still see the midi activity in Cubase).

What is you audio interface?

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

kenneho
New Member
Posts: 13
Joined: Sat Jun 20, 2015 2:48 pm
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by kenneho » Sun Dec 23, 2018 4:10 pm

Prock wrote:
Sat Dec 22, 2018 5:14 pm
A few more simple things to check...

- Looks like you are but... make sure you are starting Cubase after you turn on the keyboard and your PC recognizes it.
- Make sure your track is not mistakenly muted.
- Go to the Cubase File>Preferences>MIDI menu and ensure that the "MIDI thru Active" option is enabled.
- Make sure you chose an instrument sound in Halion Sonic SE.
- Make sure that the Halion Sonic SE (HSSE) instrument is active and not bypassed. The "Activate Effect" button is at the top left of the HSSE edit panel. When active it will be blue colored.
- Make sure the gain (volume) control in the mixconsole for that instrument track is set high enough.

Also, you are not using this as an external midi device. So it would not show up in the MIDI Device manager.

One last thing... All of my instructions assumes that your audio interface is setup/connected properly. if it not, you will most likely not hear anything (but you should still see the midi activity in Cubase).

What is you audio interface?

Regards 8-)
Thanks again for you help. First, let me add that I just upgraded to Cubase Elements 10 Full Version. In addition, since I'm now a paying customer I decided to register a support ticket. With that said, I greatly appreciate the help I'm getting here, and hopefully I'll get things working even before Steinberg support gets to review the ticket. Getting Cubase and the keyboard up and running is actually a christmas present for my wife, so I'm crossing my fingers I'll get it working by tomorrow afternoon. If you or anyone still decide to help me out I really appreciate it, but fully understand if you don't considering I've already issued a ticket at Steinberg.

Anyways, let me answer your questions above. I've waited for my computer to recognize the keyboard (both gotten the Windows notification about the event, and checked the device manager that the USB2.0MIDI or whatever it's called device is present). I've enabled the "Local mode" setting on the keyboard, which mutes the keyboard internal monitors. In Cubase, I've checked that the track is not muted. "MIDI thru Active" is enabled. I've chosen an instrument in Halion Sonic SE, and ensured that the "Activate Effect" is blue. All the sliders in the mixing console is in their default settings (about 70% volume or so).

Still there is no MIDI activity.

I'm using the Focusrite Scarlett 2i2 (https://focusrite.com/usb-audio-interfa ... arlett-2i2) interface. When I open a browser an play for instance YouTube videos, the Focusrite is working properly and the sound is coming from my studio monitors.

This is really a puzzle. Might it be that the cable I'm using to connect the keyboard to the computer somehow is not compatible, even though Windows says it has configured the device properly? I've seen some people referring to the Yamaha UX16 (https://usa.yamaha.com/products/musical ... index.html) adapter cable, which has the box in the middle that my current cable does not: https://evenstadmusikk.no/omnitronic/10 ... -interface

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by Prock » Sun Dec 23, 2018 9:26 pm

It is that cable you are using. Apparently your cable does not have the converter box. Sorry I did not notice it at first. You need a midi to USB converter cable (like the UX16) as shown in your OP manual on page 24.

Regards. 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

kenneho
New Member
Posts: 13
Joined: Sat Jun 20, 2015 2:48 pm
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by kenneho » Mon Dec 24, 2018 1:16 pm

Prock wrote:
Sun Dec 23, 2018 9:26 pm
It is that cable you are using. Apparently your cable does not have the converter box. Sorry I did not notice it at first. You need a midi to USB converter cable (like the UX16) as shown in your OP manual on page 24.

Regards. 8-)
Ah, thanks! I came across the Roland UM-ONE MK2 (http://eg.roland.com/products/um-one_mk2) USB MIDI interface, which is half the price of the Yamaha UX16. Do you know if the Roland is compatible with my equipment? If so, is there any reason not to go for the Roland one instead of the Yamaha one?

User avatar
Prock
Grand Senior Member
Posts: 3772
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by Prock » Mon Dec 24, 2018 3:10 pm

Roland is a good brand name so I would think it is compatible. I too thought the UX16 was way over priced so I used this one https://m-audio.com/products/view/uno for years without any issue until my old PSR 38 keyboard crapped out. My replacement keyboard has USB to USB midi so that type of cable is not required.

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.0.40, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

kenneho
New Member
Posts: 13
Joined: Sat Jun 20, 2015 2:48 pm
Contact:

Re: How to connect Yamaha P-95 keyboard to Cubase

Post by kenneho » Mon Dec 24, 2018 8:55 pm

Prock wrote:
Mon Dec 24, 2018 3:10 pm
Roland is a good brand name so I would think it is compatible. I too thought the UX16 was way over priced so I used this one https://m-audio.com/products/view/uno for years without any issue until my old PSR 38 keyboard crapped out. My replacement keyboard has USB to USB midi so that type of cable is not required.

Regards 8-)
Thanks once again for you excellent help! I've just placed an order for the Roland interface. Crossing my fingers it's compatible with my equipment!

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 7 guests