ASIO issue Wavelab Pro 9.5

Post questions and find answers on our latest WaveLab releases here.
Post Reply
Leif Anders
New Member
Posts: 5
Joined: Tue Dec 11, 2018 8:21 pm
Contact:

ASIO issue Wavelab Pro 9.5

Post by Leif Anders » Tue Mar 26, 2019 7:53 pm

ASIO driver using Dante i/o can not handle Sample rate changes. I.E. 48K is my default but when using file browser to preview a 44.1 or an open 44.1 music track - the wavelab driver balks at the sample rate change and will not play anything other than 48K files. Adobe audtion as an example (older version too) can easily transition sample rates under ASIO and the same Dante hardware.
How is it the Company that brought us ASIO doesn't handle this?
I must use the MME driver in this Windows 10 workstation to get all the functionality of Wavelab.

PG
Moderator
Posts: 6641
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by PG » Tue Mar 26, 2019 8:42 pm

Maybe Audition is using a resampling stage, rather than changing the driver sample rate.
Are you sure your Dante driver is not set in mode 'external clock'?
Philippe

S-EH
Member
Posts: 356
Joined: Sat Dec 18, 2010 12:47 pm
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by S-EH » Tue Mar 26, 2019 10:05 pm

What brand with Dante interface are you using !?

regards S-EH
RME Fireface 800, WaveLab, Cubase...

User avatar
bobybayo
New Member
Posts: 48
Joined: Thu Feb 02, 2017 12:47 am
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by bobybayo » Wed Mar 27, 2019 1:20 am

Leif Anders wrote:
Tue Mar 26, 2019 7:53 pm
ASIO driver using Dante i/o can not handle Sample rate changes. I.E. 48K is my default but when using file browser to preview a 44.1 or an open 44.1 music track - the wavelab driver balks at the sample rate change and will not play anything other than 48K files. Adobe audtion as an example (older version too) can easily transition sample rates under ASIO and the same Dante hardware.
How is it the Company that brought us ASIO doesn't handle this?
I must use the MME driver in this Windows 10 workstation to get all the functionality of Wavelab.
Leif, my experience with WL and ASIO is that WL works better the it runs the clock. My audio card is set to internal clock so when WL detects a different sample rate it changes the card clock. Works very nice. I tried using external (better clocks) and it was a nightmare. My 2 cents.
Robert
Robert Bayona
Bayona Mastering
Puerto Rico

Leif Anders
New Member
Posts: 5
Joined: Tue Dec 11, 2018 8:21 pm
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by Leif Anders » Sat Mar 30, 2019 11:55 pm

Thanks for the replies -
It's true unfortunately Dante controller will not allow me to set the internal clock to Grand Master. Dante Via and Dante Virtual Soundcard are essentially the interface. Only the external Audinate and Rednet devices can be set to master and they are all at 48k, so the issue lies with Audinate's Dante than with Wavelab. I believe Adobe audition is doing some resampling as how else could it work with both 48k files and 44.1? Both sample rates will play or record in Audition when Wavelab will complains the soundcard is in slave mode. When I check the ASIO setting in Wavelab Audio device control Panel the Sample rate option in Dante Via ASIO Control panel shows 4800 which is grayed out and otherwise locked. Same is true when checking Adobe Audition's ASIO control panel. Dante Via is locked at 48K But Audition works at any sample sample rate, which is very cool but I can't explain. I only wish Wavelab was as flexible. If I bring in a 44.1 file to Wavelab, it will import the file but does not resample. It just screws up the pitch instead.
Thoughts?

User avatar
Arjan P
Senior Member
Posts: 2523
Joined: Wed Dec 15, 2010 6:28 pm
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by Arjan P » Sun Mar 31, 2019 1:02 am

I also use an interface that's not easily changed from whatever I'm on. Therefor I use a resampler in the WL Playback Processing slot so I can quickly have WL play back whatever sample rate I wanna check out. It's a workaround and I don't use it for critical listening but it's quick and easy..
--- "If anyone owes it all to Bach, it's God" - Emil Cioran ---
SOFT: (All 64 bit) | WaveLab 9.5.50 | Cubase 10.0 | HALion 6.0 | Win10 Pro - SoundCloud
HARD: i7-950 | Asus P6TD | 30GB | Tascam DM-3200 | DigiMax48 | Midisport 8x8 - SoundByte Studio

Leif Anders
New Member
Posts: 5
Joined: Tue Dec 11, 2018 8:21 pm
Contact:

Re: ASIO issue Wavelab Pro 9.5

Post by Leif Anders » Mon Apr 01, 2019 4:27 pm

That's a great work around. Thanks for pointing that out. Works well for my needs however it doesn't help when using the file browser preview feature. In a perfect world... :)

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 4 guests