WHD 517DX hi hat triggers rogue midi notes

Use this forum for an overview of issues and to report new ones.
Post Reply
Instructor750
New Member
Posts: 2
Joined: Wed Oct 30, 2019 6:52 pm
Contact:

WHD 517DX hi hat triggers rogue midi notes

Post by Instructor750 »

I am hoping there is someone in this gathering of Cubase users who can help with this very frustrating problem?
A year ago I purchased a WHD 517DX e-drum kit. When recording in audio mode, everything works and sounds perfectly.
However, when trying to record via MIDI into Groove Agent (Cubase Pro 10), no matter what kit I select, when the hi hat pedal is roughly half-way up/down and the hi hat pad is simultaneously hit, (from a gentle tap to full strike), it triggers the snare, kick and Tom 1 together. Using the hi hat pedal on its own produces the correct sound when pressed (closing hi hat) and striking the hi hat pad with no pedal produces the correct sound of hi hat open.Holding the pedal down and striking the pad also produces the correct sound of closed hi hat. In desperation I sent the pedal, pad and module back to the manufacturer who eventually sent me replacement parts. In the meantime I purchased a 2nd e-drum kit Alexis Nitro Mesh and have not experienced the same issue at all.
However, apart from this one annoying problem, I prefer to play the WHD kit as the pads are bigger and feel more akin to my old acoustic kit. Has anyone experienced this problem and, if so how did you resolve it? Short of using the Alexis module to operate the hi hat and pedal only, I would really like to use the WHD kit in its entirety. Thank you in advance for any help with this.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: Rycar and 4 guests