SOLVED BY HOTFIX UPDATE: Cubase Elements 10.5.10 update not recognizing UAD Arrow

Use this forum for an overview of issues and to report new ones.
Post Reply
t_rattle
New Member
Posts: 3
Joined: Wed Apr 23, 2014 11:03 pm
Contact:

SOLVED BY HOTFIX UPDATE: Cubase Elements 10.5.10 update not recognizing UAD Arrow

Post by t_rattle »

I recently purchased Elements 10.5 a couple of days ago. Getting it set up and working right with my Universal Audio Arrow was straightforward and everything was proceeding nicely until this afternoon when I notice that there was already an update for me to download, 10.5.10. So I did what I thought was the right thing, I downloaded, installed it and now Elements won't even give me the option of selecting the Arrow as my stereo input and output device! I also have Reaper on my laptop (a Macbook Pro running High Sierra 10.13.6) so as a troubleshooting measure I fired that up with an existing project and sure enough, the Arrow works just fine with Reaper. iTunes also I checked and it was playing everything like normal through the Arrow.

So, clearly the bug is with this new update. Is there anyone here than can help me solve this problem? {Thank you *Steinberg*, why are you always so damn buggy? :x }

t_rattle
New Member
Posts: 3
Joined: Wed Apr 23, 2014 11:03 pm
Contact:

Re: SOLVED BY HOTFIX UPDATE: Cubase Elements 10.5.10 update not recognizing UAD Arrow

Post by t_rattle »

So today's 10.5.11 update happily eliminated whatever bug or fixed whatever the problem was with the previous update. Nice :D

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest